Emoncms V10.2.2 release + .org upgrade

Recent changes to emoncms master and associated modules have now been merged to stable and are now available via emonPi/emonbase update.

This release is marked as v10.2.1: Release v10.2.1 路 emoncms/emoncms 路 GitHub

Thankyou to everyone who contributed to development associated with this release!

:tada: :tada: :tada:

To update: run emonPi/emonbase update from the Admin tab of emoncms.


CHANGE LOG SUMMARY

Emoncms core 10.2.1:

  • fix redis buffer issue that did not show latest data in graphs where redis buffer is enabled
  • fix database update issue, thanks @emrys
  • log invalid auth attempts to emoncms.log
  • fix js error on deleting empty feed, thanks @hutorny
  • improved appearance of php modules in admin interface @gablau
  • new rpi models in admin interface @gablau
  • option to get feed id via tag and name in feed API
  • Stacked and Stacked solar view automatically covers available data rather than full 5 years.
  • Improved MQTT topic filter
  • Automatic logout if session expires on input and view UI
  • Fix to PI4 to show shutdown button, thanks @emrys
  • fixed emailer function to support swiftmailer v5.4.8 and different installation location
  • improved error reporting on password reset
  • improved feed unit filter to allow special chars, thanks @emrys
  • updated Italian language files, thanks @gablau
  • Virtual feed user identification fix for public dashboards (Needs further review).
  • Disable logging of invalid apikeys, thanks @MyForest
  • Fix to issue with empty values in vis/realtime, thanks @emrys
  • urlencode referer parameter user for user/login, thanks @emrys

*BREAKING CHANGE: The new MQTT topic filter provides better support for a larger variety of topic formats but it can result in broken inputs which will need re-mapping. See Emoncms v10.2.1 New MQTT Topic Filter Issue - #8 by borpin.

Emoncms core 10.2.2 (minor update 18th April 2020):
Merge to stable by TrystanLea 路 Pull Request #1555 路 emoncms/emoncms 路 GitHub

  • Fixes missing emoncms log window
  • Allow height of input row to expand when multiple lines of processes
  • Fix sidebar divider, thanks @hutorny
  • Support for schemas with compound key, thanks @hutorny
  • Fix handling of missing feeds @hutorny
  • Fix footer margin
  • Note deprecated visualisations
  • Spelling and missing semicolon @Twincarb
  • Admin user list, view user button @Twincarb

Dashboard module v2.0.7

  • Conditional colour formatting for feed value widget, thanks to @thib66
  • Rotated triangle symbols to visualize pump operation, thanks to @Ogyb
  • Fix issue relating to html chars in dashboard, thanks @emrys

Config module v2.0.5

  • fix emonhub restart button
  • open documentation in new window, thanks a @danbates

App module v2.1.1

  • Fix Octopus Agile legend, thanks to @MyForest
  • Make Octopus Agile import feed optional

Device module v2.0.5

  • Device template examples thanks to @MyForest
  • Auto reload devices to redis to fix devices already exist errors

Backup Module v2.2.2

  • Support additional USB drives in USB import script
  • Remove /home/pi paths and hardcoded pi user
  • Check that log files exist before trying to load into UI
  • Strip out # comments from ini file

DemandShaper Module v1.2.4

  • Preparation for multi-user support on servers that use MQTT access lists and authentication.
  • Use basetopic from settings file
  • Updated documentation, smartplug guide moved to OEM guide
  • Cost per kWh added to OpenEVSE UI thanks @WeeBull
  • Fixed OVMS state of charge request
  • Option to change device name
  • Automatically recalculate schedule based on updated SOC including balancing time.

Sync Module v2.0.4

  • fix feed tag & name support
  • urlencode feed names
  • additional feed parameter checks

Usefulscripts: Option to run SDS011 air-quality sensor service via docker, thanks to @glyn.hudson


The total number of open bugs on all emoncms repositories including modules is now 35 and can be tracked here: https://github.com/issues?q=is%3Aopen+is%3Aissue+user%3Aemoncms+label%3Abug


To update: run emonPi/emonbase update from the Admin tab of emoncms.

4 Likes

Top work highfive

1 Like

4 posts were split to a new topic: Emoncms v10.2.1 New MQTT Topic Filter

I noticed a bug in the Sync module upload function that I鈥檝e now fixed. I鈥檝e also added a 鈥楧ownload All鈥 and 鈥楿pload All鈥 button to make this easier. I鈥檝e merged this feature into stable and tagged v2.0.5.

I use the Sync module to backup the feeds on my home pi to an instance of emoncms running on my Ubuntu laptop. Using the upload feature to do this from the pi means I don鈥檛 have to have any emoncms services running on my main computer, it just needs to be a basic emoncms installation.

Emoncms.org is now also up-to-date with the current release Emoncms.org Upgraded to V10.2.1

What鈥檚 the easiest way to manually update - I鈥檓 running on a Debian PC and get this message after clicking the update button

  Starting update via service-runner-update.sh (v3.0) ><br />
- emonSD version: emonSD-15Jan2018<br />
emonSD-17Jun2015<br />
ERROR: emonSD base image old or undefined...update will not continue<br />
See latest verson: https://github.com/openenergymonitor/emonpi/wiki/emonSD-pre-built-SD-card-Download-&-Change-Log<br />
Stopping update</details><br />

How did you install?

@TrystanLea emonSD base image old or undefined if undefined I think the update should continue as it is clearly not a Pi image.

From memory I ran the EmonScripts using the Debian instructions.

Ok, great so a newish install. What version does it currently say?

I just tried it on my Ubuntu install and it was OK. We did change some things around this so maybe the base update script is not updating first.

Try

cd /opt/openenergymonitor/EmonScripts
git pull

And then run the update.

1 Like

I think that might be unlikely, that would raise a question over where the 2 image dates of emonSD-15Jan2018 and emonSD-17Jun2015 come from in the error message.

I suspect the version file may have been corrupted or edit to facilitate a previous update and perhaps there are 2 images listed in the file, hence the content doesn鈥檛 match any single date and doesn鈥檛 proceed.

An install via the scripts on Debian does not put anything in /boot or shouldn鈥檛 if the pienv variable is set correctly.

@kevin - just check /boot for a file 'emonSD` - it shouldn鈥檛 be there.

I don鈥檛 doubt that, but where would a date of 2015 spring up from on a install created via a script born in 2019? Maybe it isn鈥檛 an emonScript install?

Where is the version kept on a Debian based 鈥渆monScript鈥 install? Is it still a emonSDxxxx? Why isn鈥檛 it kept in the boot dir for consistency?

It seems I have 2 EMONSD files in /boot

emonSD-17Jun2015
emonSD-15Jan2018

and from memory I had quite a game trying to get the backup script to do a restore so I likely had to create at least one of them for that. In this case should I delete them both? Whats the route it takes to do an update? Its late here so I鈥檒l get onto it tomorrow

Yes that is possible - if the above request to update the EmonScripts local repo fails we will know that :grinning:.

There is not one.

Ok, we need to establish exactly how you did the install. I mentioned a folder above, does it exist?

Yes it does,

returns 鈥淎lready up to date鈥

Deleting both emonSD files allowed the update to work. Thanks for your help.

By way of a little background this was a V9 system that was migrated from a Pi some time ago. When moving to V10 I backed up and deleted everything to do with emoncms, then updated the OS before installing, emoncms V10, then manually restoring as the restore function didn鈥檛 work on my system. The emonSD files must have remained from the original Pi and inside one of them I鈥檇 left a comment about it being needed to enable backup to work.

1 Like

Since the update last 2 day.
My Dashboard show errors鈥

Emoncms - user login ( should be public accessible鈥)
expect the problem somewhere in the batt percentage.

EmonCMS Error

Message: URIError: malformed URI sequence
Route: Modules/vis/visualisations/common/vis.helper.js
Line: 100
Column: 40