Community
OpenEnergyMonitor

Community

Can't get emonTx to enter RF config mode

Tags: #<Tag:0x00007f6e13ef74e0> #<Tag:0x00007f6e13ef73f0> #<Tag:0x00007f6e13ef7238> #<Tag:0x00007f6e13ef7120>

Hi, I can not get into the RF config mode. I open the serial monitor in arduino and send the +++ command but I can not get into the RF mode. I am I missing a step.
THanks For all the help.

Am I assuming your referring to emonTx? The serial config was added in version V2.6

Can you see what version your emonTx is running? Its printed to serial at startup? The firmware can be updated, see uploading instructions:

Its version emonTx V3.4 discrete Sampling V2.6

Ah great, in that case config mode should work! There are no tricks that I can think of. Are you using the standard USB to UART cable from the OpenEnergyMonitor shop?

Yep. right when the ‘+++’ then [Enter] for RF config mode pops up. I put the +++ and hit enter. But nothing happens.

I got the usb to uart programmer and I’m using a mini usb to usb cable. Should be ok

1 Like

Can you post up the serial output you can see?

Double check the Tx connection on the USB to UART cable… Can you test to see if the USB to UART cable Tx line is working correctly by connecting it to another UART cable Rx line and then looking to see if the +++ you are sending is received? Maybe you could have a faulty cable?

emonTx V3.4 Discrete Sampling V2.60
OpenEnergyMonitor.org

No EEPROM config
RFM69CW Node: 8 Freq: 433Mhz Group: 210

POST.....wait 10s
'+++' then [Enter] for RF config mode
CT 1 Cal 90.90
CT 2 Cal 90.90
CT 3 Cal 90.90
CT 4 Cal 16.67
RMS Voltage on AC-AC  is: ~251V
AC-AC detected - Real Power measure enabled
assuming pwr from AC-AC (jumper closed)
USA mode active
Vcal: 130.00
Phase Shift: 1.70
NO CT's detected
No temperature sensor
CT1 CT2 CT3 CT4 VRMS/BATT PULSE 
ct1:78,ct2:0,ct3:0,ct4:0,vrms:11998,pulse:0
ct1:8,ct2:0,ct3:0,ct4:0,vrms:11998,pulse:0
ct1:10,ct2:0,ct3:0,ct4:0,vrms:12031,pulse:0

All looks good, please report on the USB to UART test. I’m suspecting faulty cable

Tried another usb to micro cable and still not sending the +++. is there a way to check the serial to usb programmer board?

If you link the RX and TX together on the serial programmer instead of connecting it to a device, you should be see everything you type into the arduino IDE’s serial console, echoed back. It’s a simple test that simply loops the transmitted serial output back down the received line. You can use a short piece of wire or a metal paper clip.

How about trying a different sketch, such as blink.ino? If that works, the upload side of the cable/hardware must be OK. The original emonTx V3.4 Discrete Sampling V2.60 code can then be installed again.

Is anyone else running V2.6? Is serial config working ok for you? I can replicate the issue, we have been using it in the factory for some time now to set node ID.

I connected the rx to tx on the programmer board and it will repeat what I send

Is it a programmer supplied by the OEM shop?

Providing the pinout is as expected, this would suggest there is a problem with the emontx or the firmware installed. Next step would probably be to try and reinstall the firmware.

Are you waiting >10s <20s? from when the serial prints these messages

POST.....wait 10s
'+++' then [Enter] for RF config mode

Once those messages print the emonTx seems to sleep for 10s before there is a 10s window to reply. Try waiting 15secs from when the message appears to [enter] the +++ to hopefully put you in the centre of the 10s window.

yep I got it from the shop. I am wait 10s after the mode line

Try 15secs, 10s is cutting it fine since the code sleeps for 10s and does other stuff before beginning to set up to listen, if all 3 +'s are not seen it won’t work either.

Are you using the Arduino IDE? Try setting the line ending to “Both NL & CR” if it isn’t already

Any update on this? Did you manage to resolve the issue? I’ve just tested again and can confirm V2.6 firmware serial config works fine with the shop USB to UART adapters. Tested with platfrmIO serial monitor and minicom (@115200 baud).

It is working. It was the board. One of the pin wasn’t connected all the way. Thanks man. Have another question when USA 1 is on that means the Vrms changes to 130?

A post was split to a new topic: EmonTx V3 USA apparent power