Community
OpenEnergyMonitor

Community

Can't get emonTx to enter RF config mode

Tags: #<Tag:0x00007f6e0504adb0> #<Tag:0x00007f6e0504ac48> #<Tag:0x00007f6e0504aa90> #<Tag:0x00007f6e0504a978>

Great! Glad you got to the bottom of the issue.

When USA mode is enabled vrms calibration = 130. This is the calibration for the AC-AC USA plug voltage sensor adapter sold via the shop.

I’ve just noticed a bug when using emonTx in apparent power mode with USA mode enabled. I’ve pushed a fix for this and started a new thread. See above.

Glyn,

Clicking on the link in your post yields a 404 error. (page not found)

This is the link text: https://github.com/emoncms/AndroidApp/invitations

Woops, that was the wrong link! I’ve removed it. Too much multitasking!

Let me add a comment on this thread, in case others stumble upon this:

I was just configuring the node numbers on three emonTx today and I was using the “Arduino IDE’s Serial Monitor” as my serial terminal SW (on Windows).

This particular terminal allows you to set what type of carriage return to send when you hit ENTER, the options are “No line ending”, “Newline”, “Carriage return” and “Both NL and CR”.

Don’t know if this is a quirk in Windows, but I had to set it to “Both NL and CR” in order to be able to access the config menu with +++ [ENTER]; any other setting would not register the command correctly.

1 Like

I thought I’d seen something about this.
A search showed PB66 did indeed mention it in this thread.

And that is printed on-screen by the emonTx. From the source code:

  Serial.println("POST.....wait 10s");
  Serial.println("'+++' then [Enter] for RF config mode");
  Serial.println("(Arduino IDE Serial Monitor: make sure 'Both NL & CR' is selected)");

NL & CR are required for Linux as well, it’s not just Windows.

That’s the other place I’d seen it. Couldn’t for the life of me remember where it was.
I’ve slept since then. :grin: