WVC inverter MQTT Data logging for all versions of inverters

Not opened the thing yet, because I might want to send it back:

Manual says rated output power is 550 W. I would expect to get this permanently if I operate the device within specs (I allow free air flow around the device, ambient temp is ~28°C, shadow).

But at only 275 W it begins to shut down due to overheating. At 300 W it is repeating ~10 min off, ~20 min on cycles, so I get just 200 W averaged output power. Way too low for my taste.

Does anyone here has similar experience? What is the sustained output power you get with your device without active cooling at ambient 20-30°C? I would be interested in numbers for other devices as well (WVC700, WVC1200, …).

Looking at the downloaded manual for the one you mention at the top of this topic (WVC600), it gives

Output parameters @120V @230V
Output peak power 700Watt 700Watt
Rated output power 600Watt 600Watt

Given that a peak power is mentioned, I interpret “rated” as meaning continuous. Then

Appearance and technical features
Temperature range -40°C to +65°C
Heat dissipation mode Self-cooling

I would read that as it is capable of giving the rated output over the stated range of temperatures, and I would interpret those numbers as the ambient temperature range. It should not require anything other than cooling by natural convection (and a limited amount of radiation) from its casing.

If it is genuinely limiting its output due to overheating, then in the UK, the data from the manual is a false trade description, and that’s not lawful. I would suggest you speak with your local or national authority responsible for consumer protection.

The temperature range stated looks very much more like the storage temperature range - but most importantly, it does not say that. Whatever else, the inverter is sold to European countries and it must be capable of working as specified in an operating environment typical of that market - I would expect 35 °C is a reasonable upper ambient temperature and you should not need to derate it until the ambient temperature exceeded that.

I have wvc1200 on 1100w of panels no issues they are currently around 5-6 years old - they output what they should roughly output for the type of day… what type of panels are you using and their configuration. having panels running at lower volt higher amp would cause that type of behaviour.

Thanks for the feedback.

Panels are 2 * 410Wp but with >60° angle to the sun → >50% loss → ~2 * 200W (measured)
Voltage of the JA Solar JAM54S30-410 is Vmp ~31V and Voc ~37V

the panels would seam to be over sized they are most likely providing too much amp and shutting down if you look at the manual it tells you what the maximum size panel you can use with the inverter

2*410W would definitely be oversized if headed directly to the sun.
But I have to mount them in an angle. They can never produce 300W or more.

Edit: verified amperes stay below limit from manual.

Final Edit: decided to keep it since I got a small refund/compensation.
So I opened it and definitely no wifi/mobile/433MHz rf inside, just a pic16 that might give away some measurement data.
Cooling looks pretty decent - no hint why it gets so hot. The types of diodes and mosfets look good.
I hoped for some obvious build errors/heat blockers like seen on some youtube videos, but nothing.

A small breeze is already enough to keep it from overheating so I ordered some alu fins and hope for the best.

Thanks for the hints.

I own a WVC 1600W life, this micro inverter has a build in wifi modul.
The WVC 1600W life is connecting via wifi (my network) to the Alibaba cloud and with the iPhone App CloudIntelligence I can access the logged data of my WVC 1600W life.


  1. Is there a possibility to download the data out of the Alibaba cloud to my PC?
  2. Is there a possibility to connect / push the WVC 1600W life data to my own database (e.g. on a Raspberry PI)?

not familiar with WVC 1600W life. but if the data being transmitted to cloud is not encrypted . you could possibly strip out the information using wireshark . hopefully they just pass the data via JSON format and you simply just strip and pass it on to pi database . or you might have to take a “man in the middle” approach to strip out the info

I’ve basically read the entire thread, and wow. Some amazing work has been done here.

I do have an ask though, I too have a WVC 700W Life model inverter. I’m unable to connect it to the internet, and was wondering if anyone has tried replacing the wifi card with a ESP32 for direct communication with the inverter. I’ve read the TUYA-CONVERT github project, however it doesn’t seem to explain how to replace the chip entirely if need be.

Could someone help me forward? Right now I am using two units as micro inverters for my panels, but in the future I’d like to control the power output to adjust power acording to demand from a battery power bank.

Has anyone managed to get the data of a LIFE edition of the inverter. The cloud intelligence app is awful and i’d like to be able top use a PI to capture the data.

The WVC700 LIFE seems to have wifi only - I can see what ip address it sat on but have no idea of port
etc to make a data request to

Did you get any further with this?

A post was split to a new topic: Putting a WVC300-320V inverter and a KD-WVC-Modem to work

If anyone is interested i’ve managed to get some logging working with the LIFE Edition using a Rpi.

Hi @stephen , long time without updates, but my WVC700-R3 just burned. To bad. I replaced some components, it seems ok, but when I connect to the grid I get red blinking led.

In the meanwhile, I bought a WVC1200, but it lacks of id. Is there a way to make a broadcast and receive the id using your wvc script?

not sure but it seams to still be the same as the older version according to website. though they do not have an ID like the older one they now use the serial number

unless you bought the life version by mistake:

or the non wireless version

Take a look at my project. Will work with the life editions that dont have the same type of ID as tbe standard R3

UPDATE: Never mind, it turns out the modem interface just needed a second more before reading the response data. And for some reason the modem test message(f8) is not getting a response while the data req(f2) is working. Oh well, it’s at least something I can now try to get reliable.

original msg:
Has anyone figured out what’s special about the Wifi WVC-Modems to talk to them over RS232?
I was able to send the modem text command 0xF8 and got the response which was just the echo of the command so I know comms is working. But when I try to send the data request command, 0xF2, it does not echo any response.

I’m using the same data request command which works over a stock 433Mhz board(via FTDI->USB) so I know that works so maybe something special for the WVC-Modem I’m missing or wrong like the BoxID? I could never get the Wifi configured on this modem and it’s like it has the wrong firmware because nothing in the docs matched what I ran across but was hoping to get the RS232 comms working.

FYI, Python message setup stuff looks something like this for creating the messages:

# Message definitions
#data acq
#modem test
# modem ID
# inverters


Sorry but I was wrong about being able to talk to the inverters via the RS232 port on the WVC-Modem. A 2nd process was communicating to the inverters over a 433MHz transciever on a different serial port but had the same ModemID as the modem so the modem was receiving transmissions with its modemID and they are readable over the RS232 but sending F2 messages out through the WVC-Modem is not working.

I can get a response from an F8 command which is a copy of what was sent.

cmd_string: f820111839ffff6b
response: b'f820111839ffff6b'
MODEM_ID   : b'20111839'
modemtest FOUND MODEM

This command works over the 433MHz transceiver but the connection is sometimes unreliable and will just stop working and stopping the process and restarting then restores functionality/msg/resp.

cmd_string: f220111839e91b000040000c6565

Does anyone have a newish WVC-Modem-IOT working via RS232? I received this modem with my WVC-700 R3 inverters and was not able to get it working over WiFi because it originally didn’t operate like any documents I’d found. Sticker on the modem says “Mode: IOT/TCP” and the WiFi Access Point it projects has an SSID of “MODEM_2011839” and passphrase of “12345678” which does not match what any documentation says it should be. When I push the reset button on the WVC-Modem it’ll open up a WAP with an SSID of AWS_6A8130

Hi Stephen,
I would like to add a output power limiter functionality in my script that monitors (cmd 0xf2)
It is possible just to read the existing Power Adjustment (cmd 0xf1) without changing it?