Vaillant eBUS hardware adapter (ebusd software) Thread

Thanks Rob, appreciate this work.

Was does ‘filter-seen’ do?

If you have a look further down the issue you raised it is suggested as a fix.

Take a look at this More conservative defaults for mqtt-hassio.cfg as some messages might not like being polled by pulquero · Pull Request #1213 · john30/ebusd · GitHub and subsequent work by pulquero.

As a follow up, I set my “filter-seen=1” last week and use a vanilla jonesPD’s configuration. All is fine so far with several DHW cycles and some short heating runs.
Looking at the status codes, it seems “Compressor blocked” and “Compressor shutdown” are normal as this happens at the end of a completed run as well.

I did try pulquero’s config but it messed up my MQTT sensors in HA so reverted to jonesPD as I didn’t have time to rework my sensors. It is likely his will work just fine too.

I might get round to figuring out which works best and maybe changing “1” to “5” but for now I am happy with the sensors I have and it is working.

I did trim the mqtt-hassio.cfg to only contain the following filter based on pulquero’s and the mentioned thread:


filter-name = ^status|^state*|statuscode$|^livemonitor|^testmenu|compressor|^hwc*temp

Hope this is of use.

1 Like

Hey @RATA1

Thanks for this. I really appreciate the level of detail and testing.

I will give this a go and see how I get on.

I used the filter-seen=1 parameter and things seem okay overnight (one DHW run and a tiny bit of heat)

I went back to the Jones config files.

Although I did have to stick with the default filtering options as half of what I wanted seemed missing in Home Assistant with your shortened filter.

filter-name = status|temp|humidity|yield|count|energy|power|runtime|hours|starts|mode|curve|^load$|^party$|sensor|timer

I may look to clean that up and remove stuff once I nail down exactly what it is I want to monitor long term.