OpenEVSE / EmonEVSE Wired Ethernet Connectivity

Using an ESP32-Gateway module it’s now possible to connect an OpenEVSE / EmonEVSE via wired Ethernet.

See the OpenEnergyMonitor store for a pre-wired and pre-loaded module which will be a drop in replacement for the current WiFi module in OpenEVSE / EmonEVE.

Or see the full ESP32-gateway technical docs to compile firmware and connect up your own ESP32-gateway module.

Pre-wired module with power supply:

Installation in an EmonEVSE:

Serial connections:


The ESP32 Gateway is a new addition and is currently considered in ‘Beta’ since the ESP32 firmware is still under active development. However, it has been extensively tested and proven reliable for many months of operation. Please report your experience

Hi this looks interesting I was wondering if
There is enough space in the esp32 to implement a stand alone version of the demand shaper that trystian is working on ?

Did I read somewhere that the esp 32 would be able to control 2 evse chargers ?

Take care bill

That should be possible. Obviously some significant changes (full rewrite) will be required to convert a php web app to run on the esp32 but the esp32 should be easily capable of the calculations required. This would be a really nice standalone feature.

No, this is not planned or easily possible.

Hi glyn
spent today changing the evse wifi boards to the esp32 gateway boards on both my chargers
these are hardwired into a cisco 24 port switch my wifi router is also wired in to this switch
also using pihole as a dchp and dns server .
i managed to download and compile the code on my linux laptop and program two virgin esp32 gateway boards . I Reserved the ip adress in the dchp server for the two boards with there Mac adress .
The boards have powered up and failed to conect to the lan but have taken me into configration for wifi Each time that i have tried from a clean install and power up they still bring up the wifi interface .
i have checked the lan cable with cable tester it is fine . and i have conected through the cable with my laptop to my network .
i have even reloaded the firmware from a binary file via http … to one of the systems and still same results .
I am making the asumtion that on power up they look for the lan and if found they then request a conection and take the ip number from dchp .
should it then display the ip number on the screen ?
and allow me to conect and configer via the lan ? .
i see just the normal evse boot up then into sleep mode : displayed
when i check wifi on phone i see the acsess point to conect and program wifi details as normal . if i program this up all workes on wifi as normal but i have to remove the lan cable to let me log on via my network . . if i plug in the lan cable and reboot the charger if will come up with the wifi infomation but not let me conect to it untill i remove the lan cable .
i have tried conecting to difernt router with a longer cable but still the same .
the compiler when finished compling reports openevse_esp32-gateway-e success
so i am sure its compiled the right version .
can you shed some more light on what we expect these to do ?
ie if programed up to conect to hard wire lan . if this lan goes down does it try wifi ? or just wait for lan to come back ?
i may try and make up a seprate lan tomorrow with just them and a hub and laptop and see what they do .
regards Bill

Hi Bill,

Could you try to upload the pre-compiled V3.1.0 to the ESP gateway:

Using this tried and tested pre-compiled firmware will rule out any issues with your local compiling.

Hi Glyn,

I have managed to flash the firmware.bin instead of the esp32-gateway-e.bin (via web ui) on one of my EmonEVSE’s. I now cannot seem to flash it back, web UI is not working. I’ve tried using the to flash the partitions file along with the correct bin file etc, (via usb programmer), but no luck and errors were returned. Is there a way back from this?

Thanks in advance

To fix this you will need to upload the esp32-gateway-e.bin and bootloader.bin and partitions.bin using esptool with the board connected via USB. See the upload instructions: openevse_esp32_firmware/docs/ at master · OpenEVSE/openevse_esp32_firmware · GitHub

Hi Glyn … ok update on this i think it may be someting with the cisco switch that i am using
as i put both chargers into a cheap network hub and then conected the hub to the switch
and all then worked as the instructions . and the units now show using the wired conection point
strange that once i had them working and configerd i was able to conect them straight into the cisco switch and they are working fine .
i still need to lookup the mac ad for the hardwire port so that i can set them to the Ip adress that i want . but at the moment living with the one that they set up to themselves .
i have now managed to get on to the octopus Argile tarriff and have set up to night to do first charge with demand shaper. so hope all goes well …
thanks for you response to this

Hi all,

I have a ESP32 GATEWAY, I have loaded the firmware on the unit and it boots ok when connected to the micro USB if i connect it to the OpenEVSE 5v power supply i just get a red light. Anyone got any ideas?


Just an update, the information on this page about the pinout is wrong ESP32_WiFi_V4.x/ at master · OpenEVSE/ESP32_WiFi_V4.x · GitHub

It should be pin 20 for 5V and 19 for GND


The these hardware connections on the doc apply to Rev.E & Rev.F of ESP32-gateway. What rev is your board?

Hi Glyn,

I think mine is a revision G, Looking at your photo you can see pin 1 is on the far left

Also looking at the manual it shows pin 20 for 5V

Interesting, my connections are correct for rev E & F (earlier revs have different pinout). Maybe the pinout has been changed again in rev G :confused:

What connections work for you?

The photo above is from the wiki and clearly shows pin 20 5v and 19 GND
Do you have a photo of the back of the board?

Mine is currently in the charger, I will take some photos next time i take it to bits

Just spit balling right now, but is the wired firmware compatible with the US module?

Bueller? @glyn.hudson is the firmware for the wired ethernet ESP32 good for both US units and EU ones? I know there was a difference where the EU ones have a 32A limit, but I don’t recall if that was for the OpenEVSE main unit or the wifi unit.

Yeah the WiFi module is independent of territory, that info is pulled from the OpenEVSE module and adjusts as appropriate

1 Like

Sounds good. Only other question I have is if the firmware for the ethernet module contains the same as the wifi module just with ethernet now being apart of it? Looks like the device selected has both wifi and ethernet available so one could go either way.

Correct the Ethernet module has both WiFi and Ethernet and is identical to other builds apart from basic hardware configuration

Thanks. Going to look into getting those for mine since I find when my Unifi AP updates which causes them to disconnect. The MQTT fails to reconnect each time and the wifi sometimes fails as well.