Community
OpenEnergyMonitor

Community

New emonSD release: emonSD-30Oct18 (Raspbian Stretch Pi3B+ compatible) 🎉

emonsd
announcement
raspberrypi3
stretch
Tags: #<Tag:0x00007f13ec54b5d0> #<Tag:0x00007f13ec54b440> #<Tag:0x00007f13ec54b288> #<Tag:0x00007f13ec54ad10>

(Brian Orpin) #62

Ah Ok that branch is on the older feedwriter cron job (strangely came across this this week).

I think first check the cron job

crontab -l

(Ian Rogers) #63

Seems like crontab is default

# Edit this file to introduce tasks to be run by cron.
#     
# Each task to run has to be defined through a single line 
# indicating with different fields when the task will be run
# and what command to run for the task
# 
# To define the time you can provide concrete values for
# minute (m), hour (h), day of month (dom), month (mon),
# and day of week (dow) or use '*' in these fields (for 'any').# 
# Notice that tasks will be started based on the cron's system
# daemon's notion of time and timezones.
# 
# Output of the crontab jobs (including errors) is sent through
# email to the user the crontab file belongs to (unless redirected).
# 
# For example, you can run a backup of all your user accounts
# at 5 a.m every week with:
# 0 5 * * 1 tar -zcf /var/backups/home.tgz /home/
# 
# For more information see the manual pages of crontab(5) and cron(8)
# 
# m h  dom mon dow   command

(Brian Orpin) #64

One last try then I’m out of ideas (not familiar with the older feedwriter service)…

The command in the script to restart it is

sudo /etc/init.d/feedwriter restart

(Ian Rogers) #65

That works, but reboot of the feedwriter.service worked too!

 sudo /etc/init.d/feedwriter restart
 Log is turned off
 Restarting feedwriter (feedwriter.php was not running...)

Still doesn’t explain/help as to why the feed writer is not restarted after emonpi update button is pressed.


(Brian Orpin) #66

I’ve raised it as an Issue.


(Ian Rogers) #67

Thanks


(Paul) #68

But also note what the actual emoncms buffer status is, it changes on the live server info, but the copy and paste version always says “loading…” so it’s effectively meaningless.


(Ian Rogers) #69

When the line below is showing, the buffer will continue increasing with a number of points to write.

Daemon is not running, start it at ~/scripts/feedwriter

(Brian Orpin) #70

Yes but I do not think that is fixable because of the way the Ajax call works. Just one to be lived with I suspect unless you could make a special call to the function and append the data at the end of the text buffer.


(Paul) #71

I wasn’t aware of that.
No one has commented on the issue I raised.

If it can’t be reported (copied) accurately, it shouldn’t included. So the best fix would be to remove it I guess, even if only temporarily. Simples!


(Greebo) #72

I don’t think feedwriter was ever cron based… it changed from SystemV Init based startup to systemd based startup… You’re thinking of service-runner (which was initially cron and changed to systemd)


(Brian Orpin) #73

Not as simple as that I suspect. The output HTML is copied by using a class ID

within that copied area is the ajax call to update the number in the buffer

I suspect removing this section when copied might be well nigh impossible (but I’m no expert).

Ah yes - getting myself confused.


(Bill Thomson) split this topic #74

2 posts were split to a new topic: MQTT not working after restore


(Anthony Vassallo) #75

@borpin I had a similar problem when updating emonBase (using emonSD-30Oct18). After update noticed feeds was not updating, so tried sudo systemctl status service-runner.service and also sudo /etc/init.d/feedwriter restart. All seemed OK…

but still no feed updates.
But a reboot of the rPi fixed it.


(Brian Orpin) split this topic #76

A post was split to a new topic: Keeping an EmonSD installation up to date