Community
OpenEnergyMonitor

Community

No SSH Password


(Sean) #1

I enabled SSH and noticed there is no password prompt. How can I enable the password prompt? It’s actually pretty weird to me that this has been disabled - what was the logic behind this?


New emonSD release: emonSD-30Oct18 (Raspbian Stretch Pi3B+ compatible) :tada:
(Brian Orpin) #2

This is odd. I’ll do some tests.


(Brian Orpin) #3

Is this an EmonPi or an EmonBase? If an EmonPi, how did you enable it? Via creating a file in boot or using the long press?

My test is that a long press does then require a password.


(Sean) #4

It’s an emonPi, and I enabled it by putting the ssh file in the boot partition. To be clear, I can log in via SSH, I just am not asked for a password (and I haven’t added an SSH key).

I’m using the Oct 2018 image.


(Glyn Hudson) #5

What are you using to login? My guess is the password must be saved somewhere on your machine from logging in previously. SSH always requires a password or key


(Sean) #6

Ah, just connected using the -v flag and found that it is indeed using my public key. I forgot that I had copied that over when I was adding the ssh file. So that clears things up. Sorry for wasting your time, my mistake!