MyElectric Setup Invalid Response Object error

i ready get installed the CT sensor to neutral
but I cant get graph I show you my screens

what would be wrong on it


Check the correct feeds are selected. See the my electric setup guide:

Home Energy - Guide | OpenEnergyMonitor

I followed your guide at the first time , I made it again and appear the same error message

@TrystanLea is the developer and maintainer of MyElectric. Maybe he can advise. Your feeds look correct to me.

Can you show us your feed list or confirm the “use” and “use_kwh” are both PHPfina fixed interval feed types?
the MyElectric app will only work with PHPfina feeds.

here is my feed list CT and AC

It looks like data is not being written to your feeds, the size field should increase at 4 bytes per interval (if 10s 4x6x60 = 1440 bytes per hour). Perhaps the emoncms feedwriter script is not running. You should be able to check this from the Setup, Administration tab

but some data is showing on my electric

some data is getting on feeds too
You should be able to check this from the Setup, Administration tab : would you explain more in details how to solve it ?

Ah ok, Can you click on Refresh Feed Size on the emoncms feeds page, could you also share a screenshot of the use feed? Im still not sure yet where the issue is located, I will need a bit more information to work it out

thanks … this is the last Refresh Feed Size

I made the creation feed process two times more , and change to 15s , now its getting data on Size as you mentioned before

but I still see this error whitout any data on my electric app
I had few ours on getting data but don’t create any kind of graphic

In the graph view (last screenshot) do you see any data when you zoom right in to the last hour?

Don’t appear any graph on it

but on the feed section appear this

I had this period time connected Window: 17:30 8 Jun > 17:45 15 Jun, Length: 168h15 (605700 seconds) but in the size KB its like stuck on that values and not go up , as you mentioned before that size kb should going up trough the time
its would be a problem in CT ( Neutral ) AC connection or its a issue in my emonpi soft config ?

Sorry I dont think I was clear enough in my last question, can you see any data when you zoom in with the graph view at address: Your screenshot shows the last 7 days, there may be data visible if you zoom in to the present day.

Do you see any errors in the emoncms.log which can be found here:
Setup > EmonHub > emoncms.log view

Have you tried restarting the emonpi? or running the emonpi update from Setup > Administration > Update EmonPi? This may unlock the issue by forcing a restart of the software on the emonpi.

My screen emoncms.log

Where did you see (Setup > Administration > Update EmonPi?)

Some Graph start appear in my electric app

As you suggested I play with zoom and I can see this

let me know your opinion about


That’s strange, there should be an Administration menu item there, is this a standard EmonPi with our latest image from the shop/download or did you build it yourself? Is there a possibility that you have created multiple users on the pi?

to see the Administration item in the menu, I have to click Logout

Do a login, then go to Setup > Administration. And then do an emonPi Update.

1 Like

i had the latest image
V2.5 (18/03/16) I download the image and write in a new SD Card
I still cant create bar graph in my electric app ( last graph showed )

thanks that works !!!

My Feeds appear with Zero KB Size again
I made an update available in emoncms local