Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Download of latest image fails

I thought I’d continue this post, as the issue is similar. I’ve had my emonpi working successfully since I first installed it early this year. About a week ago, we had some power outages, and I noticed the emonpi was stuck on “booting-please wait”. I’ve tried several times to re-boot it, but no change.
I’ve retrieved the SD card and looked at it on my Ubuntu machine. I used fsck to check and repair errors on each of the three partitions, which it said it had done, but the emonpi still won’t boot.
I tried downloading the latest SD image ( emonSD-21Jul21 (Stable)) from this page emonSD pre built SD card Download & Change Log · openenergymonitor/emonpi Wiki · GitHub, but the 1.7GB download crashed with “network error” at 1.0 GB four times.
So I’ve ground to a halt. Any suggestions most welcome! I have a backup about a month old, which I’m happy to use.
Many thanks in advance

Do you have access to another computer on another network where you can attempt the download from?

Or can you build the image yourself using the scripts? Don’t ask me how, it’s completely outside my field, @borpin or @TrystanLea are best placed to help you.

My only remaining suggestion, in the absence of a local mirror, is to purchase a pre-loaded SD card.

Thanks for your comments Robert. I tried downloading the image again this morning, thinking it might be a server traffic issue, and a different time might help (I’m in Australia). No change, download fails at 1.0GB out of 1.7GB. Other similarly sized downloads work fine from other sites, so no download problems at my end. I might start a new thread on a different page. Investigate if it’s a problem at the server end. Ta anyway, and all the best for being ever present on this site!

I had a download stop on me - I can’t remember the version now - but if my memory serves, it either carried on where it left off, or completed satisfactorily the second time. I would have been using Opera browser under Ubuntu 20.04.

I’ve no idea whether Github works on just one server in one country (very doubtful), or whether they have mirrors in various places. I’m quite sure that if it was the image file itself, we would have known about it a long time ago.

If you want to try the scripts: GitHub - openenergymonitor/EmonScripts: Emoncms Stack Installation and Update scripts

Or a different browser?

It might be worth asking your ISP if there’s a limit or timeout on downloads.

@TrystanLea @glyn.hudson the download is horribly slow from https://openenergymonitor.org/files/emonSD-21Jul21.zip

But is did complete for me. Does sound like a timeout issue.

Sorry about this, what sort of speeds are you seeing @borpin trying here now it seems to be around 4MB/s, suggesting 6 minutes at the moment…

Completed a full image download here, took about the 6 minutes it suggested.

Not sure if this will help, but it looks like Chrome has perhaps a better ability to resume half completed downloads?

Tried turning off my WiFi connection part way through and it seems to continue after restoring the connection…

No changes have been made recently to the image hosting server, I’m also unable to replicate. I’m getting fast download speed, the whole image took about 6 min to download

The image is hosted from a dedicated redstation server in the UK which is on a web backbone connection, I don’t think the server is the bottleneck. I guess it would be good to have some mirrors in different counties.

The server load is also looking healthy on the server at the moment and quite a bit lower than it was before @glyn.hudson moved the forum to a different server.

If anyone in Australia would like to help us mirror the image that would be much appreciated!

Must have just got a bad download then :frowning:. Pulling the RaspberryOS image and it’s a bit quicker, but not much.

Worked for me (also in Australia) - downloaded successfully at the limit of my Internet connection (approx 5MB/s - about 6 minutes). Using Chrome on Windows 10.
@AdeinFNQ - My NBN provider is Exetel in case that helps.

Thanks for all the comments everybody! I’ve never encountered the problem before, but it seems it must be local after all. I’ll try a few things and report back here for completeness. Thanks again.
Kind regards

2 Likes