OpenEnergyMonitor Community

Booting please wait, what do I do

I have an emonpi that has been working fine for a month or so, but it stopped recording, and when I checked it, it just has the message “Booting please wait”. Whatever I do it reverts to this message, and I cannot connect again to emoncms. What can I do?

Welcome, Jeremy, to the forum.

That is an indication that either the Pi or emonCMS has not started - that message comes from the “emon” part - a separate processor to the Pi.

If it just stopped, I would guess that either a power outage or a spike on the supply has corrupted the SD card.

If you can communicate at all with the Pi via SSH, then you could look at the log. If you can’t, and you don’t mind losing the data you’ve already gathered, then the easy way is probably to reflash the SD card. If you want the data (assuming it’s recoverable) then somebody who knows where all the files are will need to help you.

Thanks that is helpful. I don’t mind losing the data, how do I “reflash” the SD card?


You need a Torx T20 screwdriver, take off the plastic end plate of the emonPi and the SD card is end-on underneath the push-button. The card holder can either be press-to-release, or you might need pinched fingers or tweezers to grasp the edge with care. Take it out, put it in your laptop/card reader. Install “Balena Etcher” on your laptop (there are other ways), download the “latest” image and follow the instructions in Etcher. It’s pretty straightforward. If you have an SD card bigger than 16 GB, then you want to expand the data partition, and the easy way to do that is still with the card in the laptop, use GParted.
It should run straight away back in the emonPi.

Or, you can buy a ready-to-go card from the OEM shop.

1 Like

Thanks, solved. The SD card seems to have been damaged. I bought a new card, wrote the latest image to it using Etcher, and it has all rebooted and works fine again.

1 Like

Welcome community!

This is my first post. My issue is identical except I can’t find the SD card. I bought the EmonPi Energy Monitor and it worked flawless for about one month. Same as for @Rhosser. Now it only says ‘Booting… please wait’.

Is there any instruction on how to find the SD card in the chassis?


emonPi v2.92


It’s a real bummer to see this completely crash so frequently…

Welcome to you, @Toodle

I’m sorry to hear you have problems. I’ve got to say that’s unusual.

My first suspicions would be in the direction of the power supply. Are you using a “good” 5 V power supply - I’d recommend either the one from the OEM shop or an official Raspberry Pi one, NOT a phone charger. My colleague @borpin also recommends the use of a “power conditioner” - a combined filter and voltage spike suppressor.

Hi there and thanks for your reply.

In the meantime I setup the system from scratch and were able to import most of the data from the crashed system. In fact it ran three month straight and I only lost about a week of data.

Fyi, I’m using the OEM power supply but will consider a power conditioner on top. The reason for the crash was rigorously switching power supply on and off several times in a row by a technican not paying attention.

Well, you know what to do about that!

The real problem was probably not switching the power on and off, but voltage spikes associated with switching the power on and off, according to @borpin

5 posts were split to a new topic: Download of latest image fails

Sorry to hear that the SD card has failed @Rhosser and @Toodle

In addition to the advice on adding surge protection suggested by @Robert.Wall, which I did on mine and seems to be working really well so far, We have recently (September this year) switched over to industrial grade SD cards as standard to hopefully help with improving longevity as well: emonSD Industrial - Pre-loaded SD card - Shop | OpenEnergyMonitor.

When did you both order your emonPi’s? @Toodle have you reflashed on the same SD card several times? with the issue repeating?