All local nodes not recognised after emonpi firmware update

Finally got round to updating emonpi because I was needing to reboot the system as the feeds stopped logging, similar to those mentioned in Reboot Required Every 20 Days Or So To Restore Logging.
I updated the system using the “emonpi update” in local emoncms administration. This worked however,
I note two things/ issues after this update, one significant and one not so significant:

  • not so significant issue - the feeds page in the local emoncms just displayed the rotating sun wheel after the update. After using different browsers this was identified as a browser issue, did not work in Safaris Technology Preview but did in Safari and Firefox (which is strange because they all use Mozilla engines).

  • significant issue - the update must have also updated the firmware on the emonpi because the voltage calibration changed back to the original value (voltage readings were incorrect when graphed).
    I therefore did a git pull of the latest emonpi to my emonpi, updated the ‘float Vcal’ value in the src.ino and then did a firmware update using Part 1/3: PlatformIO open-source embedded development ecosystem, which worked fine except that all my local nodes (two emonTx and eight emonTh) stopped logging. I only had the emonpi node and two emonhub nodes (BMW i3 and SMA) logging. Fortunately I had an old git pull copy of the emonpi firmware, which then used to do a firmware update on the emonpi that corrected the problem.

By using the older firmware git pull and updating have I negated the original issue of logging stopping after 20 or so days? Or, have done something wrong while updating git pull and firmware update?