Community
OpenEnergyMonitor

Community

Wired as Type 1 but will set up only as Type 2

Tags: #<Tag:0x00007fdb5d9a1a60> #<Tag:0x00007fdb5d9a18f8>

Just set up my system and am having trouble setting the local machine up. I have got the app working in power view although it has not registered any history since May 16 when I finally got the power view working. I think this is something to do with the two feeds:- use_kw & power1 in the screenshot, these feeds also seem strange as there appears no way to edit them.

Can anyone explain why my wiring seems to be Type 1 yet I can only get it working when set to type 2.
I only got my emoncms.org setup working thanks to Glen, so I am struggling a bit here.






I’m really struggling to see your screenshots properly, 4 images combined into one isn’t easy on the eye and each image seems to have a lot of dead space included, so if I’ve got something wrong I apologise in advance, but in future can you please upload individual images or if you want to be efficient with fewer uploads, please zoom in on the detail a bit, my eyes are not what they used to be (and they weren’t that great then!).

It looks to me like you have an error in line 3 of the power1 processing, you seem to be saving both the power and the energy (kWh) to the same “emonpi:use” feed and not using the “emonpi:use_kwh” feed, hence the last update was 4.2days ago.

You should be able to edit that line in the input processing by clicking the edit/pencil icon to the right, once opened for editing, you can select the correct feed from the feed dropdown and save the changes.

Hi Paul Thank you for your help I altered the images as you suggested, and made the alteration to line 3 which appears to have corrected the solar history, what edit do I have to do to correct the import history.



I’m not sure how that change should effect the solar history, something is still not right with your processing as

how can your “use_kwh” be a negative value? Do your appliances generate power?

If your emoncms.org account is correct, can you post details of that for us to compare with?

These are the screenshots of my emoncms.org account, this was set up for me by
@glyn.hudson and is working fine. if you check above you will see that while my system is wired as Type 1 solar PV System it is working as a type 2 for some reason.




The thread title is Wired as Type 1 but will set up only as Type 2

I was looking at your photo and it looks to me as if one c.t. is on the supply side of the meter, i.e. on the Grid connection, and the second is on the P.V. infeed. That is not exactly a Type 2 installation, but it is equivalent, the only difference being the grid c.t. is the opposite side of the meter.

Thank you for that, it was me misreading it

It looks to me like your local emoncms and emoncms.org are the same now and I concur with Robert this is a type2 (as did Glyn here Feeds not working on emoncms.org). I think you have it set up fairly correctly now, but the running use_kwh value is already very wrong. I imagine that -1164kWh has now moved in the opposite direction (towards zero) but that will need to pass through zero into positive values before it makes complete sense. The quicker solution might be to delete and recreate that feed so you start from zero today, the history is already no good. so you may as well get back on track sooner rather than later.

You could watch for a day or 2 to confirm, but I’m fairly sure that -1164kWh is going to cause an issue for a while yet since you have only racked up a total of 74kWh on the use_kwh at emoncms.org.

Hi Paul
Do I just delete that one feed use_kwh and then recreate it, or do I delete all feeds,
and are the node emonpi:power1 & power 1 feeds redundant and can just be deleted

As far as I can see right now it’s just that one feed that is causing an issue so just start with that one. You can review whether to do any others once you see the outcome of resetting that one feed and how easy/difficult you find the task as to whether you think it’s worth doing.

It looks that way to me, I don’t see them in the input processing and they are not updating so I think the’re probably safe to go.

Hi Paul I deleted the field but when I created the new feed I could only create this virtual feed which stops the app working completely it offers me the option to set up a process list but, I do not know what settings to put in that list. If I delete that new feed, the app works but has no History menu.

Studying it further I think I have got it wrong here, do you set up the feed from the process list.
I did that and added a 6 line of use_kwh to the list then I altered line 3 of the solar app from auto to use_kwh:use. after this I noticed the sixth line I had added had disappeared, but strangely it seemed to work a lot better, although I could no longer create an Electric app so something is still wrong. The figures the history shows for yesterday all agree with the ones in the .org account. Although when I corrected my time zone to BST it lost the import above the line, maybe it just needs time for the graph to fill


(upload://iAGGXukrEUqUWrnJFcPlbZqr8VW.png)

app%20setup%20alteration

If you could look at these and suggest any further alterations I would be grateful

Sorry you’ve lost me!

I’m confused about the 6th line disappearing, plus it would not have been recording the right info there. The processlist you previously had was correct, all you were doing was changing the feed.

The best way to of done that would have been to just go to that line of the input process list and edit it by “creating a new feed” called “use_kwh2” perhaps? Then gone to the feeds page, deleted the “use_kwh” feed and renamed the “use_kwh2” feed to “use_kwh”.

I think now, you need to create a new “3rd line” power to kWh process and a new “use_kwh” feed (if you haven’t already) but when you do it will appear at the bottom of the processlist, then you need to use the arrows on the left to move it up the processlist to the 3rd line position. and save it before closing (that might be why you lost the first one?).

If you are unsure then post your processlist and feed list for us to see again as it is now so that we know what you have and how to move forward.

Hi Paul
I think you posted just as I was editing my post, the screenshots above are as the system is running now if you could tell me what to add to that process list.
One other thing that might be causing confusion if you look at my feeds list I think I renamed some of the feeds when I first set up the system, can you tell me what the default names should be and can I just rename them to that default.

Hi Paul
I have studied your last post and have made the changes you suggested creating new feed and adding line3, does this look right to you.

Yup, that looks better, do the numbers look ok in the app? You will need to wait 24hrs’ish to get a full picture in the apps.

Yes the numbers all seem to agree when I changed the date to BST theMay21 entry in history lost its blue import above the line but I am presuming that will work itself out after a day.

By the way there is an entry in delete feeds now that allows you to delete either all your data or up to a certain date. I used it before I deleted that feed but it still left one entry still showing -1164 and a lot of null entrys, maybe that would have worked itself out after a few hours, Perhaps I can use it to trim the solar of -1558kw showing on my first entry of 9May, I had got the impression from the forum that it was very difficult to trim data.
I’ll get back to you when the history graphs have run for a bit. thanks again for your help

1 Like

Yes, there is, I had considered an alternative method to deleting and recreating the feed that made use of the trim function, but went for what I thought should have been the simpler option so as not to confuse things.

The trim function on it’s own will not work as you have discovered, that is because when you have a series of totals, eg -1000, -1050, -1100, -1164, when you trim any number of values away from the beginning, the end is always still -1164. The trim function is for reducing the file size on disk, it doesn’t alter the values.

However, had we stopped new data from coming in (stopped the mqtt service for example) and then created a temporary new input solely for the purpose of adding your troublesome to feed(s) to it with a simple “log to feed” process, we could have posted some zero values to it, then (optionally) trimmed it, restarted the mqtt and deleted the temporary input. (You see why I went for recreating the feed :slight_smile:)

You want to be sure all the values are updating correctly before recreating (or zeroing) any other feeds to avoid needing to do it more than once, hopefully it should be working better now.

Hi Paul
I am posting the history graph which is now showing correct for the 23/may but how do we get rid of the mess of the carry forward figures from the previous days, do we recreate the use feed like we did with the use_kwh which by the way did restart at zero yesterday when I activated it. Thanks for clarifying the trim feeds option.

Yes the simple way to “get rid of the mess” is to reset the feeds in question.

I just fired up an old emoncms test server I’m not currently using to see if there was an easier way for you to clear the data. It took me a while to find the trim data as it only shows when you try to delete the feed. IMO that’s not overly intuitive as i was effectively looking for an alternative to deleting the feed, but I see how it’s connected. I will have to try and remember where it is (although I have obviously already forgotten this previously!). Anyway! It seems I had also forgotten there is a “Clear data” function too.

Did you not see that option when you tried the trim function? Or is it not present on your setup? (This test server is not bang up to date but it is recent’ish).

I have never used the “Clear” function, but if it does what it says on the tin and “Empty feed of all data” that will do exactly what we need and clicking that button, I would have to say, has to be somewhat easier than either of the aforementioned methods (sorry 'bout that).

Hi Paul I did try the clear field off all data first and as far as I remember after checking the show csv everything was showing null with just one entry showing -1102 after that I went straight to delete and reinstall the feed but now I assume it would all have worked itself out if I had left it a bit.
Do you think I should now go ahead select all six feeds and delete all data.
John