Windows install emoncms

instructions for install wampserver state (“”)

“On Wampserver, enabling mod-rewrite is simply a case of left-click on your Wamp icon and hover on Apache, then hover over Apache Modules, then click PHP, then click on rewrite-module (you’ll need to scroll down the list - it it’s ticked, it’s enabled). Do a restart all services on Wampserver.”

Version php is version 5.6.31.
Wampserver version

I can left click on wamp icon and hover over Apache and hover over Apache modules. I then see PHP but i do see rewrite-module which is already ticked.

Is this right or have i missed something?

Do I understand you cannot get it to work?

From the old forum:

“I had issues moving my setup from linux to WAMP. The only extra thing I can remember I had to do was to enable mbstring and gettext extensions in your php.ini file. You might have to install gettext, depending on how your php was compiled. Restart apache and you should be fine.”

So check if you have those too. I moved from Windows to Linux a couple of years ago, so I’m not up to date with the present version of WAMP.


After I posted this I simply continued with the rest of the instructions.


was going fine until the last instruction.
"In the ‘Other settings’ section, change the $log_filename location to:

$log_filename = dirname(FILE).'\\' . 'emoncms.log';

I am geting error when logging into localhost emoncms

( ! ) Notice: Use of undefined constant FILE - assumed 'FILE' in D:\wamp64\www\emoncms\settings.php on line 138
Call Stack
#	Time	Memory	Function	Location
1	0.0005	313720	{main}( )	...\index.php:0
2	0.0008	355888	require( 'D:\wamp64\www\emoncms\process_settings.php' )	...\index.php:18
3	0.0011	375000	require_once( 'D:\wamp64\www\emoncms\settings.php' )	...\process_settings.php:21

Line 138 in settings.php reads

$log_filename = dirname(FILE).'\\' . 'emoncms.log';

Not sure if the first reports error has caused the second?

Thanks for assistance

As I said, I don’t have WAMP any more, and I can’t remember the details. That reads to me as if the installation instructions have been corrupted in translation to the new forum, and likewise what you’ve copied above, so I’m not sure what’s going on. It looks like a simple formatting error, unfortunately I don’t have an original copy to check against.

I think what should be happening there is you’re simply moving the log file to a more accessible place.

The first “error” is just an error in the instructions. Rewrite-module is now enabled by default in wamp. I vaguely remember the 2nd issue when I tried this a year or so ago. I was able to figure out a solution, but I don’t recall what it was. I put running emoncms on Windows on the back burner, since it seemed no one else was doing that and it was likely there would be other issues. For awhile I tried it on docker (on Windows) but that too doesn’t seem like a common use case either. Right now I am just using the cloud version. I can take a look at my other computers to see if one still has the install on it and the answer to your question.

Thanks. Will check coding.

Also, thanks will follow up on possible coding error

OKay. Did some more looking around and a little experimenting only to find out the line in error should read:

$log_filename = ‘emoncms.log’;

So have now logged in. Now for getting the emonpi and localhost to communicate.

Again Thanks Robert and Frogmore42

To clarify previous message. I’ve finally got the admin screen to see the log file using the following in the settings.php file
$log_filename = ‘D:\wamp64\www\emoncms\’ . ‘emoncms.log’;

was clearly an attempt to construct this:


As you have hard-codeed it,
‘D:\wamp64\www\emoncms\’ . ‘emoncms.log’
is exactly equivalent to
the dot operator ( . ) concatenates the two strings.