Community
OpenEnergyMonitor

Community

Which version of emonhub to use


(Brian Orpin) #1

I currently have the following version of emonhub that has been in use for a long time, possibly I got it from Noah.

Pre-Release Development Version (rc1.2)

Doing some system reorganisation and I want to reinstall it on a new Pi Zero W. I know there have been some developments so I’d rather bring it up to date. However, the GitHub repository simply talks about the ‘emon-pi’ variant so I am wondering what I should install?

The RFM module is the old RFM12Pi V2.6 which again I know needs some specific settings.


(Trystan Lea) #2

Hello @borpin, there’s a long discussion on the status of the different variants of emonhub and what the future direction is here (linked post is summary of work to be done): EmonHub Development. Im working on the indexed inputs part for emoncms at the moment, I know @pb66 is really busy, but wants to at some point review the code and points raised so that we can work towards a single version.

The emon-pi variant is stable, if you want to try out the developments by all means do so. The emon-pi variant name is a bit misleading as it will work on any system. If your happy with your current setup and emonhub version then dont feel there’s a need to switch either.


(Brian Orpin) #3

@TrystanLea, thanks.

Just trying it and I am getting an error (different error - needed some packages installed)

2018-09-26 22:53:58,088 INFO     MainThread EmonHub emonHub emon-pi variant v2.1.1
2018-09-26 22:53:58,091 INFO     MainThread Opening hub...
2018-09-26 22:53:58,093 INFO     MainThread Logging level set to DEBUG
2018-09-26 22:53:58,106 INFO     MainThread Creating EmonHubJeeInterfacer 'RFM2Pi'
2018-09-26 22:53:58,113 ERROR    MainThread Unable to create 'RFM2Pi' interfacer: 'module' object has no attribute 'SerialException'

[edit] should mention I am not using the installer as I am not running Raspbian on my Pi.


(Trystan Lea) #4

Yes I think you need:

sudo apt-get install -y python-pip python-serial python-configobj

and possibly:

sudo pip install paho-mqtt

There’s a little more here in the emonpi emonSD build guide on emonhub installation:
https://github.com/openenergymonitor/emonpi/blob/master/docs/SD-card-build.md

including running the emonhub installer, but that’s for a raspberrypi system

git clone https://github.com/openenergymonitor/emonhub.git && emonhub/install

(Paul Reed) #5

Good question @borpin!
This is the single most divisive issue facing emonpi/self build alignment and has been ongoing for far too long, and raised many times previously.
It would be really nice if @TrystanLea & @pb66 could bring this to some conclusion.

Paul


(Brian Orpin) #6

I’m getting there - and I’ll write it up for the docs when I am done. I raised a similar issue before I discovered :frowning: EmonHub Install - different instructions

@TrystanLea - you are right. I already had pip installed but I installed serial and configobj via pip as well as paho-mqtt. I’m not familiar enough with the process to understand the difference between installing via apt-get or pip.

I also rewrote the emonhub.service file based on the work by @Greebo for service-runner as well as modifying the install method.

Finally I amended my ‘emonhub.conf’ file in line with https://github.com/openenergymonitor/emonhub/blob/emon-pi/conf/emonhub.conf - I am not sure I have that quite right though as I do not use the mqtt interface, just the HTTP one and the emonth setup seemed completely different.

I still get the error I posted above but I realised overnight that I seem to remember there is a need to disable the serial console and I also did not check the name of the serial port.

@Paul can you remind me if I am right about the serial console and how to check which is the right serial port please?


(Brian Orpin) #7

I Realised that my plan had a major flaw. I’m using the Pi Zero for presence detection via Bluetooth and I can’t do Bluetooth and use the UART at the same time. So for the moment, it is staying where it is.