Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Update to the iOS app

Tags: #<Tag:0x00007f1be273c1e8> #<Tag:0x00007f1be2743f60> #<Tag:0x00007f1be2743a10> #<Tag:0x00007f1be27436c8>

Hey everyone. It’s been a long time since we did an update to the iOS app, but I decided to take a look at it when iOS 14 was rolling out because I wanted a widget to put on the home screen to show feeds.

I’m pleased to say that after a bunch of work, I’ve got something I want to share with folks before doing a submission to Apple for a full release.

The main new features are:

  • iOS 14 widgets. These are a really nice way to have feed data always accessible. The previous version of the app had a Today widget, which is still available, but these new home screen widgets are much better.
  • Dark mode support. It’ll switch with the system setting. Nice addition for folks who use dark mode (like me!).

There’s also a bunch of little fixes and tweaks which I think make the app a little smoother.

If you’re interested in testing this out before a full release to the App Store then you can sign up by clicking here: https://testflight.apple.com/join/LREu9f4l . You’ll get the new build as soon as Apple have approved it for testing.

Let me know what you think!

Here’s some screenshots:

3 Likes

Ooh, exciting - looks good.

I just clicked on the link on my iPhone but it says “This beta isn’t accepting any new testers right now”. I’ll try again tomorrow to see if the status changes.

FWIW, I already had Test Flight installed for a different app.

1 Like

That looks really nice @mattjgalloway wow! love the widgets!

Thanks!

The TestFlight link should be up soon - Apple are taking ages to approve for testing for some reason. Maybe because there hasn’t been an update for a while.

1 Like

Well Apple still haven’t reviewed it, but I pushed another update onto their queue tonight with some small bug fixes from testing I did today.

The widgets are pretty nice I think! I want to try to do a MyElectric / MySolar / MySolarDivert widget. It’s not trivial though sadly. But I might be able to get it done sometime.

1 Like

Finally it was approved for beta testing! Please if anyone can spare some time - go and use the beta and let me know if you run into any issues.

I’ve been tweaking the style of the widgets a little bit since I posted about this update. I’d be interested in anyone has feedback on how they look and their usefulness.

I’ve just installed the new version (on top of my exiting OEM app), and it seemed to go well, and my existing data (Inputs, Feeds, Apps etc) came across in to the new version.

I have set up one Widget, and it displays well. The only thing that slightly confuses me is that when selecting which Feeds are going to be displayed all of them show up under “EmonPi”, and the EmonTx names that the Feeds originate from don’t appear. Is this right? Makes selecting the Feeds harder than it might otherwise be.

Also, all of the Feed names are duplicated - not sure whether that is me or the app!

Will play some more tomorrow, but initial impressions are very good!

1 Like

Great stuff! That’s good to know that the upgrade path worked for you. I of course test that, but it’s always a scary bit that it’s good to get positive signal on during beta testing.

The duplicates might be because you are logged in twice in the app? Go to Settings > Switch Account to see if there’s multiple.

I’m not sure I 100% follow on the issue of the names in the list. Are you saying that it would be good to know the node that the feed comes from in the list as well? That does make sense and to even sort by that as well. I’ll whip that up. Is that what you meant?

Great! Let me know any other thoughts you have!

Hi Matt,

I am only logged in once (called “EmonPi / http://192.168.2.50”), so that may be where it picked up what I had thought was the node names previously as I also have a Node called EmonPi - and now I understand it. That said, within the app / Feeds, none of the Feeds are duplicated there so I am still not quite sure why they are in the Widgets selection page.

As above, I had thought that the Widget Feeds selection page was showing all coming from my EmonPi, but I now realise that they were coming from the name of my Account, so that was a red herring - sorry.

However, when I first woke my phone (iPhone X, iOS 14.1 installed over night) this morning, the 3 sections of the Widget showed an error, with no connection; but when I then went in to re-apply the Feeds it had already re-populated the fields. Don’t waste any time on this, but I will see if I can re-create the issue later today / tomorrow morning.

ACTUALLY - it has just happened again, with the phone having been asleep for a few minutes. But this time I couldn’t seem to re-connect them. I then went in to the app and started to Settings > Configure Today Widget; by the time I then looked at my Home Screen the original widget was populated. See attached, including times taken. NB: The rest of my emonCMS system & app is working & updating fine.

@haffle - thanks for the info!

The bug with the “Error loading data” should be fixed in the most recent build that I put up last night. Can you try with that one please?

Also on the feed selection list in the widget - please check out the new build because I tweaked it quite a bit. Let me know what you think!

1 Like

Bug seems squished, and data is being updated - well done! It is also much easier to select a Feed as the Node Names are now shown. :+1:

JAAMOI, what is the updating interval of the feed(s) shown in a widget?

Great!

TIL an acronym!

2 minutes. Apple want it to be not a very frequent update for battery life reasons.

1 Like

@mattjgalloway; I have just upgraded to a new iPhones and transferred everything across, including Test Flight. But when I tap on the widget which asks me to “Error loading data / Select a Feed”, it takes me across to my list of Feeds, but when I tap on one all it does is “open” that Feed to show a graph. But it doesn’t add it to the widget.

Is it something I have done, or something in the app?

TIA

Hmm weird that it didn’t pull across properly to your new phone. I’ll have a think why.

You need to “edit” the widget. Long press on it and select “edit widget”. That’s the standard for widgets sadly and I can’t make it so that if there’s no feed selected a tap goes to the edit screen.

Since all seems to be going well - I’ve submitted the latest build to Apple for the App Store! Should be out as soon as they’ve reviewed it :-D.