Unable to "+++" into emonTH to change node id

Tags: #<Tag:0x00007f6e029f5408> #<Tag:0x00007f6e029f5278> #<Tag:0x00007f6e029f49b8> #<Tag:0x00007f6e029f46c0> #<Tag:0x00007f6e029f4580>

I am trying to change the node id on the 5th emonTH I have just got. The other 4 have been configured using DIP switches, so I’m now using an FTDI serial adaptor to do this. I already had an adaptor I use to reconfigure stepper motor drivers for my 3D printer:

The pinout order of this board’s header is:
DTR, RX, TX, VCC (set to 5v), CTS, GND.
From what I can see from the EmonTH schematic that is the same:

I am using Putty on Windows 7. Baud 115200, 8n1, no flow (also tried xon/xoff). I know my FTDI board works as I have tried a wire link between TX & RX and keystrokes echo in the terminal. When I connect the FTDI board to the emonTH I can see the prompt asking me to press +++ then Enter, but doing this does nothing (shift and “=” key on keyboard, or the + key next to the numpad and either enter key) and after 5 seconds it times out and shows me the data it is broadcasting.

I have tried the same programming lead on another emonTH and I am still unable to +++ enter to get into the node config.

All my emonTH’s are v2.0.2. Any suggestions please?

Cheers :slight_smile:

Mmm it sounds like you are doing everything correct.

What version FW is your emonTH running? V2.0.2 is the hardware version. The emonTH should print it’s version at startup. V3.2.0 onward should support serial RF node ID config:

I’m assuming you have seen the demo video on the post:

I did watch that video clip. Never got to the node config stage because entering +++ enter never seemed to do anything. The emonTH had 3.2.0 on it. Ive just downloaded PlatformIO for Atom, downloaded the latest 3.2.3 software, went straight for build then upload. Using the inbuilt serial terminal within PlatformIO, I could then (after several attempts to connect at 115200 baud) enter +++ then configure node 27.

What is odd now, is that within my EmonCMS input view, it shows up as Node 30 & all the key names are numbers, all the data values are missing decimal places etc:

I think I’ve buggered something up here! I guess some editing of the config and src.ino files is needed…

the emonth has 4 possible node id’s as you probably know. the node id used is set by 2 dip sw’s. It sounds like you have set the base node id to 27 and the emonth has added 3 due to dip sw positions.

Try setting both dip sw’s off or alternatively reprogram again to 24 for a target node of 27 with existing dip sw settings.

The nodenames and value scales are applied in emonhub based on node id, if node 30 isn’t configured in emonhub.conf [nodes] with emonth details, it cannot apply the scales, datacodes and names. Which ever node id you end up running with, try just copying over one of your existing emonth configs to a new entry with the node number you are using, if that node id is already in the conf comment it out as there can be only one entry with any one node id.

Thank you!! That was exactly what happened. I had the 2x DIP switches still ON as I didn’t want to conflict with my first emonTH I had set up which is pulse counting my Gas meter on a hall probe.

Found the emonhub.comf file as you say, copied node 26 details to 27 and gave it a new name. All sorted!

Next stop, mess about with the WiFi MQTT relay board to control the gas boiler.

Cheers :grin:

Fantastic! :slight_smile:

That’s odd. could you post the serial output of the emonTH at startup and your emonhub.log and emonhub.config.

You will need to create the corresponding entry for node 27 in emonhub.conf.

Emonhub can be edited and log downloaded via local Emoncms on emonPi / emonBase