Community
OpenEnergyMonitor

Community

SSH problem with MacOS

Tags: #<Tag:0x00007fc92464dc38>

I am trying to access my emonpi via SSH; I have enabled SSH by holding down the button via the LCD screen, and have typed ssh 192.168.1.150 in Terminal (macOS) and it asks for a password. I have tried both emonpi2016 and emonpi2018 but neither work. Nor does my Emoncms emonpi.local password work. What should I be doing differently?

I want to use the Dataplicity software but AIUI the first thing I need to do is log in to the pi :grinning:

Try ssh [email protected]<IP> and emonpi2016

Thanks @borpin ; Typing in ssh [email protected] returns

[i]Last login: Thu Nov 28 17:25:37 on ttys000
JJB-MBP-13:~ jjb$ ssh [email protected]
The authenticity of host '192.168.1.150 (192.168.1.150)' can't be established.
ECDSA key fingerprint is SHA256:DsgHI4HLC5/uga7o7x3wK1gKMpd0rzdidyvoIuvUDYY.
Are you sure you want to continue connecting (yes/no)?[/I]

I typed “yes” and that returned

[i]Warning: Permanently added '192.168.1.150' (ECDSA) to the list of known hosts.
ssh_dispatch_run_fatal: Connection to 192.168.1.150 port 22: Broken pipe
JJB-MBP-13:~ jjb$[/I]

Typing ssh 192.168.1.150 and then using the password “emonpi2016” returns

[i][email protected]'s password: 
Permission denied, please try again.
[email protected]'s password: [/I]

:flushed:

First you must use the form I said as you are logging in as the user pi to the machine on that IP address.

I presume that

  1. you are on the same network as the Pi?
  2. that IP is the one in the LCD?
  3. you can ping 192.168.1.150?

[edit]
A Google on " ssh mac broken pipe" offers this solution http://www.yellow-bricks.com/2018/11/26/ssh-broken-pipe-osx/

Google is your friend.

Again, many thanks @borpin . I can confirm points 1-3 above are all “yes”, and also that the IPQoS=thoughput tip worked a treat. Thank You!

I have now also managed to get my emonpi to show up within Dataplicity on my Mac as well.