Setup emonTXv3 / emonESP and local emoncms - Feeds are not created

Apologize for my very basic question.

I have this system since Jan. 2019. But i had a corrupted sd-card in my Raspberry Pi3 which runs emoncms. My installation until then has functioned without me having to do anything about it, so my knowledge is a bit rusty…
To start al over again, I downloaded the latest emoncms (emonSD-21Jul21.zip) and installed this on a new sd-card with Etcher.
My home configuration is a singe phase input, a solar system (and recently an EV).
I started the new setup, following the guide for Solar-PV (Solar PV - Guide | OpenEnergyMonitor).
I used the type 2 System installation.
Here i had my fist Issue; The guide speaks about CT1 for Grid input/return and CT2 for Solar.
But when I select emonCMS – Configure Device it says: “Type-2 template usingCT4 for Solar ”. That was not my origional configuration, that had Solar on CT2.

Zo i thought that has maybe changed with this version of emoncms… So i connected the Solar to CT4.

But when i continue with the setup (via this template) and i put the Write API Key in the emonESP config the connection between the two is established:

But i am not able to get the Feeds configured:


As you see the power1 and power4 are not there, consequently the Feeds page has no info.

( I started this process already several times (again flashing sd-card, also tried with the Solar on CT2 as it originally was… but without success)

Please, can anyone help me with this?
Kind regards, Bert

image

Where this says ‘log’ - that is logging to a Feed.

However, the newer setup does not have ‘Power1’, it has ‘CT1’.

@glyn.hudson @TrystanLea - is this a problem with the templates?

Hi Brian, Thank you for stepping in. Really appreciate it.
I have an other question with regard to the Device Key from the Configure Device page. I did save that key, but I am not sure what to do with it; where it will be used… Could that be related with my problem?
I searched the Guide and the community, but could not find anything about it…

@borpin Hi Brian, I was very hesitant to tinker with this configuration, but I started anyway
I made a note of the configuration for power1 and power4, next I deleted all individual settings for power1 and power4. Unfortunately it is not possible to delete power1 and power4 completely, they remain in the Inputs screen.

Next, I created the configuration for respectively power1 and power4 on Inputs ct1 and ct4.
Result:

And now I have Feeds:

Also the Apps for My energy and My solar are functioning again.
I think i will change ct4 for ct2, as I had it before.

I do have a few questions left.

  1. How can i delete the power1 and power4 completely from the Inputs window?

  2. Do you know of an example for the setup op my ct3 for the EV Wall charger?
    BTW, this is not an OpenEVSE Kit but a standard EV-charging unit.

If there might be an issue with the templates (power1 in stead of ct1 etc.) I am perfectly willing to start over again with an new emonCD install if that would be helpful. My data history is lost anyway, so no problem with an eventually new install.

Thanks for your help so far and kind regards, Bert

Edit; Browsing all info about setting up the system, i run into this post from @TrystanLea where the Feeds are differently configured:

Yes this looks like a template issue, looks like the templates are configured fine for data coming in via emonhub but not for the names passed through via EmonESP.

You can select and delete those inputs safely, just click on the selection checkbox and then the delete icon will appear at the top.

I would use first ‘Log to Feed’ at 10s interval and the PHPFina engine and then ‘Power to kWh’ at 10s with the PHPFina engine again.

I dont think there’s a need, it looks like what you have done above in terms of moving the input processing to the ct1 etc inputs will work fine and is what I would have advised.

1 Like