Community
OpenEnergyMonitor

Community

Questions about emoncms 10.0.2 upgrade

Hi,

Recently I have upgraded from emoncms 9.9.5 with a raspberry PI 2 to latest emoncms, 10.0.2, and now I like to give details about some questions that I have detected after this upgrade:

  • Where is backup and restore tool?
  • postprocess, I have a old data to postprocess:
    58532 points behind but executing run postprocess is not updated on 1 of 3 post process, postprocess.log is:
    {“input”:21,“output”:35,“process”:“powertokwh”}
    input meta: {“interval”:10,“start_time”:1546208910,“npoints”:1268025}
    output meta: {“interval”:10,“start_time”:1546208910,“npoints”:1209491}
    -------------------------------------------------------Found and filtered 58534 values ±1MW
    -------------------------------------------------------bytes written: 0
    one question related with postprocess, can be shceduled automatically, for now U’m executing manually…
    last time value: 1558889160 6850809
  • On emonhub.log appears this from fronius Primo with latest firmware
    2019-05-26 18:30:13,040 ERROR ModbusTCP Connection failed on read of register: 40118 : ‘ModbusIOException’ object has no attribute ‘function_code’ --> I think that this error was appearing before emoncms, not sure but maybe is a fronius upgrade, but not sure because only this register returns this error in some querys, not always

I have updated because in some situation graphs were not updated, I’ll try to check if with latest versions this error is solved

Thanks

Click on the settings cog (top right) and you should see ‘backup’ as an option (this is backup/restore - export/import).

To provide more details, in the admin screen, click on the ‘Copy as markdown’ button next to the Server Information heading then paste it in a reply (no further formatting required).
image

What is your setup? An EmonBase (i.e. a Pi with the RFM card fitted). It is possible the RFM card has been updated with the wrong firmware.

Sorry, I can’t help with postprocess.

Hi,

sorry, but I can’t fins backup option, attached screenshot

Is a raspberry pi without ny other componen, on monitoring with modbus tfp fronius primo, I don’t think that is a firmware issue with raspberry, maybe fronius firmware? but only one register? Strange…

details

Server Information

Server Information

Services

  • emonhub :- Active Running
  • mqtt_input :- Active Running
  • feedwriter :- Active Running - sleep 60s 0 feed points pending write
  • service-runner :- Active Running
  • emonPiLCD :- Active Exited
  • redis-server :- Active Running
  • mosquitto :- Active Running

Emoncms

  • Version :- low-write 10.0.2
  • Modules :- Administration | App v2.0.1 | EmonHub Config v2.0.2 | Dashboard v2.0.1 | Device v2.0.0 | EventProcesses | Feed | Graph v2.0.1 | Input | Postprocess v2.0.0 | CoreProcess | Schedule | Network Setup v1.0.0 | sync | Time | User | Visualisation | WiFi v2.0.0
  • Git :-

Server

  • OS :- Linux 4.19.42-v7+
  • Host :- emonpi | emonpi | (192.168.10.4)
  • Date :- 2019-05-27 19:44:38 CEST
  • Uptime :- 19:44:38 up 1 day, 9 min, 0 users, load average: 0.34, 0.37, 0.41

Memory

  • RAM :- Used: 17.71%
    • Total :- 975.62 MB
    • Used :- 172.78 MB
    • Free :- 802.84 MB
  • Swap :- Used: 0.00%
    • Total :- 100 MB
    • Used :- 0 B
    • Free :- 100 MB

Disk

  • / :- Used: 46.53%
    • Total :- 3.81 GB
    • Used :- 1.77 GB
    • Free :- 1.86 GB
  • /boot :- Used: 52.12%
    • Total :- 42.52 MB
    • Used :- 22.16 MB
    • Free :- 20.36 MB
  • /home/pi/data :- Used: 4.53%
    • Total :- 10.66 GB
    • Used :- 494.57 MB
    • Free :- 9.64 GB

HTTP

  • Server :- Apache/2.4.25 (Raspbian) HTTP/1.1 CGI/1.1 80

MySQL

  • Version :- 5.5.5-10.1.23-MariaDB-9+deb9u1
  • Host :- localhost:6379 (127.0.0.1)
  • Date :- 2019-05-27 19:44:37 (UTC 02:00‌)
  • Stats :- Uptime: 87447 Threads: 3 Questions: 80208 Slow queries: 0 Opens: 28 Flush tables: 1 Open tables: 22 Queries per second avg: 0.917

Redis

  • Version :- 3.2.6
  • Host :- localhost:6379
  • Size :- 286 keys (789.46K)
  • Uptime :- 1 days

MQTT Server

  • Version :- Mosquitto 1.4.10
  • Host :- localhost:1883 (127.0.0.1)

PHP

  • Version :- 7.0.33-0+deb9u3 (Zend Version 3.0.0)
  • Modules :- apache2handler | calendar v7.0.33-0+deb9u3 | Core v7.0.33-0+deb9u3 | ctype v7.0.33-0+deb9u3 | curl v7.0.33-0+deb9u3 | date v7.0.33-0+deb9u3 | dom v20031129 | exif v7.0.33-0+deb9u3 | fileinfo v1.0.5 | filter v7.0.33-0+deb9u3 | ftp v7.0.33-0+deb9u3 | gd v7.0.33-0+deb9u3 | gettext v7.0.33-0+deb9u3 | hash v1.0 | iconv v7.0.33-0+deb9u3 | igbinary v2.0.1 | json v1.4.0 | libxml v7.0.33-0+deb9u3 | mbstring v7.0.33-0+deb9u3 | mcrypt v7.0.33-0+deb9u3 | mosquitto v0.4.0 | mysqli v7.0.33-0+deb9u3 | mysqlnd vmysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $ | openssl v7.0.33-0+deb9u3 | pcre v7.0.33-0+deb9u3 | PDO v7.0.33-0+deb9u3 | pdo_mysql v7.0.33-0+deb9u3 | Phar v2.0.2 | posix v7.0.33-0+deb9u3 | readline v7.0.33-0+deb9u3 | redis v4.1.1 | Reflection v7.0.33-0+deb9u3 | session v7.0.33-0+deb9u3 | shmop v7.0.33-0+deb9u3 | SimpleXML v7.0.33-0+deb9u3 | sockets v7.0.33-0+deb9u3 | SPL v7.0.33-0+deb9u3 | standard v7.0.33-0+deb9u3 | sysvmsg v7.0.33-0+deb9u3 | sysvsem v7.0.33-0+deb9u3 | sysvshm v7.0.33-0+deb9u3 | tokenizer v7.0.33-0+deb9u3 | wddx v7.0.33-0+deb9u3 | xml v7.0.33-0+deb9u3 | xmlreader v7.0.33-0+deb9u3 | xmlwriter v7.0.33-0+deb9u3 | xsl v7.0.33-0+deb9u3 | Zend OPcache v7.0.33-0+deb9u3 | zlib v7.0.33-0+deb9u3

Pi

  • Model :- Raspberry Pi 2 Model B Rev 1.1 - 1 GB (Embest)
  • SoC :- Broadcom BCM2835
  • Serial num. :- 34FA5044
  • Temperature :- 45.46°C - 45.5°C
  • emonpiRelease :- emonSD-30Oct18
  • File-system :- read-write
Client Information

Client Information

HTTP

  • Browser :- Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0
  • Language :- ca,en-US;q=0.7,en;q=0.3

Window

  • Size :- 2125 x 1079

Screen

  • Resolution :- 2144 x 1206

I have tried to create another prostprocess using same feed, but is noct reated… corrputed?

Thanks

Missatge de Brian Orpin via Community [email protected] del dia dl., 27 de maig 2019 a les 8:24:

Can you post the update log please?

Put 3 backticks (top left of keyboard) on a line before and after the paste of the log please.

Hi,

Where is update log?

Missatge de Brian Orpin via Community [email protected] del dia dt., 28 de maig 2019 a les 13:45:

Admin page

# cat emonpiupdate.log
Starting emonPi Update >
via service-runner-update.sh
Service Runner update script V1.1.1
EUID: 1000
Argument: all
Sun 26 May 18:20:05 CEST 2019

Thanks @klxout is that the full content of your update log?, if you click on “Copy Log to Clipboard” it should copy the whole thing, should be several hundred lines.

Right, all log, but i think that update was executed two times to confirm that latest update was applied

It shouldnt matter how many times you run update, it should run through the whole update again.

The missing backup module in the menu sounds to me like the backup module has not updated on your system. If you are comfortable with SSH you can check its status with the following commands:

cd /home/pi/backup
git status

you could then try updating it with:

git pull 

if you have a local change it may not update and that may be our problem, could you let me know what you see?

Another option to try is to run a full update manually you can do this with the manual update steps described at the bottom of the page here: https://community.openenergymonitor.org/t/upgrading-emonsd-07nov16-to-latest-via-emonpi-emonbase-update/11051

Hi,

output

cd /home/pi/backup

[email protected]:/home/pi/backup# git status
On branch stable
Your branch is up-to-date with ‘origin/stable’.
nothing to commit, working tree clean
[email protected]:/home/pi/backup# git pull
remote: Enumerating objects: 4, done.
remote: Counting objects: 100% (4/4), done.
remote: Compressing objects: 100% (4/4), done.
remote: Total 4 (delta 0), reused 1 (delta 0), pack-reused 0
Unpacking objects: 100% (4/4), done.
From https://github.com/emoncms/backup

  • [new branch] log_location -> origin/log_location
    Already up-to-date.

seems all ok… any suggestion?

Thanks

Missatge de Trystan Lea via Community [email protected] del dia dc., 29 de maig 2019 a les 22:39:

About this url:
https://community.openenergymonitor.org/t/upgrading-emonsd-07nov16-to-latest-via-emonpi-emonbase-update/11051

with a raspberry pi2 waht option can I use?

Run the automatic update process (emonpi hardware):

/home/pi/emonpi/service-runner-update.sh all emonpi

emonbase (rfm69pi) hardware:

/home/pi/emonpi/service-runner-update.sh all rfm69pi
what?

Missatge de klxout [email protected] del dia dc., 29 de maig 2019 a les 22:57:

which hardware apart from pi2 do you have? You can actually skip the firmware upload step with the following version of the command if you dont have emonpi or rfm69pi hardware

/home/pi/emonpi/service-runner-update.sh all custom

Executed update:

# /home/pi/emonpi/service-runner-update.sh all emonpi

I have this same issue. Updated my stock emonpi to 10.0.2 and now on to 10.1 and I have no backup option. Tried running manual update, no change. The backup option is not available in the cog dropdown…

image

[email protected]:~/backup $ cd /home/pi/backup
[email protected]:~/backup $ git status
On branch stable
Your branch is up-to-date with 'origin/stable'.
nothing to commit, working tree clean
[email protected]:~/backup $ git pull
Already up-to-date.
[email protected]:~/backup $

From manual update:

    ------------------------------------------
    Updating backup module
    ------------------------------------------
    - git branch: stable
    - git tags: 2.0.0-12-g67a1f1d
    - no local changes
    - running: git pull origin stable

    From https://github.com/emoncms/backup
     * branch            stable     -> FETCH_HEAD
    Already up-to-date.

I have the same issue following a Full Update. The config files for the backup need to be set up again with the correct paths, which got backup working again, but I still don’t have a link to it.

The more serious issue is that Emonhub is not starting, and it appears to be a similar issue, as the config appears to be out of date and the paths in the config files don’t match my system. I am trying to run the update again, and at the moment the log is filling up with lines saying:

Writing | avrdude-original: stk500_loadaddr(): (a) protocol error, expect=0x14, resp=0x1c

avrdude-original: stk500_cmd(): programmer is out of sync
avrdude-original: stk500_cmd(): programmer is out of sync
avrdude-original: stk500_recv(): programmer is not responding
avrdude-original: stk500_recv(): programmer is not responding

I had the same lines in the first run of the update, which does eventually complete, but it looks like I might have to wipe the system and start again if it does not work this time.

After a lot of playing around, I have got Emonhub working again. The config in emonhub.service file did not match the config in my system, so the service was not starting (for example, it was not looking in /home/pi/data for emonhub.conf, which is where the Emonhub link on the web interface pulls it from). The links in the emonhub.service were:

Process: 3892 ExecStart=/usr/local/bin/emonhub/emonhub.py --config-file=/etc/emonhub/emonhub.conf --logfile=/var/log/emonhub/emonhub.log (code=exited, status=203/EXEC)

After all that, there is still no link to the Backup!

No emonhub issues for me. Not sure if anyone can point us in the right direction to rediscover backup however. Happy to post any and all config or logs that may lead to a clue…

@TrystanLea - something potentially not quite right with the update script.

Can you tell us what the base system is? Is it an EmonSD (the version will be in the admin screen)?