OpenEVSE new user interface, testers & translations needed

A very small thing- spelling of “developer” (not “developper”).

Another thing- perhaps coming?

Need to be able to set a charge limit with “handle self production” when car not connected.

Example: I set “handle set production”, limit 4kwhrs, limit 14amps with car disconnected. Away next day but tell my wife she can plug the car in after shopping and it will start when and if enough solar and then put it a defined amount of charge & then go back to sleep.

I like the snappy new interface.

I have set time= “Sydney/Australia”. However date is being shown in American format.

Another issue. I tried the Self Production setting but it started charging as soon as the car was plugged in, even though there was not nearly enough excess solar. Worked okay with V1.


I had this issue after updating and had to turn off eco and then back on and it has behaved OK since.


Thanks for your inputs.
The charge limit stuff you are talking about is a firmware feature but not related to UI yet. You can ask for feature request on related git btw.

I’d like to deepen your time issue . It’s surprising as it use locale from browser ( or system depending of browser ) .
Do you have your browser language / locale set to Aus too?

Yes, browser is set correctly. However it is the BRAVE browser and Firefox is okay. So presumably a browser issue. Chrome is also wrong even though locale okay. Brave is based on Chrome.

So please ignore and I’ll treat that one as a local issue.

However I cannot make self-production work. The feed is okay and I can see the data coming in and updating the watts and the update time. However available current always sits at red zero.

Worked fine at V1 and I’ve been using it for a couple of years.

There’s no fw change here. Gui has nothing to do with divert, it’s just displaying published data.

Well, something is wrong with it. I just put back V1 firmware and divert is now working properly again.

As I mentioned earlier, one indication is that the import/export data is showing correctly (in green). The update intervals are also showing correctly (in green) but the available current (or some such description) is ALWAYS showing as zero and is red. Perhaps that has something to do with it or is a symptom?

When you say switching to V1 you mean same firmware dev version but with V1 UI?

That’s what you should test to eliminate firmware issue.

Also it should display the PV production or grid +i-e value it got from Mqtt. Is it ok?

Correct. I am switching between latest 4.1.17 V1 UI WiFi software and the V2.

However, interesting, after switching back to V1 (where Eco mode is working), I reinstalled V2 and now available and smoothed current are updating correctly. So it seems to be behaving correctly now. Will do some more testing when the sun has fully risen (over the trees).

1 Like

In my SW Engineering days, this was always caused by an un-initialised boolean.

It’s working well now.
I like the new screen arrangements and button groupings on the Eco-divert screens.
Great work- well done!
I am running 3 phase firmware and there is an inconsistency (for me) between kW and kWhrs on single phase but I’ll leave that for now while I think about the ramifications. It was also an issue with the older UI but in a different manner. Probably not an issue for 99% of people and I’ll probably end up with some specific mods to the firmware.

Yes there’s still inconsistencies with triphased. I have to rework shaper for this, calculation is wrong.

I have also opened another thread here about rewiring L1 L2 L3 through the core to have correct measurement for triphased without changing the code.

This would be the best solution instead of configuring mono/tri on the interface. This would work either for mono or tri sessions.

@doggy I think I’ve found what was wrong with divert on UI, and fixed it in latest build ( hopefiully :slight_smile: )

Thanks. I’m away for a few days but will give it a good try next week.
I’m happy enough in general to stick with the new UI from now on.

I still have a bunch of things to finish before rc4, I hope to finalise this before end of next week and should enter feature freeze.

Love the new web GUI, and the changes to how solar divert is displayed. Great work.

I’ve noticed I now have a No Ground error = 1. Which I never saw in the old firmware. Everything otherwise works normally. My OpenEVSE firmware version is 8.2.0.EU. OpenEVSE Wifi: 4.1.7, still the same in the one from this morning.
I think I saw someone else having a similar problem?


PS. I reflashed the old GUI and can’t find anywhere to view errors. And I looked at system tab / debug and openevse terminal and couldn’t spot any errors. Maybe the error was there all along from some long distant testing on my part? There’s no message on the LCD during boot. I’ll double check the hardware.
I saw this thread earlier: No ground fault after upgrading OpenEVSE v5 controller to D8.2.0


I have the same but ignored it as has not given any problem charging and has not gone above 1


This seems to be related to openevse module firmware. UI displays what it received from api endpoints perhaps old UI had a bug displaying the fault, can you check the Json from /status ?
. I never got this issue on 5.5 module btw


I don’t see anything on