OpenEVSE new user interface, testers & translations needed

Well, something is wrong with it. I just put back V1 firmware and divert is now working properly again.

As I mentioned earlier, one indication is that the import/export data is showing correctly (in green). The update intervals are also showing correctly (in green) but the available current (or some such description) is ALWAYS showing as zero and is red. Perhaps that has something to do with it or is a symptom?

When you say switching to V1 you mean same firmware dev version but with V1 UI?

That’s what you should test to eliminate firmware issue.

Also it should display the PV production or grid +i-e value it got from Mqtt. Is it ok?

Correct. I am switching between latest 4.1.17 V1 UI WiFi software and the V2.

However, interesting, after switching back to V1 (where Eco mode is working), I reinstalled V2 and now available and smoothed current are updating correctly. So it seems to be behaving correctly now. Will do some more testing when the sun has fully risen (over the trees).

1 Like

In my SW Engineering days, this was always caused by an un-initialised boolean.

It’s working well now.
I like the new screen arrangements and button groupings on the Eco-divert screens.
Great work- well done!
I am running 3 phase firmware and there is an inconsistency (for me) between kW and kWhrs on single phase but I’ll leave that for now while I think about the ramifications. It was also an issue with the older UI but in a different manner. Probably not an issue for 99% of people and I’ll probably end up with some specific mods to the firmware.

Yes there’s still inconsistencies with triphased. I have to rework shaper for this, calculation is wrong.

I have also opened another thread here about rewiring L1 L2 L3 through the core to have correct measurement for triphased without changing the code.

This would be the best solution instead of configuring mono/tri on the interface. This would work either for mono or tri sessions.

@doggy I think I’ve found what was wrong with divert on UI, and fixed it in latest build ( hopefiully :slight_smile: )

Thanks. I’m away for a few days but will give it a good try next week.
I’m happy enough in general to stick with the new UI from now on.

I still have a bunch of things to finish before rc4, I hope to finalise this before end of next week and should enter feature freeze.

Love the new web GUI, and the changes to how solar divert is displayed. Great work.

I’ve noticed I now have a No Ground error = 1. Which I never saw in the old firmware. Everything otherwise works normally. My OpenEVSE firmware version is 8.2.0.EU. OpenEVSE Wifi: 4.1.7, still the same in the one from this morning.
I think I saw someone else having a similar problem?


PS. I reflashed the old GUI and can’t find anywhere to view errors. And I looked at system tab / debug and openevse terminal and couldn’t spot any errors. Maybe the error was there all along from some long distant testing on my part? There’s no message on the LCD during boot. I’ll double check the hardware.
I saw this thread earlier: No ground fault after upgrading OpenEVSE v5 controller to D8.2.0


I have the same but ignored it as has not given any problem charging and has not gone above 1


This seems to be related to openevse module firmware. UI displays what it received from api endpoints perhaps old UI had a bug displaying the fault, can you check the Json from /status ?
. I never got this issue on 5.5 module btw


I don’t see anything on

it is here.There’s either an error, or evse fw bug

Does that count increment on each boot if there are on going ground errors? I have a usbASP on the way to flash the OpenEVSE firmware. I’ll check hardware, flash and see what happens then.

The incorrect spelling “Developper” is not fixed on the settings config page.

The latest UI is working well for me.

@doggy, can you try the latest build, I’ve pushed a new triphased fw setting on wifi module, you can set it from UI v2 / config / EVSE

It should now display amps x 3 , power calculation should then be ok, and current/shaper divert too.
Can you confirm this ? Thanks

I’ve updated and spelling of “developer” is corrected so definitely the latest.

But, with “3 Phase= no”, the amps are correct and also the kW but the kWHrs are three times what they should be. Probably the EVSE firmware is reporting triple? If so, it would be good if that could be divided by 3. But maybe then non-3phase EVSE firmware would give the wrong answer through the GUI? Eco divert is working well (because the kW calculation is correct.)

With “3 Phase =yes”, the amps are correct (amps for each phase). The kW are correct. The kwHrs are correct and incrementing properly. Eco divert is fine.

I don’t have a way to test the shaper.

I most frequently use my OpenEVSE on single phase at home and three phase on a trip.

the kwh displays comes from the Evse module.
It depends of the fw you have inside, if it’s tri firmware there it factors by 3.
There’s no way for now to have correct kwh for booth mono/tri on same evse module.

We would need to move the kwh counter on the wifi module first. Factoring/dividing by 3 on the wifi module as a hack would work for the current session but the total will still be wrong.
UI just display what it receives btw.

Yes, I understand.

With U1 what I have always done is a little “hack” but it works.

When plugged into 3 phase, everything okay. Power, energy, amps.

When I am plugged into single phase (nearly always at home) I have a MQTT publish to voltage of 77volts. The OpenEVSE then does all the correct things. The current is still correct. The calculated and displayed power in kW is correct. The accumulating kWHrs is also correct both for the current charge session and also the all-time record from EVSE firmware. Of course the displayed voltage is wrong but that is not a problem because I know I have changed it and the EVSE does not measure it.

If I have 3phase set to no with U2 and voltage topic 235V, plugged into single phase, the amps are correct and also the power but energy increments at three times the real rate. If I publish 77V to the voltage topic, then the amps are still correct but the power is shown as one third of the actual and the energy increments correctly. But the Eco Divert totally misbehaves (because of the one third power calculation).

But maybe setting 3phase on and publishing 77V will work. I am testing that now and it seems to be working okay. Unfortunately it is very cloudy thus making testing the Eco divert a little difficult.

So now with U2 and plugged into single phase with 3 phase firmware, it is possible that setting the 3phase switch in U2 to “on” and publishing 77Volts makes it perform correctly with Eco divert and energy accumulation and power calculations.