OpenEVSE Home Assistant Integration

Tags: #<Tag:0x00007f10a7ecafb8>
(Glyn Hudson) #1

For completeness, here’s the Home Assistant OpenEVSE sensor component. Let me know how you get on if you mange to test this:


Significant OpenEVSE WiFi 2.0 Firmware Update. Call for beta testers
(Jake) #2

I tried to implement that in my configuration.yaml file but it probably belongs in sensors.yaml because nothing showed up. I ran out of time to test, and now I’m in Munich waiting for my connecting flight.



(Glyn Hudson) #3

I’m pretty sure you can added it to either file. The yaml syntax can be quite picky. See my openenergymonitor example where I added sensor info to confuguration,yaml. Probably not best practice but works for simple setups:


(Jake) #4

Hi Glyn,

I managed to get one of my OpenEVSE units working with the new firmware, I have Hassio loaded in docker, I installed emoncms with docker, and I have the OpenEVSE posting to emoncms. Not going to lie, I feel pretty accomplished right now.

However, what I really want to do is ‘see’ if the car is connected to the OpenEVSE as a condition for presence detection if I can. I can get empty icons by using your configuration example above, but I don’t have those parameters set up in my emoncms, and I’m not even sure if ‘status’ exists.

Any pointers?

1 Like

(Jake) #5

I have managed to get values in the icons now. I’ve been trying to convert the temperature to F, which I can see in emoncms, but not in hassio. Also, my car finished charging just about the same time I made the tweaks for the current reading, so I’m not sure if it’s correct or not.


(Glyn Hudson) #6

Nice work @jakekooser, that sounds really great :+1:

It would be cool if you could share your .yaml setup and some screenshots to show off your setup.

I’ve finally got round to testing the OpenEVSE Home Assistant integration myself, however I’ve not been able to get it to work. I’ve entered the following into my config.yaml file, after a restart the metrics do not display and there are no errors in the logfile, any ideas?

  - platform: openevse
    host: 192.168.XX.XX
      - status
      - usage_session
      - charge_time

(Jake) #7

Hi Glyn,

I am not sure if I ever got it working the way I wanted to with the IP address. I do know I enabled MQTT and just ended up connecting that to my MQTT server and it’s working fine.

This is what I have in my sensors.yaml file - I separated it out from the main configuration.yaml to save space.

### Smart car charging amps

- platform: mqtt

name: OpenEVSE amps

state_topic: "car/charging_amps"

unit_of_measurement: 'amps'

### Smart car connection status

- platform: mqtt

name: OpenEVSE status

state_topic: "car/status"

### OpenEVSE total KWh

- platform: mqtt

name: OpenEVSE KWh

state_topic: "openevse/kwh"

I use node-red to process the reading I get from the OpenEVSE like so:

I use a state-machine node to process the connection status from the EVSE to tell me on my phone (VIA MQTT message) if the car is charging, connected, or disconnected like so:

And that allows me to see a graph on a Lovelace history-graph card, and display the charging status and current as entities


Here’s what the graph looks like, I just came back from a dinner party and plugged the car in.


For me, it was easiest just to jump in with MQTT, since I really didn’t have much understanding of the Open Energy Monitor stuff. I still don’t really have a perfect grasp of MQTT, but it allowed me to get the information I wanted to see easily enough.

Hope this helps!


1 Like

(Glyn Hudson) #8

Thanks, I agree MQTT is the best way to do this. I’ve just seen an open issue on HA github discussion the openevse component:

User TonyApuzzo has developed a MQTT based solution which looks very good:


(Jake) #9

That looks pretty nice as well. I haven’t really needed any more information than my setup gathers. I really need to sort out a node-red automation to remind me if the car is not plugged in.