Significant OpenEVSE WiFi 2.0 Firmware Update. Call for beta testers

I managed to get it working on my portable unit, but the one mounted in my garage won’t take the update. Disappointing. I’ve played with it a little bit and everything looks good so far. I’ll see if I can get it to talk to HASS tomorrow.

Nice work, what do you mean by “won’t take the update”. What’s the issue? What errors do you see? What steps are you using to do the update?

Is it possible to use a network connection instead of a WIFI?

I used a USBASP v2.0 to program the portable one, noting pin 1 to the yellow wire, etc, but when I went outside to the garage to program the installed one, running flash.bat with the same cable connected to the other unit fails, saying something about unit not found. I didn’t think to take screenshots of it, but the display isn’t working now and it’s not happy. I even tried to program it using a FTDI friend to the pins where you would connect the ESP8266 to and no luck.

I’m flying out for work this evening, so I don’t have time today to fool with it. I’ll resume on Thursday of next week when I get back. I was able to get the portable unit working, so at least I can charge my car before I go to the airport. I also got the wifi working on it, so worst-case scenario, I would just swap the two units, as I really haven’t ever used the portable one out in the wild.

My installed unit is an older 50A unit and the portable one is a 30A unit.

Are both units V4 controller? Do they both look the same?

Often ISP programmers don’t supply power to the unit, you may need to have the power the openevse switched on while programming. Be sure to plug in the programmer before switching the power on and proceed with caution.

I’m afraid this won’t work since the openevsed controller does not have a serial bootloder, it’s ISP program only.

3 posts were split to a new topic: OpenEVSE Home Assistant Integration

I can not go through the web in the wifi module settings

Hi @DimaBY,

Have you got a different browser you could try? Issues have been reported with older versions of internet explorer. Recommend using Edge/Chrome/Firefox/Safari or smartphone browsers work well.

I tried on Google and iphone se

Could you post a screen shot showing which version you are running? Version number should be at the bottom of the page

it’s impossible to go further

I finally got home from this work trip and I have to get my OpenEVSE working. I tried programming it per the instructions at but all I get is an error as below.

I am using a USBASP V2.0 with the OpenEVSE powered from the wall, I have double checked my physical connections and reloaded the driver for the USBASP all to no avail.

I figured it’s better to ask a stupid question here before I make it to the drawer full of hammers in the toolbox.

Any advice? What simple thing am I missing here? Would Linux help? I have another computer next to the thing running linux rather than my Win 7 64 bit laptop.

It looks like you’re nearly there. Double check your connections, it could either be that you have some pins mixed up on the ISP connections or your ISP programmer does not power the unit. Try again with the unit powered up. Be sure to close the enclosure and stay safe if powering from the mains. You can also power via 5V DC via UART header which is safer.

I tried every possible iteration that I have available to me - USBASP v2.0, Sparkfun Pocket AVR programmer, FTDI programmer, AVRdude on Linux, Windows 7, Windows 10, Arduino IDE, nothing and no combination of those things worked - every single one comes back with ‘Target doesn’t answer’. I even added the J3 jumpers to the USBASP for ‘slow’ programming, to no avail. I can’t have my main charger not working, so I swapped the lead going to the car with my 30A unit that I had built to be L1/L2 as a portable unit and replaced the dead unit with it.

Now, I at least have a functional EVSE, but the 50A unit I took down doesn’t do anything at all, and I have no idea how to access it for reprogramming.


Off topic, I am on v2.7.0. Can I upgrade to v 2.7.3 over the air? I do not want to mess it up as it seems to be working well.
Thanks for any help.

I don’t have an OpenEVSE but I have my own NodeRed flow to do much the divert logic against an ABL EVCC. I have found that the PWM can be varied at the lowest granularity and that my Outlander happily tracked the available current at a 0.06A resolution. The graph in the first post seems to be at a 1A granularity - if this is the decision tree I do suggest trying floating point :slight_smile:

Yes, we’ve extensively tested updating from 2.7.0 to 2.7.3 via the HTTP updater in the web UI with no issues. It should always be safe to update to latest stable release version using HTTP updater. The releases are always tested before release.

Nice! that’s interesting. I think 1A increments is adequate for most use cases.

Thanks Glynn!