On update problems with dashboards

Just created an account to post this reply to a helpful thread… :nerd_face:

A few days ago I upgraded from 9.x (I can’t remember exactly which version) to 10.2.0. Ubuntu in VM (on Hyper-V) just taking feeds from some power monitoring gear. It’s been great for at least 9mo and has helped me make many decisions around power usage, new PV, etc… so firstly a big thumbs up for the software!

Now to the bug. Before the upgrade, I’ve had a couple of dashboards with mixed graphs and dials running really well. As soon as the upgrade happened, the non-authenticated dashboards would not show the dials - none of them - but the graphs work fine.

I’m not sure on exactly the timezone in emoncms (I can’t find any setting there) but the VM is set to GMT+10, no DST.

In this thread I saw the ‘virtual feed breaks it’ comment and that was definitely true for me. I had a single virtual feed, basically source ‘power used total kwh/day’ - ‘solar generated kwh/d’ giving me ‘kwh/d from grid’.

I’m running authenticated to emoncms in firefox on Win10-64 on my desktop and had edge open for the ‘view only’ (non-auth) dashboard and, no jokes, as soon as I clicked ‘delete’ on the virtual feed and ok’d it, the non-auth view dials appeared and jumped to life. Within the second of the del happening. Very weird.

Anyway, I created the account here to help try and troubleshoot this and post what my experience has been. If you want data (builds, etc) please let me know what you want and I’ll post it… I’m new-ish (and definitely inexperienced) with emoncms but I can find my way around most OSes if I know what is needed.

Thanks again for great software. :+1:

1 Like

Welcome, Simon, to the OEM forum, and thanks for the information and the offer of more. I’m glad you have it all back again. I’m sure those looking at the problem will be in touch if they need more details.

1 Like

Edit the dashboards, move something to force an update, and everything may well work fine.

Thanks for the ideas… however I had tried with no luck (ie dials still not visible):

  • Moving dials around
  • deleting dials
  • creating more dials
  • nothing from the ‘dials’ menu would work; anything I tried from the graphs would

Then I deleted the virtual feed and everything sprung to life. I’m not sure of the back end code, so I can’t say what has an interdependency on being authenticated, the virtual feeds and dials… but there’s a bug there, somewhere.

1 Like

@TrystanLea @emrys

hi @ssau
this might be related to the timezone issue you mentioned…

If the changes in the pull request (linked in above post) fix the issue the changes should be added to the ‘stable’ version of EmonCMS you’ll then be able to update again to get the fix.

I thought I’d get into the ‘how to recreate’ this bug.

I created a virtual feed (i had to go to zero virtual feeds in order to make my public dashboards work again, as per earlier in this thread).

Then I created a simple dials dashboard.
watts used [real feed] ‘minus’ solar generated [real feed] ‘equals’ grid use now [virtual feed].

Public dashboard is on left (Edge) and logged in on right (Firefox). It’s not a browser thing - I can swap them around easily enough and get the same result. You can see the virtual feed dial is missing.

Happy to be told I’m doing something wrong… or to provide more feedback / checks.

1 Like

I also just noticed that when I originally posted my message (top of this thread) my unauthenticated page was showing no dials at all with the virtual feed even existing (i.e. no virtual feed dial was on the page - the virtual feed simply existed in the system). However now I’m only getting the virtual feed’s dial disappearing.

This could be related to the fact the bug only appeared as I had upgraded from 9.x, so it may have been a different dial ordering on the page or something.

In my recreation just now, I should also note I created the virtual feed first, then the dials from left to right; i.e. the virtual feed dial was the last dial I created, then saved the dashboard. (I then added the two text fields, for clarity; re-saved.)

1 Like

…so I thought “that was a virtual realtime, what happens if I add a virtual daily feed?”

Well, that breaks all the dials.

I created a new virtual feed with just the source of my daily kWh/day in it.

Now all the dials on all my dashboards are gone, whether the dashboard uses virtual feeds or not. All dials, all gone.

If I then click ‘delete permanently’ on that virtual daily feed, all the dials spring to life. (Quite literally, as soon as the virtual daily feed is deleted the dashboard on my unauthenticated Edge browser has all the dials magically reappear without refresh/reload. It’s like they can’t access their data while the virtual daily feed exists. :thinking:

Since my day is only starting, I better get to the office… happy to troubleshoot more this evening (Australian time) if anyone has ideas to narrow this down?

1 Like

It does appear that it’s not a browser issue. But, both FF and Edge have idiosyncrasies.
Have you tried Chrome, or any other browser besides Edge and FF?

This definitely isn’t a browser issue. I’ve tried it on Win10 (Edge, Chrome, FF), Mac OSX (Safari & Chrome), iOS and two (admittedly older) Android tablets.

Eg: Win10 Chrome (it screenshots poorly, I think due to HDR handling issues)

iOS screencap

Thanks for all the effort posting ‘how to recreate’ info.

I seem to be able to create a dashboard here with realtime virtual feeds that work whether authenticated or not.

Did you make your virtual feed public? as well as the source feed?

daily virtual feed in a bar graph however is giving me an error (when logged out):

I’ve fixed the bar graph / daily virtual feed issue in the emoncms master branch. (commit fetch userid from feed table alongside datatype, remote static cache. · emoncms/[email protected] · GitHub). This will be available in the stable branch for updating via emoncms ui updater at the next release.

Good spot - with all the create-delete-recreations, I’d missed making the virtual realtime feed public again! So now the virtual realtime works in unauthenticated mode. :smiley: :+1:

(I think part of me missing the ‘public’ setting is how much the UI has changed, for the better, since the 9.x releases where I have been comfortably sitting for a while. Took me a moment to find the public checkbox.)

Once I see the update hit my systems, I’ll try to recreate the virtual daily feed and go from there.

Great work, thanks!

To confirm, the 10.2.1 update seems to enable virtual feeds in dials on public dashboards - both realtime and daily virtual feeds work for me in 10.2.1 (they did not work in 10.2.0). Nothing else has changed on my system, other than updating the core code.

Thanks for all your work on this, coders!

1 Like

Thanks for letting us know @ssau