Community
OpenEnergyMonitor

Community

No Inputs information, No LCD information

emonpi
emoncms
Tags: #<Tag:0x00007f1be6e7c8a0> #<Tag:0x00007f1be6e6fe48>

(Joao Sampaio) #1

Hello,

I’ve just bought a EmonPi for shop with 2 CTs and 1 Temperature sensor and I’m trying to set it up.

Have flashed the emonSD-30Oct18 and boot up the system and configured new Device has “HomeEnergyMonitor”.

But in the Inputs there is no updates of the CT1. Also there is no Input created for the Temperature sensor.

  • What have to done additionally to have CT1 reads values?
  • How to add the temperature sensor Input?
  • How to add the CT2 sensor?

Additionally, the LCD display is lighted on, but does not display any information, even pushing the black button.

Please find attached screenshots, photos collected from the EmonPi.
If there is needed a specific log from the system please let me know.

Thank you for the support.
Regards,
João


(Robert Wall) #2

Did it work correctly with the SD card supplied?

Did you connect the two c.t’s and the temperature sensor before you applied power to the emonTx? You cannot add any of the sensor inputs - the sensors are detected at power-up (and only then - not when you reboot the Raspberry Pi) and the inputs are created automatically when the first readings are made.

What does the LCD show as it starts up? You should see:

emonPi V [and the version number]
OpenEnergyMon
AC Wave Detected [or “AC NOT Detected”]
Detected CT1 [and/or CT2] [or “No CT’s”]
Detected: DS18B20 Temp
Raspberry Pi Booting…


(Joao Sampaio) #3

Hello Robert,

The steps done were:

  • Downloaded emonSD-30Oct1 image and Flashed the SD card with it.
  • Pluged the SD card
  • Connected the CT1, CT2, Temperature sensor
  • Connected Ethernet cable
  • Powered up the system
  • Waited the updated were finished, in emonpiupdate.log:
emonPi update done
restarting service-runner\n
service-runner: no process found

Then after login in CMS no Inputs, feeds nor Devices are setup, so added new Device as “HomeEnergyMonitor”.

After rebooting again no input values are shown.

Regarding the LCD, it just lights up, but never display any information. Just stays as in the picture shown.

In there any system log that can be checked regarding these symptoms?

Thanks a lot!
João


(Robert Wall) #4

I’m afraid I know very little about the emonPi and emonCMS, so I can’t help you any further. if @TrystanLea or @borpin see this, they are more likely to be able to help you.


(Brian Orpin) #5

@jsampaio Can you post the details in the admin screen. Click on the Copy to Clipboard button next to Server Information and then just paste it to a reply here (no further formatting required). I Don’t have an EmonPi so this is not something I can help with you need @glyn.hudson or @TrystanLea to help but that info will aid them.

BTW if you are formatting code use the backtick which is the key in the top left of the keyboard (3 required).


(Joao Sampaio) #6

Hello Brian,

Please find below the system information requested:

Server Information
Emoncms Version low-write 9.9.5
Modules Administration : App v1.2.0 : Backup v1.1.5 : EmonHub Config v1.0.0 : Dashboard v1.3.1 : Device v1.2.0 : EventProcesses : Feed : Graph v1.2.1 : Input : Postprocess v1.0.0 : CoreProcess : Schedule : Network Setup v1.0.0 : sync : Time : User : Visualisation : WiFi v1.3.0
Git URL https://github.com/emoncms/emoncms.git
Git Branch * stable
Buffer loading…
Writer Daemon is running with sleep 60s
Server OS Linux 4.14.71-v7+
Host emonpi emonpi (192.168.1.118)
Date 2018-12-27 15:55:07 UTC
Uptime 15:55:07 up 0 min, 1 user, load average: 0.57, 0.18, 0.06
HTTP Server Apache/2.4.25 (Raspbian) HTTP/1.1 CGI/1.1 80
MySQL Version 5.5.5-10.1.23-MariaDB-9+deb9u1
Host 127.0.0.1 (127.0.0.1)
Date 2018-12-27 15:55:07 (UTC 00:00‌​)
Stats Uptime: 751 Threads: 3 Questions: 83 Slow queries: 0 Opens: 23 Flush tables: 1 Open tables: 17 Queries per second avg: 0.110
Redis Version 3.2.6
Host localhost:6379 (127.0.0.1)
Size 7 keys (743.41K)
Uptime 0 days
MQTT Server Version Mosquitto 1.4.10
Host localhost:1883 (127.0.0.1)
Pi Model Raspberry Pi 3 Model B Rev 1.2 - 1 GB (Stadium)
SoC Broadcom BCM2835
Serial num. BD3D2F95
Temperature CPU: 35.40°C - GPU: 35.4’C
Release emonSD-30Oct18
File-system Current: read-write - Set root file-system temporarily to read-write, (default read-only)
Memory RAM Used: 15.13% Total: 976.74 MB Used: 147.81 MB Free: 828.93 MB
Swap Used: 0.00% Total: 100 MB Used: 0 B Free: 100 MB
Disk Mount Stats
/ Used: 39.76% Total: 3.81 GB Used: 1.52 GB Free: 2.12 GB
/boot Used: 51.69% Total: 42.52 MB Used: 21.98 MB Free: 20.54 MB
/home/pi/data Used: 1.06% Total: 10.35 GB Used: 112.86 MB Free: 9.71 GB
PHP Version 7.0.30-0+deb9u1 (Zend Version 3.0.0)
Modules apache2handler : calendar v7.0.30-0+deb9u1 : Core v7.0.30-0+deb9u1 : ctype v7.0.30-0+deb9u1 : curl v7.0.30-0+deb9u1 : date v7.0.30-0+deb9u1 : dom v20031129 : exif v7.0.30-0+deb9u1 : fileinfo v1.0.5 : filter v7.0.30-0+deb9u1 : ftp v7.0.30-0+deb9u1 : gd v7.0.30-0+deb9u1 : gettext v7.0.30-0+deb9u1 : hash v1.0 : iconv v7.0.30-0+deb9u1 : igbinary v2.0.1 : json v1.4.0 : libxml v7.0.30-0+deb9u1 : mbstring v7.0.30-0+deb9u1 : mcrypt v7.0.30-0+deb9u1 : mosquitto v0.4.0 : mysqli v7.0.30-0+deb9u1 : mysqlnd vmysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $ : openssl v7.0.30-0+deb9u1 : pcre v7.0.30-0+deb9u1 : PDO v7.0.30-0+deb9u1 : pdo_mysql v7.0.30-0+deb9u1 : Phar v2.0.2 : posix v7.0.30-0+deb9u1 : readline v7.0.30-0+deb9u1 : redis v4.1.1 : Reflection v7.0.30-0+deb9u1 : session v7.0.30-0+deb9u1 : shmop v7.0.30-0+deb9u1 : SimpleXML v7.0.30-0+deb9u1 : sockets v7.0.30-0+deb9u1 : SPL v7.0.30-0+deb9u1 : standard v7.0.30-0+deb9u1 : sysvmsg v7.0.30-0+deb9u1 : sysvsem v7.0.30-0+deb9u1 : sysvshm v7.0.30-0+deb9u1 : tokenizer v7.0.30-0+deb9u1 : wddx v7.0.30-0+deb9u1 : xml v7.0.30-0+deb9u1 : xmlreader v7.0.30-0+deb9u1 : xmlwriter v7.0.30-0+deb9u1 : xsl v7.0.30-0+deb9u1 : Zend OPcache v7.0.30-0+deb9u1 : zlib v7.0.30-0+deb9u1
Client Information
HTTP Browser Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.28 Safari/537.36
Screen Resolution 2048 x 1152
Window Size 2031 x 1010

Thanks a lot!
João


(Joao Sampaio) #7

Hello,

Any ideas on how to overcome these issues on EmonPi?

Thanks!
João


(Robert Wall) #8

Most people in the UK have been celebrating Christmas over the last few days, and will be on holiday for the next few days, so are probably not reading this forum as often as they usually do.


(Joao Sampaio) #9

Thanks Robert!

Was just further reading post and documentation and just want to add that in my case the LCD display on boot also does not display any information, like the EmonPi version, Detecting CTs, Detecting Temperature sensor, …


(Robert Wall) #10

@glyn.hudson too might be able to help.


(Glyn Hudson) #11

Hi @jsampaio

Sorry to hear your having issues. You mention that you flashed your own SD card, it looks like you have done a good job, however did the emonPi not come pre-assembled with an SD card pre-installed? Do you have you #XXX order ID number to hand, so I can verify exactly what was shipped.

All sensors must be connected before powering up the unit. For the emonPi to detect the temp sensor and CT2 they must be connected before power up. Restarting the RasPi is not enough, try to fully shutdown the unit and remove the power then power up.

The emonPi LCD defiantly dost not look right. It looks like a hardware issue. Could you double check the I2C LCD connections to the emonPi PCD and the contrast adjustment. After adjusting the connection you will need to restart the unit to try to reinitialize the LCD.

Yes, you can check /var/log/emonpilcd/emonpilcd.log

If you are not seeing any Inputs on the Input page of Emoncms then something is not right with your hardware.


(Joao Sampaio) #12

Hi @glyn.hudson

Thanks for your detailed reply.

The EmonPi was shipped with SD version emonSD-26Oct17 and upon powerup with the sensors connected the same issue reported was occurring, no inputs, no LCD information.
So, have tried to flash the new SD emonSD-30Oct18 to check if was version issue, but the same occurred and have opened this thread in the community for assistance.

The order ID is #18545

Regarding the LCD I2C connection, haven’t touch on them and attach a photo here of how they were.

Also attach several emonpi log files.

Thank a lot!
João

emonpiLogs.zip (20.3 KB)


(Greebo) #13

From your emonpilcd.log file:

2018-12-28 21:17:20,969 INFO Starting emonPiLCD V3.0.1
2018-12-28 21:17:21,032 INFO I2C LCD DETECTED 0x27
2018-12-28 21:17:21,415 INFO SD card image build version: emonSD-30Oct18
2018-12-28 21:17:21,415 INFO Attaching push button interrupt...
2018-12-28 21:17:21,422 INFO Attaching shutdown button interrupt...
2018-12-28 21:17:21,429 INFO Connecting to redis server...
2018-12-28 21:17:21,431 INFO Connected to redis
2018-12-28 21:17:21,432 INFO Connecting to MQTT Server: 127.0.0.1 on port: 1883 with user: emonpi
2018-12-28 21:17:21,435 INFO Connected to MQTT

It appears the LCD process is working correctly and found the LCD. Could it be that the contrast is turned up way too high on the LCD? It could be that the LCD is working perfectly but you just can’t read it due to the contrast. The contrast is set by that grey cross head screw in the blue square on the back of the LCD board.

Does the LCD change if you turn the grey adjustment screw in the blue square on the back of the LCD?


(Joao Sampaio) #14

Hello @Greebo

I’ve now tried to reduce the LCD contrast with the grey cross, I can see the contract going low and high, but no chars are displayed. Have also tried to power up the EmonPi again with less contrast and LCD lights up but nothing is displayed.

Thanks!
João


(Trystan Lea) #15

3 posts were split to a new topic: Lechacal board configuration, emonhub


(Glyn Hudson) #16

This sounds like a hardware issue, we have been in touch with @jsampaio to arrange a replacement.