Community
OpenEnergyMonitor

OpenEnergyMonitor Community

No data and cannot connect to Emoncms on emonPi with emonESP

@borpin
Originally, it was radio only. I think serial was added at some point, I know there were some complaints because the radio was left on as well as serial when only serial was wanted. I think the “either - or” happened when whitening was introduced.

What’s missing from the emonTx is sufficient I/O to be able to have a bank of DIP switches to be able to select all the options that it’s accrued over the years.

You will still use your ESP8266 once you have changed the output of the emonTx over. You will need to disconnect the ESP to do it, check that the serial output is present with the correct format, then reconnect the ESP, and you should see your output.

It might be possible to use another serial comms program to talk to the programmer, but the simplest is probably the Arduino IDE, which will be useful if you want to update or change something else. Instructions for setting that up are in the ‘Learn’ section. You won’t need any of the libraries until you come to change the sketch itself and recompile and reload it.

I’ve purchased the programmer via the shop it’s just not something I expected to have to purchase or do as there is no mention of the need to change the EmonTx settings in relation to the EmonESP

1 Like

Yes, I think a good solution would be for the emonESP firmware to automatically configure the emonTx github issue added. In the meantime until this functions has been implemented and tested we will remove the emonESP from the shop as an individual item and only sell it in conjunction with a correctly configured emonTx.

Yes, the discrete sampling FW had serial in EmonESP format always switched on by default. This issue was introduced when we switched to the continuous sampling firmware.

The programmer arrived today, I believe I’ve connected to it correctly and turned RF to off. Now just testing to see if any data from the feeds appears in the ESP latest data section.

I’ve still had no joy getting a connection to emoncms.org using the web interface, it just always shows ‘Connected’ as No

I presuming the RF setting is persistent after the ESP has been powered off and rebooted?

If you saved the settings, then yes, the emonTx will retain that. Otherwise, it will revert to whatever it was when you next power up.

Available commands for config during start-up:
b - set r.f. band n = a single numeral: 4 = 433MHz, 8 = 868MHz, 9 = 915MHz (may require hardware change)
g - set Network Group nnn - an integer (OEM default = 210)
i - set node ID i= an integer (standard node ids are 1…30)
r - restore sketch defaults
s - save config to EEPROM
v - show firmware version
w - turn RFM Wireless data on or off:
- x = 0 for OFF, x = 1 for ON, x = 2 for ON with whitening
x - exit and continue
? - show this text again

Available commands only when running:
k <yy.y> <zz.z>
- Calibrate an analogue input channel:
- x = a single numeral: 0 = voltage calibration, 1 = ct1 calibration, 2 = ct2 calibration, etc
- yy.y = a floating point number for the voltage/current calibration constant
- zz.z = a floating point number for the phase calibration for this c.t. (z is not needed, or ignored if supplied, when x = 0)
- e.g. k0 256.8
- k1 90.9 2.00
l - list the config values
m - meter pulse counting:
x = 0 for OFF, x = 1 for ON, = an integer for the pulse minimum period in ms. (y is not needed, or ignored when x = 0)
p<xx.x> - xx.x = a floating point number for the datalogging period
s - save config to EEPROM
t0 - turn temperature measurement on or off:
- y = 0 for OFF, y = 1 for ON
t
- change a temperature sensor’s address or position:
- x = a single numeral: the position of the sensor in the list (1-based)
- yy = 8 hexadecimal bytes representing the sensor’s address
e.g. 28 81 43 31 07 00 00 D9
N.B. Sensors CANNOT be added.
? - show this text again

Great, I was just googling for that answer as it’s clear that the setting hadn’t been saved. I’ll try that again!

Thanks for all the help but I’m officially giving up.

The flimsy nature of the emonesp connectors and the need for me to keep removing it to try insert the programmer and faff about with sending serial commands led to the inevitable and the connectors on the emonesp snapped.

Guess I’ll be sticking to the radio connection instead.

I don’t have an ESP8266, so I don’t know what the connector on that end is like. If it’s what I think, then maybe I’m very gentle with those sorts of things, because I’ve never snapped the pins on the emonTx, emonTH, emonGLCD, or even inside the emonPi, and I’m plugging a programmer into something many times every day. (e.g. I had to transfer my programmer to a different emonTx to grab that text I posted above.)

However, the emonTx was never designed to have a WiFi module added, so it always looked exactly like it was - something that came along later.

There’s a problem there. At present, if the (genuine) receive pin on the emonTx is connected, rogue data from the ESP8266, sent as I understand it as part of it’s start-up / Welcome message, destroys parts of the configuration settings of the emonTx.

If you are going to do that, it wants if at all possible to be the same as the emonPi front-end configuration that I’m working on - which if the ESP8266 is bi-directional - could be done inside emonhub.conf - like the emonPi will be (if it can be made to work).

The alternative to the ESP, is an RPi EmonTX to Rpi - Direct Serial Connection

Except that the serial connection isn’t available on the emonPi - it’s already in use for the analogue front end data.

And if @fatherofgrafton has broken the connector on the emonTx, then depending on which pin(s) are broken, any serial connection/reprogramming is out of the question until a new header is fitted.

He hasn’t by his description.

He wants to communicate from the emonTX by WiFi.

No it’s the pins on the ESP that are broken.

The TX is placed right on the edge of reception back to the Pi so yes I was aiming to connect the TX to my wifi which I have available where the TX is placed in my garage.

I’m not prepared to buy a replacement ESP I’ll just have to try and improve radio connectivity between the TX and the Pi

Thanks for the help

The alternative is a second Pi (anything, A, Zero upwards) and connect the serial to that.

There are several options for that. If your emonTx uses a RFM69CW transmitter module, which it will if it’s reasonably new, then you can increase the r.f. power.

The second is to put a sheet of metal acting as a ground plane underneath both transmitter and receiver. There was a lot about this some time ago - Improving RF signal strength emonTH emonTX

The third is to move either or both ends just a little - that can make a surprising difference if one happens to be at a place where the reflected signal partially cancels the direct one.

1 Like

Hard to beat a Pi Zero, especially given the price and the “bang for your buck.”

1 Like

Yeah tried the foil under both Pi and TX units to increase signal strength and now all feeds / inputs no longer working, the PiLCD is showing a fault (showing ‘Booting… Please wait’ plus showing a red dot next to the service) and reboots not helping.

So now my whole system is essentially dead. I am officially done… :angry:

You’ve obviously done something else as well as providing a ground plane, because that could not possibly cause the emonPi not to boot.

Nope, I can assure you I literally slipped a piece of tin foil under the emonpi casing where it was sitting and feeds no longer showing data / invalid and on reboot lcd issue.

Total farce from start to finish. From faulty software loaded prior to shipping through to EmonTx incompatibility with Wi-Fi unit and need for programmer having to to be purchased to be able to change settings and now this.

£300 down the drain.

Hello @fatherofgrafton

Sorry that the system has given you so much trouble. Given that these are all new units we would be happy if you wish to return them for a refund. Alternatively we could replace the Wi-Fi unit and configure the EmonTx unit for you if you send those back to us.

If you could email us at [email protected] with what you would like to do we can take it from there.