Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Newbie having trouble with emoncms.org

I purchased my emonPi in 2017 and set it up and it worked great.

Then I stopped using it, and this month I started to try to use it again, and did a software update which failed, so I have used a new 16GB micro sd card and flashed the June 2020 image, and I am back up and running again.

The local emonpi works perfect, but I cannot get the Emoncms.org to work

Is there a newbie guide to getting it synced to the emonpi local ?

I have chosen to start a fresh and not look for any backup or old data. So I have the new feed setup on the local emonpi but cannot get it to show live readings in the Emoncms.org

Hi,

have you put the API key in, cannot remember where it goes at the moment but you do need it

John

Hi John

Thank you for replying. I can’t get far enough to enter an API key…

David

Welcome, David.

In where? Can you log in to your emonPi and in to emoncms.org?

If you can, get the API key from emoncms.org. On the Inputs page, click on Input API Help . The one you need is the Read & Write a few lines down.

Put that in your emonPi - you need it so that your emonPi can assure emoncms.org that it’s OK to accept the data.

Go to Emonhub, click “Edit config”, and about 3 window’s height’s down, under [[emoncmsorg]], replace the X’s with your emoncms.org APIkey in

   apikey = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

then change senddata = 0 to senddata = 1
and it should work.

(Despite having sendinterval= 10, mine appears to be sending every 30 s.)

1 Like

Hi Robert

Perfect solution

Thank you very much

Its a bit daunting at first but actually very rewarding when it works!!

David

This appears to be the same for me. Anyone have any ideas how to send to emoncms.org every 10 seconds?

Looks like the setting name is incorrect in the default config. looking at the code it looks like it should be just:

interval = 10

Let me know if that works for you, il make a note to look at this and update the defaults if needed.

Thank you, it worked (changing from sendinterval = 10 to interval = 10)

1 Like

It doesn’t actually affect the data that’s received at emoncms.org - the data points are still 10 s apart, it’s just that they get sent in batches of (in my case) 3.

1 Like

Isn’t it the code that needs changing? In my book, sendinterval is much more explicit as to what it means.

yes that’s a key point, sending in batches reduces bandwidth use significantly and also load on the emoncms.org server.

So maybe a sensible default would be 60 s or 150 s? Or even 300 s?

1 Like

Yes that would be ideal, it’s just that it can be frustrating to wait for the data to come in I guess - if your looking at a dashboard…

As most seem to use emoncms.org as a backup/sharing mechanism (though that’s only the impression I get from the forums, you must have a better idea from server use and the number of accounts vs. sales of emonPi’s & ESP’s), I don’t see waiting a minute as being a big problem.

Again, this comes down to documentation. If the user knows what it does, and the implications of various values, they can make an informed decision. Without it, they’ll leave the default in place, because they don’t know any better.

All interfacers inherit a “interval” setting, adding a “sendinterval” is duplicating code and is actually the cause of the confusion. Trystan didn’t know there was already an “interval” in emonhub and documented when he added a sendinterval. The result was some users were using “interval” and others were using “sendinterval” because various docs and config files showed either. He then fixed that by removing the then recently added “sendinterval” again, reverting to the established “interval”. This new very recent re emerging confusion is probably due to a minor typo or copy/paste from outdated examples/docs etc.