Community
OpenEnergyMonitor

Community

Newbie - Are the instruction videos out of date or am I missing something?

I have spent a really frustrating series of evenings trying to get started and failing dismally. I’d be really grateful of a bit of hand-holding as I am clearly missing something!

Having followed the video of the connection of an EMONPI to the ethernet I have an IP address. Having put that into the browser I have been able to register and get into EMONCMS. However the screen once logged in bears only a passing resemblance to the instruction video (https://www.youtube.com/watch?v=7RppS-Q-qaI) with completely different menus. Am I looking at the wrong video?

Video:
[Video deleted as it had read and write API keys visible - Mod]

My screen shot - no WiFi menu
[Video deleted as it had read and write API keys visible - Mod]

Sorry to bother people with the basics, but I am clearly on the wrong track and I am getting no-where.

Thanks,

Neil

Hi Neil, I deleted the images as they had your read and write keys visible - never a good idea. It also looked like the second screenshot was of your emoncms.org account page rather than your local emoncms.

The UI has had quite a makeover since the videos and instructions were last done - @TrystanLea @glyn.hudson those need a refresh.

What do you have and what are you trying to do?

Brian,
Thanks for responding and the bit about the keys. Thanks too about the videos being out of date… I really was beginning to think it was just me!

So I have unboxed the EMONPI and am trying to set it up. So far I have one temp sensor plugged in, but I cannot find out how to get the EMONPI onto the wireless network, or indeed anything!

In due course I am looking to do monitoring of several temperatures and humidity. I will want to put it on a website that my wife can see. Does this help?

Neil

Have you gone through these steps to connect to WiFi?

Brian,

Sorry I have been away: I have tried to follow the instructions, but to no avail. I have used the Ethernet connection to register an account. I have then unplugged the ethernet cable and the EMONPI has then displayed a password (as per the instructions) and there is a light on the wifi dongle, but it says ‘Wi-fi not connected’ and I do not see it appear as a new wireless connection/node on either the main household PC nor on any phones… Is there something I need to do to make the dongle visible to the network in some way?

A new EmonPi has no need for a dongle as WiFi is built into the Raspberry Pi. This might be the issue if you have plugged a dongle in.

So I have naw taken the wi-fi dongle out and now the screen on the EMONPI cycles between ‘Ethernet not connected’ and something about no GSM i.e. the ‘Wi-Fi not connected’ menu has disappeared…

I have not re-booted the EMONPI

If you plug in the ethernet cable and reboot the EmonPi then navigate to the EmonCMS page, I think you might get a page asking if you wish to continue on Ethernet or connect by wifi.

If you don’t then you can log in and set the WiFi up from the WiFi menu under settings cog (top right).

Remember, the IP for the emonpi will be different for the ethernet connection v the WiFi connection.

Actually, you can connect to both at the same time (i.e. no need to remove ethernet cable).

Brian,
Right; back home again! Sorry to be such a pain.

When you say ‘plug in the ethernet cable’ I assume you mean plug in to the router and not the PC.

Also when I do boot it up (plugged into the router) the EMONPI gives the address of 192.168.1.104

Putting that into my browser brings up the EMONCMS screen and asks for a username, but when I put in a known username it says:
image

I know it is a known user name because I can login direct to EMONCMS and that brings up the following screen with the same username autofilled!

image and with the password in place. When I click ‘Login’ it lets me in. So I know the Username is valid!

Finally: If I do click the ‘login’ option I get into the site, but there is no ‘cog’ as shown.

Where do we start?

Neil

Ok.

Emoncms.org and the EmonCMS you access from the Pi are 2 completely separate systems so they have their own usernames and passwords.

emoncms.org runs an older version of the user interface and you do not get the same options as you are just a user rather than an administrator on your local system.

So go back to the steps I linked to above. You will need to create an account on the EmonPi and then work from there.

You should be able to setup the WiFi using those instructions rather than plugging it into the Router. It would be better if the EmonPi was setup with the CT all plugged in before you start creating an account etc.

Brian,

Thanks for your persistence. I am not sure I understand the differences you allude to yet, so please bear with me.

Firstly I have followed the instructions, but the EMONPI does not connect to WiFi as the instructions seem to indicate it should. So this bit does not happen:

Note the unit has a build date of 26 Oct 2017, so it is not an ‘older unit’ as referred to in the ‘Important’ section.

When I power up the unit with one temp sensor in it, powered just by the USB the unit DOES NOT broadcast a WiFi access point. I have videoed this step. I see that a couple of minutes after boot up the button on the top becomes effective and I can scroll through the menus. The WiFi one says ‘not connected’. I have also checked at that point on my PC and also mobile to see if a new network has appeared and it has not. The unit is sitting here next to me as I type and now shows an ‘Uptime of 0.01 days’ and still says ‘No Wifi.’

Note: I have also borrowed another EMONPI from a friend who gave up trying to install it a year or so ago. It seems to behave in the same way.

Is there anything I need to do to my WiFi network to open it to recruit the EMONPI?

Neil

Hi Neil,

I’m not sure why the WiFi is not advertising an AP but we can set it up if you plug it into your router via an Ethernet cable.

At this point, you need to create a new user for your local EmonCMS system so click on Register and create an account.

Once connected, click on the cog, then admin and click on the Full Update button.

Once that has completed, click on the cog, then WiFi. You should be able to select your WiFi connection from there.

Note once you have the WiFi setup, the IP address you will use will be different, but the username/password will be the same as the other IP address.

Brian,

Have started again and plugged into the ethernet cable, booted up and left alone. (no mention of Wi-fi at all in the menus).

Have left it plugged in and come to the PC.

I note in your text you refer to 'your local EmonCMS system '…what do you mean ‘local’? The interaction I seem to be having with EmonCMS is a website. Am I looking in the wrong place? I have done a search on my home PC and find no reference to EmonCMS. The search does bring up the option of a website and that then gives me the opportunity to register (which I have done) and I then received an E-mail for verification. Clicking on that took me to
image

but there is no cog to click on, so the trail goes cold again here…

Any ideas?

Neil

What is in your browser’s address bar? If it contains “emoncms.org”, then you are using the (paid for) shared, OEM version run by Trystan.
If it (most likely) is a “dotted IP address” like 192.168.1.104 that you saw earlier, it is your own private local copy running on your emonPi.

You will, or should, be able to get to both from your PC, depending obviously on the address that your web browser has gone to.

Hi Neil,

There are 2 distinct systems.

The first is an Internet based system that you access via the address emoncms.org (this is the one in your image).

The second, is the one that runs on your emonpi (i.e. local) that (as Robert says) you access via a numerical IP address as you did previously. It is this second version you need to access and create a new user on.

You found it previously…

Robert and Brian,

Thanks for your input.

I have put the 192.168.1.104 into the browser and it brings up a login page. (Note it adds the /emomcms/ suffix to the address.)

but note it does not have a ‘register option’. I have also got in a complete bloody mess with logins, so it gives me a list of about 6. However none of them seem to work and all return a ‘User Name does not exist’…

Neil

Is this a brand new unit? If not it will explain some of the issues.

I think the only solution is to create a new SDCard (or buy a pre loaded one from the OEM shop) and start again from scratch.

Brian,

It was brand new, and someone tried to use it at work and gave up. (I can see why! :slight_smile: ) I have taken it on having eventually got an older system up and running with David’s help before.

I think the ‘start again’ option with a new SD card is looking appealing… if it works.

Is there no way that I can wipe and reload the contents of the SD card?

Neil

See https://github.com/openenergymonitor/emonpi/wiki/emonSD-pre-built-SD-card-Download-&-Change-Log

1 Like

That is probably the issue. It has already been connected to a wifi network and a user created.

Restarting with a fresh image should improve things but do be aware, the UI has changed since the videos were done, but the principles remain.