Community
OpenEnergyMonitor

Community

NEW INSTALL - feedback on experience


(Richard) #1

Placing this here as feedback on the install process of an emonpi (January 2019) in case anyone else runs into these issues.

  1. Unpacked, connected via ethernet, and switched on. It connected to my router OK, and presented its own wifi point.

  2. Attempted to connect to http://emonpi.local, and to its ip address. Setup Step 2 “Connect” notes “emonPi network setup wizard should now be displayed”. No guidance on what to do if it does not. It did not - blank screen. Restarted browser, tried Safari, Firefox, Chrome, rebooted router, PC, and emonpi. No success.

  3. Section 12 “Troubleshooting”, right at the bottom, gives the factory reset command. No obvious information in setup how to enter the pi (for anyone in a similar position, it’s under “Technical -> Service Credentials”). Enabled SSH, gained entry, did factory reset, rebooted, and gained access to the setup wizard.

  4. Gave up after an hour waiting for the wizard to find the network. Set /etc/wpa_supplicant/wpa_supplicant.conf manually and connected. But selecting “WiFi” in the application now displays a message that the wifi driver cannot be found (I do have wifi access).

  5. Tried to reset the pi’s password from default. Unsuccessful - password reverts to factory setting on reboot.

  6. Positioned the device at the meter. My phone (Google Pixel 3) at that location reports a wifi signal strength of 75%. Emonpi unable to detect network. Relocated the router until it could - router now in the middle of the bedroom until I can think of a fix.

  7. It’s running, but reporting a c. -40W offset (reported in a separate topic). This may be a configuration issue but there’s not a lot of guidance on how to trouble shoot beyond avoiding clamping simultaneously to live and neutral, and installing it the correct way round.

I have very modest raspberry pi skills and it took me over 3 hours to get this working. This was not encouraging.


(Trystan Lea) #2

Thankyou for the feedback @richardlyon sorry to hear that its given you so much trouble.

We are in the process of improving point 2, knowing that hostnames dont always work Local Network Device Discovery. This tool will work after the next emonpi update (work in progress): Emoncms V9.9.6 Stable merge (pre-merge check).

Im not sure what’s going wrong at point 4, did it list any wifi networks? can you give more details on the wifi driver error?

When trying to change the default pi password did you type “passwd” following the guide?

Interested to hear if @Robert.Wall suggestion in your post here New emonpi install - interpretation/elimination of power offset provides any light on the offset.


(Richard) #3

Re. List of wifi networks: No - it hung with the “Scanning…” message on the screen.

Re: Driver error:

Emoncms -> Setup -> WiFi

Fatal error: Uncaught Error: Class ‘Wifi’ not found in /var/www/emoncms/Modules/wifi/wifi_controller.php:22 Stack trace: #0 /var/www/emoncms/core.php(64): wifi_controller() #1 /var/www/emoncms/index.php(191): controller(‘wifi’) #2 {main} thrown in /var/www/emoncms/Modules/wifi/wifi_controller.php on line 22

Re: password. I used:

sudo passwd

The current situation is that I now have a rather expensive device connected to a clean, “live” line feeding an almost empty apartment (one fridge and a few lights), registering a consistent ~ -40W offset.

I’m reluctant to mess about any further as the whole device is behind a set of torx screws and I’ve no way of getting at the card to reflash it if I lock myself out.


(Greebo) #4

passwd should be run as the user you wish to change the password of… you were probably changing the passwd of root by doing that. There’s not really any time you would use sudo and passwd together unless you were changing someone else’s password.

[EDIT] the manpage for passwd is here: http://man7.org/linux/man-pages/man1/passwd.1.html
Correct usage to change the pi user password on an emonpi is either:

passwd

or

sudo passwd pi

(Richard) #5

Thanks Greebo - makes sense, and helpful advice.