Monitoring & Controlling Ecodan via CN105

Dumb question: I’ve updated to v 5.0, I read I should change the configuration.yaml file but I can’t find any file in HA but the general configuration.yaml that I assume is not the one.
Any help?

Yes that is the correct file.

I generally just copy from the mqtt: line and below to stop any duplication conflicts, add that to the end of your configuration.yaml file.

As Ben said, yes that’s the correct file
You can copy & paste the lines all the lines if the file is currently identical - or as Ben said, copy from line 14 in the example onwards

image

Thank @Tango130 and @F1p for answering.
Adding from the MQTT line at the bottom of the file returns some errors.
Here’s my config file, it already has template and sensors listed, not sure if adding at the bottom will do the trick.

homeassistant:
  packages: !include_dir_named packages

default_config:
  template: !include template.yaml

# Load frontend themes from the themes folder
frontend:
  themes: !include_dir_merge_named themes

automation: !include automations.yaml

script: !include scripts.yaml

python_script:

scene: !include scenes.yaml

system_log:
  fire_event: true

device_tracker:
  - platform: luci
    host: 192.168.10.1
    username: admin
    password: XXXXXXXXX

energy_meter:
  daily_energy:
    source: sensor.power_meter_energia_importata_dalla_rete
    name: Daily Energy
    cycle: daily
    price_entity: sensor.pun_prezzo_fascia_corrente

  monthly_energy:
    source: sensor.energy
    name: Monthly Energy
    cycle: monthly
    price_entity: sensor.pun_mono_orario

http:
  use_x_forwarded_for: true
  trusted_proxies:
    - 172.30.33.0/24

# Example configuration.yaml entry
google_assistant:
  project_id: XXXXXXXXXXX
  service_account: !include SERVICE_ACCOUNT.json
  report_state: true
  exposed_domains:
    - switch
    - light
  entity_config:
    switch.kitchen:
      name: pirris
      aliases:
        - BRIGHT_LIGHTS
        - ENTRY_LIGHTS
    light.living_room:
      expose: false
      room: SALOTTO

template:
  - sensor:
      - name: "House power Consumption"
        unique_id: "house_power_consumption"
        unit_of_measurement: "W"
        device_class: power
        state_class: measurement
        state: >
          {% set meter_potenza = states('sensor.power_meter_potenza_attiva') | float %}
          {% set inverter_potenza = states('sensor.inverter_potenza_attiva') | float %}
          {{ (inverter_potenza - meter_potenza ) | float(0) }}

      - name: "Overproduction Company Injection"
        unique_id: "solar_power_Overproduction"
        unit_of_measurement: "W"
        device_class: power
        state_class: measurement
        state: >
          {% set meter_potenza = states('sensor.house_power_consumption') | float %}
          {% set inverter_potenza = states('sensor.inverter_potenza_in_ingresso') | float %}
          {% set battery = states('sensor.battery_potenza_di_carica_scarica') | float %}
          {{ (inverter_potenza - meter_potenza - battery ) | float(0) }}

      - name: "Consumo EDP"
        unique_id: "Consumo_EDP"
        unit_of_measurement: "W"
        device_class: power
        state_class: measurement
        state: >
          {% set consumo_rete_edp = states('sensor.power_meter_potenza_attiva') | float %}
          {{ (consumo_rete_edp * (-1) ) | float(0) }}

      - name: "energy_pv"
        unique_id: "PV Energy"
        state: >
          {{ (states('sensor.inverter_rendimento_giornaliero') | float) - (states('sensor.battery_scaricamento_totale') | float) + (states('sensor.battery_carica_totale') | float) }}
        device_class: power
        state_class: total_increasing
        unit_of_measurement: 'kWh'

      - name: "energy_pv_daily"
        unique_id: "PV Energy daily"
        state: >
          {{ (states('sensor.inverter_rendimento_giornaliero') | float) - (states('sensor.battery_scarica_giornaliera') | float) + (states('sensor.battery_carica_giornaliera') | float) }}
        device_class: power
        state_class: total_increasing
        unit_of_measurement: 'kWh'

You will need to add the entities under templates from @F1p 's into your templates section and the rest should be able to be appended.

Cool thanks, working now!
But how can I chose the holiday mode and other stuff?
Which card should I use?
(if you’ve youe own code please paste :slight_smile: )

In Home Assistant you can now go + Add Card from one of your Dashboards
Then Choose Entities:

The Heat Pump ones should appear in the list now

e.g.

1 Like

@F1p I have 2 DHW tank temperature probes attached to my FTC6.
THW5B is the normal DHW temperature probe but I also have THW5A attached that is the upper temperature probe. This is standard on the newest Ecodan cylinders but I’ve added it myself.

It allows you to have a temperature probe near the coil (THW5B) that is used during a reheat to decide the target temperature is reached but a separate probe (THW5A) higher up the cylinder that can be set as the one to monitor for temperature drop to trigger the recharge.
When you have both you can choose between Large (trigger based on THW5B) or Standard (trigger of THW5A) in the ‘DHW Recharge’ setting.

This is confusingly enabled using the following DIP switch
image

even though it doesn’t appear to change any behaviour except to enable this 2nd temperature sensor.

After all that waffle my actual question is do you think this temperature might me one of the ones that haven’t been identified yet? It would be useful to have access to this temperature as then I can also use it in Home Assistant to make decisions about reheating.

@ajdunlop,

Are you able to Telnet to your Ecodan Bridge and send me the output displayed after “Triggering Heat Pump Query” has output the rows and it pauses?

In addition, what the value of THW5A & 5B is displaying at the same time so i can see if i can correlate the value.

Thanks!

Thanks @ajdunlop for providing your debug output, i hope you can try this out:

4 Likes

Excellent all working, thank you for the quick work.

3 Likes