Community
OpenEnergyMonitor

Community

Issues with Wifi and creating feeds

Hi, literally just received my emonPi and emonTX and seem to have some issues.

I’m currently unable to get wifi scanning to work, either at initial setup or when I’ve tried to do it after selecting standalone mode. I get the error “cannot find /home/pi/emonpi/wifiap/networklog.sh”.

I also cannot create any feeds from my inputs as I get the following error “ERROR: Feed could not be created, could not write meta data file fopen(/home/pi/data/phpfina/3.meta): failed to open stream: No such file or directory”

I new to this but happy to tweak stuff but this seems to be something fundamental brand new out of the box. Any help gratefully received.

Hello @fatherofgrafton very sorry about this, it sounds like something has gone wrong with the configuration of the SD card on your system. Both errors are referring to the old path locations rather than where networklog.sh and the data directory should be. Would you mind emailing us at: [email protected] including and include your order ID, we can sort out a replacement unit or SD card, depending on what works best for you.

1 Like

Thanks for the quick response. Thought it might be something like that.

As I’m an impatient soul is it easy enough for me to load up the latest SD card image onto the existing card presuming it’s easy enough to access and reflash?

Sure the latest is available here: https://github.com/openenergymonitor/emonpi/wiki/emonSD-pre-built-SD-card-Download-&-Change-Log#emonsd-17oct19-stable if you load that on and leave it connected via ethernet for 20 mins or so at boot up to download the latest update that will give you the latest version.

1 Like

I’ll give that a go now. Thanks

1 Like

That’s done and booted. Logged in while on ethernet and saw the following on the admin page:

"Starting update via service-runner-update.sh (v3.0) >

Have I flashed the wrong image? I used this one https://github.com/openenergymonitor/emonpi/wiki/emonSD-pre-built-SD-card-Download-&-Change-Log#emonsd-17oct19-stable

Thanks @fatherofgrafton could you try running the update again from the admin page, it may be that it didnt quite have internet at the point it tried to update on first boot.

1 Like

That was it. And now wifi is working and so are inputs / feeds. Thanks for all your help.

1 Like

Great to hear @fatherofgrafton!

1 Like

We have worked out the underlying issue that caused the errors, there was a misunderstanding in the office whilst updating the master image last week that has left the settings.php file mistakenly in place. @martin had the same issue here: Brand new emonPi emonCMS not working

We will be emailing everyone who has ordered a unit in the last week to offer either a replacement SD card or for those confident in a little SSH the steps to fix, which are:


1. Enable SSH using the push button to scroll through the emonPi menu then press and hold on the “enable ssh screen”

2. Connect via SSH using putty, download here:
https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html
host: You will need to enter your emonPi’s IP address, as soon on the LCD

username: pi
password: emonpi2016

3. Once you are connected, execute the following command

sudo rm /var/www/emoncms/settings.php

then reboot the emonpi

sudo reboot
1 Like

That’s good. However I’m afraid I’m still unable to connect to any wifi.

The scanning of wifi happens ok and I tick the selected SSID and can enter my PSK. After clicking ‘save and connect’ and then closing the pop up I get the config saved pop and nothing else happens. Clicking refresh doesn’t do anything and connection info doesn’t change and nothing appears in the network log.

I’ve tried it using the AP mode and also ethernet and no difference I’m afraid. I’m obviously jinxed!

Any ideas?

Thanks again.

Hello @fatherofgrafton There seems to have been a couple of reports of WiFi issues recently, @glyn.hudson is investigating.

Could you check if the WiFi network is saved by any chance in wpa_supplicant:

sudo cat /etc/wpa_supplicant/wpa_supplicant.conf

Hello @fatherofgrafton I’ve found an issue with the WiFi log that I have now fixed. If you run an update via Admin > Full Update that should bring it in for you.

Great. I will do that later today.

It is me! I am jinxed for sure😂

I’ve made a few other changes to the WiFi module that should hopefully make it clear what it is doing when its trying to connect to a network, again if you can run the update and let me know what results you get that would be great! much appreciated!

Will do later today

1 Like

Did full update.

Tried to configure wifi while connected via ethernet. No info in the log and only difference was in the messaging when you save and connect. Rebooted to see if that helped. The log contained some info regarding binding to the ethernet connection but nothing regarding wifi. Added wifi credentials again and saved and connected, then refreshed. No new info in log and status stayed as ‘disconnected’ throughout I’m afraid.

Thanks, is there any chance you could check to the content of:

sudo cat /etc/wpa_supplicant/wpa_supplicant.conf

Could you double check the passkey is saved correctly, try reloading the WiFi page, it should be saved alongside the selected SSID. You also need to tick the checkbox next to the SSID you wish to connect to.

Oh dear, a couple of things you could try:

  1. Run $ sudo iwlist wlan0 scan this should return a list of available wifi networks

  2. Try to connect to a network using sudo raspi-config



If this fails then you must have faulty RasberryPi hardware.

Does your SSID / PSK have any unusual characters?