Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Issues with Wifi and creating feeds

Hello @fatherofgrafton

I’ve found another issue with the WiFi module that may have been causing what you were seeing. I wonder if you would mind running update again and trying to connect to WiFi again?

Will do now

I’ve done another update and made sure to check the SSID after entering password and then saving.

I’ve now got the countdown timer for the wifi restarting which is new, but nothing else changes after saving or pressing ‘refresh’, it still shows as disconnected and no more info in the logs. My SSID has no special characters just letters and a zero.

If I refresh the wifi page, my password and tick box selection are not saved so it doesn’t look like the config has saved.

I can try the sudo commands suggested by Glyn next if you wish?

@glyn.hudson @TrystanLea I have managed to connect to my wifi via the SSH commands from Glyn.

I’m happy to keep testing new builds though if you want?

Thanks @fatherofgrafton the settings are saving fine for me here, so it sounds like you have a different issue to what I was suspecting.

Could you try:

sudo cat /etc/wpa_supplicant/wpa_supplicant.conf

Now that I am connected ok with the wifi saved via the SSH commands the conf is showing the correct ssid and password. Do you want me to run that sudo command after I have removed the wifi connection again?

No that’s fine. Good to hear that you have it saved ok. We could try and get to the bottom of why it wasnt saving through the interface - or if you are happy that its working now, we can leave it at that? up to you, dont want to waste more of your time…

1 Like

I’m happy to help now that I know how to hard code it via SSH.

If it helps you to debug other users who might have the same issue saving via the interface I’m happy to keep trying new builds. Just let me know?

Thanks @fatherofgrafton, does your password have special characters by any chance? It should work with special characters, I did a test earlier and it was fine, but @glyn.hudson suggested there may be a particular character that might trip it up, perhaps "?

Are you based in the UK? is your WiFi locale GB?

Yes to being based in UK and having GB locale. Password only contains 1 special character an &

Of course that’s the character! Just tried it here and got the same result as you. I should be able to work out a fix

1 Like

Ok all done, if you want to test it, feel free to clear the WiFi config and try setting again via the interface after doing an update.

Yeah that works great. Thanks for that :grin:

1 Like

Cheers great to hear!