Community
OpenEnergyMonitor

Community

Issue with upgrade from 9.8.3

I upgraded my Emoncms running on a Ubuntu 18.04 server following the instructions found here:

https://github.com/emoncms/emoncms/blob/master/docs/Upgrading.md

I’ve upgraded the database, cleared the cache from my browser and logged in Emoncms.
First thing I noticed was that the Apps, Dashboards and DemandShaper menu items are missing:

Second, I noticed that the install scripts didn’t create the /var/log/emoncms directory and the system was complaining about missing emoncms.log and emonpiupdate.log so I created them.

Feeds seem to be working and updating normal.
Can anyone help me restore the missing menu items?

There really could be any number of issues caused by updating from a 9.x on an Ubuntu system.

It could take an awful long time to resolve.

My advice is to start from scratch and reinstall using the emonScripts (quick search here will find them) and do a backup export and import of the data and settings.

When using Ubuntu, my advice is to create a user ‘pi’ and add it to sudo as using a different account has not been fully sorted (there is a recent thread on installing on Ubuntu IIRC).

I reinstalled using emonScripts and it worked great. Did a backup export from my emonpi and imported the data in emncms and I am up and running.
I have one small issue - my http server defaults to https and when I try to access https://mydomain/emoncms it asks me “404 Not Found: Is modrewrite configured on your system?” after I input the username and password.
If I access http://mydomain/emoncms, it works ok.

You will have to investigate what you need to do to your setup yourself I’m afraid. There is a topic here about using https and Let’s Encrypt which may help. Does the Apache server do anything else? If not running certbot to recreate the certificate may adjust the configuration for you.

Another thing I noticed is that the log timestamp in /var/log/emoncms/emoncms.log in on UTC time.
Setting the timezone in My Account/My Profile doesn’t change anything.
I did a search and found this topic https://community.openenergymonitor.org/t/timezone-settings-are-ignored/9477 which comes close to the issue I am seeing but it’s not the same thing.
Is there any other place where you can set the timezone specifically for logging?

I think this is set in the code.

What does

[email protected]:~ $ timedatectl

tell you? e.g.

               Local time: Mon 2020-07-20 09:19:50 BST
           Universal time: Mon 2020-07-20 08:19:50 UTC
                 RTC time: n/a
                Time zone: Europe/London (BST, +0100)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no

The info displayed by timedatectl is correct:

[email protected]:~$ timedatectl
                      Local time: Mon 2020-07-20 12:11:38 EEST
                  Universal time: Mon 2020-07-20 09:11:38 UTC
                        RTC time: Mon 2020-07-20 09:11:38
                       Time zone: Europe/Bucharest (EEST, +0300)
       System clock synchronized: yes
systemd-timesyncd.service active: yes
                 RTC in local TZ: no

and the log:

[email protected]:~$ tail -f /var/log/emoncms/emoncms.log

2020-07-20 02:38:11.050|WARN|index.php|406 Not Acceptable|TP/public/index

2020-07-20 02:38:11.540|WARN|index.php|406 Not Acceptable|TP/index

2020-07-20 02:38:12.121|WARN|index.php|406 Not Acceptable|thinkphp/html/public

2020-07-20 02:38:12.739|WARN|index.php|406 Not Acceptable|html/public/index

2020-07-20 02:38:13.309|WARN|index.php|406 Not Acceptable|public/index

2020-07-20 02:38:14.257|WARN|index.php|406 Not Acceptable|TP/html/public

2020-07-20 02:38:15.204|WARN|index.php|406 Not Acceptable|elrekt

2020-07-20 04:18:54.227|WARN|index.php|406 Not Acceptable|hudson

2020-07-20 04:46:52.165|WARN|index.php|406 Not Acceptable|manager/text/list

2020-07-20 06:37:17.470|WARN|index.php|406 Not Acceptable|cgi-bin/ViewLog

2020-07-20 09:11:29.425|ERROR|user_model.php|Login: Incorrect password username:liviu ip:192.168.0.250

The timedatectl command was issued seconds after an unsuccessful login attempt.

Pretty sure it is hardcoded. Is you syslog UTC or local? It is not unusual to run logs in UTC.

Syslog is in local time.