Community
OpenEnergyMonitor

Community

IotaWatt 4.0

iotawatt
Tags: #<Tag:0x00007f1be66ce040>

(George (aka Costas the coder)) #177

Still available. Use a computer, clear your cart, start again and the coupon box should be there.


(Frogmore42) #178


Still not seeing it. It was there this morning. I tried in Edge and Chrome and Chrome on my phone, which was working this morning.


(George (aka Costas the coder)) #179

I used Chrome on Windows 8.1. Click on Proceed to Checkout to get access to the promo code box.


(Paul Reed) #180

You can add the code several steps later in the purchase process. Proceed to checkout, and the voucher box doesn’t appear until you get to ‘Order Confirmation’.

Paul


(Frogmore42) #181

Thanks, I found the place to enter the code and it appeared to work. But then when it was processing the payment, it said it was declined. When I went to try it again, I discovered that my cart was completely empty. At this point, it seems like a sign that I should not be purchasing this :grinning:

Thanks for the help though.


(Glyn Hudson) #182

I’ve just sent you a PM to try and resolve this. Very sorry for the hassle. Our payment providor PayPal website payments pro has had some issues today :frowning: . I will send you an alternative method using our other payment gateway.


(Frogmore42) #183

Thanks for the quick response. I was able to get the payment to process on the alternate link. I have been watching this project for some months and am really excited to get a chance to try it out.


(Pete) #184

Hi there, first off thanks for a great product that is now streaming my VT and 12 CTs to InfluxDb for storage and dashboarding. All is working really well and getting some great data/analytics (both voltage and power). But I cant figure out how to stream energy as well. Is that possible ? The data (e.g. Feeds-53:Energy:Living_Room in kWh) is available in the built-in graphing package but not in the InfluxDb setup fields. Appreciate any guidance.


(Inactive) #185

Not at the moment Pete, but I’m not sure you are asking for the same thing as in the graph app.

The graph app plots cumulative kWh since the device was setup. So to make sense of that for a particular period of time, you need to know what it was at the start of the period in question and subtract that from the ending value.

But the output to influx is periodic. Say every 10 seconds or whatever interval you specified. That’s a different question. Should it report cumulative kWh as in the graph, or wh consumed during the period being reported. If it’s going to be the latter, it’s going to need a lot of decimal places to be meaningful at small intervals.

It’s would be pretty straightforward to look at what is specified in the units box and return such a value, but probably want to clarify what makes the most sense because you only get one shot at getting something like this right.

Update: btw, there is a change coming to the api To use a more meaningful feed specification that makes it easier to use the configured outputs. It’s all set to go but waiting for some dependencies in the merge pipe.


(Pete) #186

Bob, thanks for the response.

A bit of context. For the last year I have had an aeotec home energy monitor providing a view of “whole house” consumption combined with a dozen or so Sonoff Pow switches giving appliance usage. They all provide Voltage, Current, Power and PF as a periodic feed into InfluxDb. In addition to that each deivce provides Energy usage in the form of “Energy Since Start-Up”, “Yesterday’s Total Energy” and “Energy So Far Today” as regular kWh feeds. So Influx holds all of the “base” data. A few weeks ago, I “upgraded” from the Aeotec to the IotaWatt with a CT on each of my CU breakers adding a great next level of power detail into the mix.

Of the three Energy feeds available, what I have found most useful, is “energy since device start up”. It replicates the familiar counter on the meter and you can re-create the other feeds from this if needed. In fact, you can calculate energy useage for a custom period using relatively economical queries (e.g. last(value) - first(value) of a particular year, month, week, day or hour) rather than having to do large sumations of many small period values.

Feels like the IotaWatt is in a great position to provide a robust energy “accumulator” given its low-level sampling and offline data-logging. The Aeotec occasionaly loses signal and leaves “flat” periods until we notice and get it going again. However, one advantage of the Aeotec is that I can set different reporting periods for V/I/W (every 30 seconds) versus Energy (every hour). I can also “true-up” the Aeotec when we do a meter reading. As a thought, I would trade the “calculator” functionality specific to the Server Set-up screen in favour of setting a “per channel” reporting interval for each of the already defined input/output channels.

I read in the previous posts the trade-off between length of history vs breadth of data being logged. This sounds like a tricky decision as my guess is that you’ve got two different sets of potential customers out there. Those wanting the IotaWatt to simply feed into a broader data pool versus those looking for a combined acquisition/storage/monitoring one-stop-shop. I guess I would be pushing for breadth of data (e.g. Current, Energy, PF, …) and I doubt I would ever need more than a months worth of IotaWatt history as pure contingency. Something like changing the “Units” entry field in the CT channel setup page to be a drop-down list of available metrics such as (Power, Current, PF, Energy, …) would be brilliant for me. Anyway, given all the efforts you have put into usability, I certainly hope you manage to get this beyond the data junkies like me and into the mainstream!


(Inactive) #187

That’s what’s maintained in the IotaWatt log, and as you say, everything else is a derivative of that. Reporting that is easy, what I need to think about is the user interface.

Most of what you are looking for is possible and probable in the future. Thanks for the feedback and for being in the vanguard.


(B Rotten) #188

Bob, at some point while configuring my inputs, the Input Channel Status screen stopped showing anything. I can see all the feeds on the graph page.

Capture

Brian


(B Rotten) #189

I made an edit to the configure outputs and the Input Channel Status screen started displaying again, but the controller seems to be resetting over and over from an exception, with no data being uploaded to emoncms.

** Restart **

No clock yet: SD initialized.
10/28/17 01:24:51 Real Time Clock is running. Unix time: 1509153891
10/28/17 01:24:51 Version: 02_02_21
10/28/17 01:24:51 Reset reason: Exception
10/28/17 01:24:51 Trace: 16,17,18,11,90,91,84,86,88,93,94,95,99,12,13,14,15,16,17,18,13,14,15,16,17,18,13,14,15,30,31,32
10/28/17 01:24:51 ESP8266 ChipID:11725030
10/27/17 17:24:51 device name: IotaWatt, version: 3
10/27/17 17:24:51 Local time zone: -8
10/27/17 17:24:51 MDNS responder started
10/27/17 17:24:51 You can now connect to http://IotaWatt.local
10/27/17 17:24:51 HTTP server started
10/27/17 17:24:51 dataLog: service started.
10/27/17 17:24:51 dataLog: Last log entry:1509153890
10/27/17 17:24:52 statService: started.
10/27/17 17:24:52 timeSync: service started.
10/27/17 17:24:52 WiFi connected. SSID: CarmenLeah5, IP: 192.168.0.202
10/27/17 17:24:56 EmonService: started.url: emoncms.org, node: IotaWatt, post interval: 10, encrypted POST
10/27/17 17:24:56 EmonService: Start posting from 1509152970

** Restart **

No clock yet: SD initialized.
10/28/17 01:24:57 Real Time Clock is running. Unix time: 1509153897
10/28/17 01:24:57 Version: 02_02_21
10/28/17 01:24:57 Reset reason: Exception
10/28/17 01:24:57 Trace: 16,17,18,11,90,91,84,86,88,93,94,95,99,12,13,14,15,16,17,18,13,14,15,16,17,18,13,14,15,30,31,32
10/28/17 01:24:57 ESP8266 ChipID:11725030
10/27/17 17:24:57 device name: IotaWatt, version: 3
10/27/17 17:24:57 Local time zone: -8
10/27/17 17:24:59 MDNS responder started
10/27/17 17:24:59 You can now connect to http://IotaWatt.local
10/27/17 17:24:59 HTTP server started
10/27/17 17:24:59 dataLog: service started.
10/27/17 17:24:59 dataLog: Last log entry:1509153895
10/27/17 17:25:00 statService: started.
10/27/17 17:25:00 timeSync: service started.
10/27/17 17:25:00 WiFi connected. SSID: CarmenLeah5, IP: 192.168.0.202

I think I will take a break for a while. :slight_smile:

Brian


(Inactive) #190

Brian,
Two issues here:

The configuration app is javascript, and it is completely event driven, so sometimes when doing a lot of transactions, something can get missed and seem to freeze the app. When that happens, I usually reload the app and pick up where I left off.

The repetitive resets indicate a more serious problem. Thetrace shows that IoTaWatt is in the middle of building an Emoncms post. The trace doesn’t do much to dig any deeper. I think that deleting the log file should stop the resets. Another option is to edit the config file to stop the Emoncms process. Both of those require removing the SD card and mounting it in another device that can read and edit it.

The log file is at
/IotaWatt/IotaLog.log (there is a .log and a .ndx, delete both)

I’ve been looking at strategies to build a diagnostic mode for situations like this, but it’s nothing available now. I do have some things nearly ready to roll out that provide backup for the log.
If you get the SD out, can you send me a copy of your config.txt. That might help figure out what happened.

Sorry for the trouble.

Update: You might first try and see if you can delete the log with the file manager app. The IotaWatt only runs for 6 or 7 seconds between exceptions, but that might be enough given that you seem to have been able to display the log. It will restart between running the app and actually deleting, but it might work. Restart (power cycle) the IotaWatt after you delete the file.


(B Rotten) #191

No worries Bob.

I pulled the card and deleted the two files, after restarting it continued to have exceptions. I turned off the posts to the emoncms server and it stopped resetting, although I can’t get the Status screen to show again.

Brian

** Restart **

No clock yet: SD initialized.
10/28/17 05:28:53 Real Time Clock is running. Unix time: 1509168533
10/28/17 05:28:53 Version: 02_02_21
10/28/17 05:28:53 Reset reason: Exception
10/28/17 05:28:53 Trace: 16,17,18,11,90,91,84,86,88,93,94,95,99,12,13,14,15,16,17,18,13,14,15,16,17,18,13,14,15,30,31,32
10/28/17 05:28:53 ESP8266 ChipID:11725030
10/27/17 21:28:53 device name: IotaWatt, version: 3
10/27/17 21:28:53 Local time zone: -8
10/27/17 21:28:53 MDNS responder started
10/27/17 21:28:53 You can now connect to http://IotaWatt.local
10/27/17 21:28:53 HTTP server started
10/27/17 21:28:53 dataLog: service started.
10/27/17 21:28:53 dataLog: Last log entry:1509168530
10/27/17 21:28:53 statService: started.
10/27/17 21:28:54 timeSync: service started.
10/27/17 21:28:54 WiFi connected. SSID: CarmenLeah5, IP: 192.168.0.202
10/27/17 21:28:58 EmonService: started.url: emoncms.org, node: IotaWatt, post interval: 10, encrypted POST
10/27/17 21:28:58 EmonService: Start posting from 1509152970

** Restart **

No clock yet: SD initialized.
10/28/17 05:28:59 Real Time Clock is running. Unix time: 1509168539
10/28/17 05:28:59 Version: 02_02_21
10/28/17 05:28:59 Reset reason: Exception
10/28/17 05:28:59 Trace: 16,17,18,11,90,91,84,86,88,93,94,95,99,12,13,14,15,16,17,18,13,14,15,16,17,18,13,14,15,30,31,32
10/28/17 05:28:59 ESP8266 ChipID:11725030
10/27/17 21:28:59 device name: IotaWatt, version: 3
10/27/17 21:28:59 Local time zone: -8
10/27/17 21:29:01 MDNS responder started
10/27/17 21:29:01 You can now connect to http://IotaWatt.local
10/27/17 21:29:01 HTTP server started
10/27/17 21:29:01 dataLog: service started.
10/27/17 21:29:01 dataLog: Last log entry:1509168535
10/27/17 21:29:02 statService: started.
10/27/17 21:29:02 timeSync: service started.
10/27/17 21:29:02 WiFi connected. SSID: CarmenLeah5, IP: 192.168.0.202
10/27/17 21:29:06 EmonService: stopped.

IOTAWATT.zip (3.0 MB)


(Inactive) #192

Sending the entire iotawatt directory was a good idea because I got to review the whole log. There are some thinks in there that I’ll follow up on. I have been seeing some issues in my local system relating to prosing to Emoncms.org, but this is the first instance I see of the same problem elsewhere. I’ve been in touch with OEM about it and will get it resolved.

But that’s not the problem. My systems recover from the errors, and yours did too, for many hours, before the problems started.

See if this narrative rings true for you:
You got the box running around 3pm on the 24th.

It ran fine and a day later, on the afternoon of the 25th, you did some work on it. I can’t see what that work was, but there is one reset that wasn’t caused by a removing the power supply, so I’m guessing the box was open, and you pressed the reset button, maybe even by accident. That’s not a problem, but I am wondering when you removed the internal burden resistors to support SCT013-030’s.

Another day goes by, still running fine, and on the afternoon of the 26th, you sit down to configure Emoncms. That goes OK and the box starts uploading. You don’t see any external indication, but there are two or three communication problems per hour going forward. IotaWatt is resending the data and it is working as designed.

Now comes yesterday afternoon the 27th. At 2:40pm your wifi drops, restores, drops again and restores again. Then nothing in the log until the first exception reset two hours later, a little after 5pm. The exception occurs processing the Emoncms portion of the config file, and since was not after a restart, that had to be from a save in the configuration app. I suspect that’s when the status screen stopped updating, after an update to the Emoncms specification. You may have noticed it later, but that appears to be the case.

So then about 9:45pm there is a half hour lapse followed by a power on, so I’m wondering what happened there. When it comes back, the datalog appears to still be there.

To clarify the status, when did you delete the datalog? The log in the iotawatt library that you posted goes from when you installed on the 24th, right up to after your last restart in the msglog. Regardless, without looking at every bit, the datalog overall looks fine, so if it wasn’t deleted, lets leave it for now.

What I need to see is your config file. It’s called CONFIG.TXT and is in the root directory of the SD card.


(B Rotten) #193

I spent the first couple of days bench testing and setting up the two “generic” CT’s I had from a previous system. I know I hit the reset a couple of times, possibly because of the blank input status page I was getting.

I removed one and swapped one burden resistor the first night, I think, and removed them all the second night. (Sorry, my memory is the worst)

I saw the wireless errors in the log, I was at work, so can’t say if my router had a problem or not. I installed all of my CT’s and finished configuring the system yesterday evening.

Brian

iotawatt_config.txt (2.2 KB)


(Inactive) #194

The config looks OK. So i’m under the impression that right now, you get nothing on the status screen. If that’s the case, can you try just issuing the following URL from your browser?

iotawatt.local/status?stats=yes&inputs=yes,&outputs=yes

If you don’t get a response, try it with each of the three parameters individually, and let me see the results. I’ll be curious to see what is coming back, if anything.

Can you verify that all the other services are working (except Emoncms), like graph and the configuration stuff.


(B Rotten) #195

Corrext, nothing on the status screen.

{“stats”:{“cyclerate”:632.3172,“chanrate”:40.01875,“runseconds”:79165,“stack”:21552,“version”:“02_02_21”,“frequency”:60.03109},“inputs”:[{“channel”:0,“Vrms”:123.2576,“Hz”:60.01877},{“channel”:1,“Watts”:" 0",“Irms”:“nan”},{“channel”:2,“Watts”:" 0",“Irms”:“nan”},{“channel”:3,“Watts”:" 4",“Irms”:“0.041”,“reversed”:“true”},{“channel”:4,“Watts”:" 2",“Irms”:“0.026”},{“channel”:5,“Watts”:“306”,“Irms”:“nan”,“Pf”:NaN,“reversed”:“true”},{“channel”:6,“Watts”:" 0",“Irms”:“0.000”},{“channel”:7,“Watts”:" 0",“Irms”:“0.000”},{“channel”:8,“Watts”:" 0",“Irms”:“0.000”},{“channel”:9,“Watts”:" 1",“Irms”:“0.022”},{“channel”:10,“Watts”:" 1",“Irms”:“0.057”,“reversed”:“true”},{“channel”:11,“Watts”:" 0",“Irms”:“0.000”},{“channel”:12,“Watts”:" 6",“Irms”:“0.058”,“reversed”:“true”},{“channel”:13,“Watts”:“470”,“Irms”:“4.201”,“Pf”:0.908134},{“channel”:14,“Watts”:“465”,“Irms”:“3.828”,“Pf”:0.98627,“reversed”:“true”}],“outputs”:[{“name”:“Everything_Else”,“units”:“Amps”,“value”:614.6484,“Watts”:614.6484},{“name”:“House”,“units”:“Amps”,“value”:7.591116,“Watts”:7.591116},{“name”:“test”,“units”:"",“value”:0.070452,“Watts”:0.070452},{“name”:“test2”,“units”:"",“value”:0.070452,“Watts”:0.070452}]}

Everything else works ok.

I have diddled with it this evening, so a few differences from the config I sent earlier.


(Inactive) #196

OK, I think I see what’s going on. Let me work on it awhile and I’ll get back in a day or two.
Thanks