Community
OpenEnergyMonitor

Community

Installing emoncms on local servers

Hello, I have been using Emoncms on PI for many years, now i want to install multi user server on ubuntu. All is fine and and the inputs and database work. Now i want to install group module and get errors. Also the email took a long time to fix. And now i have installed the Task module but cant find process module that is required.

can someone help?

Edited thread name. BT, moderator

Hello @dori Im not sure that the task module is up to date with the latest emoncms version, It was a development by carbon coop here https://github.com/carboncoop/task it looks like the last updates were 2-3 years ago. Might be worth raising an issue there but not sure if its still in development now

Hi Trystan

I will check that. What about the group module, the gui is not showing and there is no menu showing.

The group module should work, are you using latest master branch of both core are the group module?

Þann 08.05.2020 16:03, skrifaði Trystan Lea via Community:

TrystanLea [1]
8 May

The group module should work, are you using latest master branch of
both core are the group module?


Visit Topic [2] or reply to this email to respond.

IN REPLY TO

dori [3] Halldór Axelsson
8 May

Hi Trystan I will check that. What about the group module, the gui is
not showing and there is no menu showing.


Visit Topic [2] or reply to this email to respond.

To unsubscribe from these emails, click here [4].

Links:

[1] https://community.openenergymonitor.org/u/trystanlea
[2]
Installing emoncms on local servers
[3] https://community.openenergymonitor.org/u/dori
[4]
https://community.openenergymonitor.org/email/unsubscribe/97aa623647bcb510a5ad04b33df97c94c4367f2e58f1f88659164eed800c988b

Hi
Im using this


is that correct?

@dori did you install emoncms using git?

version of emoncms core:

/var/www/emoncms/version.txt

version of the group module:

/var/www/emoncms/Modules/group/module.json

Hello

My directory is /var/www/emoncmsorg/emoncms end there is no file “version.txt”

The modus file says “Name” : Group and “version” : 2.0.0

Hello @dori

I would use the emoncms repository rather than the emoncmsorg repository. The latest version of emoncms.org is closer to the main emoncms repository now and I still need to update the emoncmsorg repository which is lagging behind a bit now.

You will get the best results if you use our EmonScripts install script on a debian server https://github.com/openenergymonitor/EmonScripts.

Ok, Will I have the https support and multi user functionality.?

yes both are covered by the standard repository

you need to add

enable_multi_user = true

in the interface section of settings.ini

https is independent of emoncms , e.g you could use letsencrypt?

Hi TrystanLea

Do I then not use the input_qeue_processor or the storageserver0 code. I already have inputs and feeds in the system. Do I have to reconfigure that?

Hello @dori, how many accounts and feeds are you hosting on this server? Have you been running the server for a long time?

Hello TrystanLea

I have about 8 accounts and 50 feeds for 15 days. The old data is now
working in the new server. I have php 7.3 and now the email is not
working. I have installed SwiftMailer as instructed.

ERROR>email.php|check() Could not find SwiftMailer, email functions are
ignored.

Þann 10.05.2020 13:50, skrifaði Trystan Lea via Community:

great, where did you install swiftmailer? Do you have the /opt/emoncms/modules directory structure?

Yes we followed the instruction in the Lib/email.php file.

Hi

How can we debug this email error, SwiftMailer can send messages with a small test program. So it is emoncms code not finding the right path?

image001.jpg

Im not sure what is going wrong Im afraid.

The error that you are seeing is coming from this line: https://github.com/emoncms/emoncms/blob/master/Lib/email.php#L44 and so the !$this->have_swift condition must be satisfied.

It should have loaded swift here: https://github.com/emoncms/emoncms/blob/master/Lib/email.php#L30

$this->have_swift = @include_once("$linked_modules_dir/swiftmailer/lib/swift_required.php");

One possibility is that $linked_modules_dir is incorrect on your system.

$linked_modules_dir is set here https://github.com/emoncms/emoncms/blob/master/process_settings.php#L58 and should be /opt/emoncms/modules

Is the file /opt/emoncms/modules/swiftmailer/lib/swift_required.php present on your system?

Ok, it gives me /home/pi as the $linked_modules_dir ?

image001.jpg

Thanks @dori are you using settings.ini or a settings.php file to configure?

Hi

I believe settins.php but there is also settins.ini in my folder.

image001.jpg