Installing emoncms on local servers

At the moment settings.php is overriding settings.ini for you. Did you create the settings.php file from example.settings.php

It sound like you have the old format installed and its using it as a fallback. I would recommend upgrading to the new settings format, you may find the .ini format easier.

copy example.settings.ini to settings.ini and copy over your database and other settings, copy over other settings from default-settings.ini as required. Then once you are happy, remove settings.php.

Hi TrystanLea

Thank you for your help, now email is working and the setup is stable.

Is tow factor registration supported? And how can I translate the interface to Icelandic?


Where can i find the option to verify email when registering new users?
and why cant a make my feeds public, nothing hapens when i click the lock icon?


That is not implemented AFAIK.


The translation files are here

You can submit a new file etc via a PR.

Select the feed and click edit.


Should be clear from there :grin:

Now i have started the translation to icelandic but my server is not responding, I always get english. Is there i guide for installing multi languages. I use ubuntu 18.4


I’m having trouble understanding the language settings, I have edited the po/mo files but see no change in the web page, is the data cached or buffered somewhere?




Have you set the language in the user profile?

You might need to add it to the drop down - not sure where it gets that list from unless it builds it dynamically. You might need to restart Apache.

This came up before, I think you need to change it in the settings. There is something odd about the language selection logic IIRC.

This was the previous discussion but I think it was fixed. Help to change default user interface

Can we have more than one recipient for email in the process list?