Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Getting data from the serial port

Hi, I am trying to read in the serial debug data from the diyBMS. I have an ftdi cable connected to my computer and the ftdi’s RX connected to the serial debug pin on the controller board and the ftdi’s gnd pin connected to gnd. I know that serial debug data is being transmitted because the blue LED is flashing, but I don’t see any output when I run screen /dev/tty.usbserial-A505V8AB 115200, any idea why I’m not seeing anything? Thanks

Do the LEDs on the FTDI cable light up at the same time as the blue led on the wemos ?

The LEDs on the FTDI cable do not light up. So, somewhere between the transmission from the WEMOS and the FTDI there is something wrong. It’s a new FTDI, but I can do some testing on it if you think that’s the problem.

Than you for responding. My ultimate goal it to get serial data through the micro USB on the WEMOS, I haven’t been able to get that to give me anything either. Is that possible in this configuration? I added a Serial.begin(9600) in the main setup code and a simple Serial.println(“hello world”) in the main loop. This worked before flashing the diyBMS code

The serial port on the ESP8266 is used to communicate with the modules, so can’t also be used for USB.

There is a 2nd serial port which is used for the debug header, however this can only transmit data from the ESP, not receive.

Ohh, the micro USB is not a separate UART, so I’ll have to use the debug header. I only need to receive data from the ESP, so that’s fine.

In which case, go through the code and remove all the SERIAL_DEBUG references, then you can use that serial port for your own purposes.

That’s fine, but I still can’t see any serial output from the serial debug interface. I’ve tried a different FTDI that I am positive works, any ideas?

Nevermind, the solder connection wasn’t good. I’ve got data now! Thank you for your help

1 Like