Community
OpenEnergyMonitor

Community

Feeds not working on emoncms.org

(John Newton) #1

Just got EmonPi to day and having trouble getting it going the feeds seem to be working OK locally but not in emoncms.org. The data viewer in the graphs is showing,

Request error Notice: Undefined index: time in /var/www/emoncms/Modules/feed/feed_model.php on line 362 [[1556747100000,null],[1556748000000,null],[1556748900000,null],[1556749800000,null],[1556750700000,null],[1556751600000,null],[1556752500000,null],[1556753400000,null],[1556754300000,null],[1556755200000,null],[1556756100000,null],

I have a pretty basic understanding of this so would appreciate any help
Screenshot 2019-05-08 23.02.46.pdf (228.9 KB)
Devices.pdf (165.7 KB)
Feeds.pdf (270.8 KB)
Inputs.pdf (313.7 KB)

1 Like
(Brian Orpin) #2

Hi John, as a point of note, it is easier if you simply paste PNG/JPEG directly into your post rather than attatching pdfs/images. On Windoze you can use the Snipping tool to get images then literally just paste that into the message.

Don’t know how to fix your issue - sorry. Is this error in the local emoncms or the remote?

(John Newton) #3

Hi Brian thanks for the tip the error is in the remote, the screenshots show both side by side if you look in the address bar you can see local is the left one.
I purchased from the open energy shop 7 May order no 20322
<a class

=“attachment”


(Brian Orpin) #4

@glyn.hudson can you take a look please.

(Glyn Hudson) #5

Hi John,

It looks like the data is being logged to emoncms.org any more. Notice on your local screenshots the values are being updated every few second while on the remote server no updates are being received. The error is due to there being no data to via.

Could you check that your remote read-API key is in your emonhub config, and if still having issues please post your emonhub log file for us to take a look. See: https://guide.openenergymonitor.org/setup/remote/

(John Newton) #6

Hi Glyn
Thanks for getting back to me apologies but I am pretty basic at this stuff’ The log file above in red is saying something about an error on line 32 and this same message appears in all the graphs
I have this key posted in the config file
subchannels = ToEmonCMS,
url = https://emoncms.org
apikey = 755a1
senddata = 1 # Enable sending data to Emoncms.o

The log file is saying:- /var/log/emonhub/emonhub.log does not exist & I cant see any option to change this. clicking on the View log button does nothing

just gone to the Admin page and have downloaded a log from there
Server inof.txt (3.6 KB)

(Robert Wall) unlisted #7
(Glyn Hudson) #8

I think I’ve spotted the issue, you have used the ‘read’ API key rather than the ‘write’ API key in emonhub config. Emonhub requires write access to you emoncms.org account to post data. The write APi key should end with ‘42e’.

It’s best not to post your API keys publicly.

(John Newton) #9

Thanks Glyn I think I have used that before and it didn’t work, but I will try it again and use the 42e key

(Glyn Hudson) #10

It must have worked for a short while since the Inputs initially appeared in Emoncms.org

(Robert Wall) #11

Can we delete the keys and re-list the topic now?
(And was there a better way of concealing the APIKeys from all & sundry?)

(Robert Wall) listed #12
(John Newton) #13

Sorry about that will not do it in future I have deleted them

(Robert Wall) #14

Publishing your APIkeys - especially to emoncms.org - meant that ANYONE who noticed them could hijack your account and use it for themselves. That wouldn’t be good.

(I’d already deleted them, and you deleted my edit! Not to worry, though.)

(John Newton) #15

Hi Glyn I have tried that putting the 42 ley in everything and rebooting the pi but still nothing

(Glyn Hudson) #16

Great, I can see you inputs from emonPi (node 5) are updating now. You just need to log them to Feeds. Unlike for local Emoncms emoncms.org uses numerical Input names to optimize bandwidth.

(John Newton) #17

Hi Glyn I already have these fields mapped

(Glyn Hudson) #18

It looks like your Input Processes are using names rather than numerical Input ID numbers. Click the spanner icon next to the numerical Input ID’s to log them to a feed.

(John Newton) #19

Hi Glyn
I am getting totally out of my depth here I have got three of the feeds logged can you tell me what names and values I should be using I am trying to get the Solar app to work (I have it working on the local machine although not properly but I will post that when I get this sorted out) I enclose screenshot of input and ouputs inemoncms.org

(Glyn Hudson) #20

I’ve just corrected the Input Process setup for you. I followed the Type1 solar PV setup guide from: https://guide.openenergymonitor.org/applications/solar-pv/#type-1-system-setup

My solarPV is working now :slight_smile:

Alternately you could have used the new device module autosetup by enabling the device module beta on your account page: