Error trying to null bad data in logs

Hi All,

Rather than resurrect a two year old topic “manually edit feed data” I thought I should start afresh, as while the procedure might be obvious I’m getting an error…

While looking at historic data I noticed that on a few of days in mid October early November the logs recorded some seriously dodgy data that I’d like to remove.

So I tried going to Visualisation and Edit Realtime but get this error

Have I done something wrong? Is there a “I don’t know what I’m doing” guide that I’ve missed explaining how to edit the data?

Thanks :slight_smile:

1 Like

Your timing is impeccable, @Techno !

I have today hit the exact same error. I have a temperature feed from a DHT22 running on an ESP32 pumping data into emoncms’s MQTT broker, and it has clearly had a single outlier spike at -1°C at some stage recently, and I want it edited to smooth out that graph (because another virtual feed is doing a ‘flow - return temperature difference’ calculation, and that outlier is ruining my axis and wrecking my OCD :smiley: )

So I did the same as you - went into Visualisations, chose EditRealtime, selected the feed in question (in my case, #77) and got exactly the same error (aside from the feedid). Same everything else - line and column number. I get it on all feeds, it turns out.

And in my case, selecting ‘full-screen’ instead of ‘view’, I see the same error but on line 346. Is this the same for you?

I’m on latest stable everything. Running emoncms et al, on a Raspberry Pi (albeit on Buster I think). Everything else seems nominal.

This looks like it needs to be raised as an issue on GitHub - @TrystanLea

1 Like

Good point, @borpin - I confess I didn’t think of checking the github earlier when I posted.

Just checking this morning, and I realise it’s been on the issues list since 16-March.

All good - it’s logged. We just have to sit tight now until it gets sorted. Might even have a crack at myself, but not sure I’m brave enough :slight_smile:

(reading deeper, it’s a security change in Chrome/Chromium that’s causing this, based on the fact that the URLs have whitespace-codes and < brackets in them. Short-term solve @Techno might be just to use Edge or Firefox to do that job? Gonna give it a whirl when I’m back from the school-run…)

1 Like

That’s a ‘no’ on MS Edge. Same error.

I guess as Edge is based on Chromium as well then it’s something in the core thats rejecting the code

Yay some success, I’m not getting the error using Firefox on a Mac and it seems to be removing some of the peaks, I need to pay more attention to the time code to verify if the reading I’m editing doesn’t last for more than one record.

However if I try the “delete data in window” option in Firefox then I get a new error.

Hunch: from emoncms/Modules/vis at master · emoncms/emoncms · GitHub

where it says:

To achieve the edition function, please note they must be run in full screen mode

maybe give that a whirl in fullscreen mode instead of View mode, and see whether it still fails? The ‘modal’ error tends to support the hunch (given that modal is probably missing unless the display is fullscreen, maybe?)

Apologies if this is a goose-chase.

Looking at the code, I’ll put my hand up and say my knowledge of MVC website coding is not good enough to actually solve this issue and make a pull-request - at least, not yet.

Good point I’ll give it a go.

I’ve managed to edit a shed load of point data, not exactly fun but the historic data is looking much cleaner now.

Thanks for all your help.

1 Like