Error PCF8574 is NOT fitted, relay control not possible! V4.21 w/ attiny841-ssu

hey @stuart

I just realized im getting error: PCF8574 is NOT fitted, relay control not possible!

I boards built by JLCPCB and the IC on the controller boards are PCF8574T

Ive found some posts that mention that if using a slightly different version the i2c address is different. But since these are built using the BOM file, shouldn’t the i2c address be correct?

Or should I change the i2c address in the main.cpp to 0x20 ???

If it’s never worked then change the i2c address in the code should fix it.


Now after reflashing the 8266 d1 mini isn’t broadcasting a ssid…

When flashing with vscode platformio I’m getting the “time” error periodically… But even when It flashes with out the error it still doesn’t broadcast a ssid…

I went to GitHub link mentioned in main.cpp and tried the renaming time.h etc… But still nothing

If you just did a reflash it will have remembered the WiFi settings so will connect to the WiFi access point.

If you want to reset the WiFi, connect the WiFi reset pins together when the led lights on power up (but not before)


I literally spent almost all night trying everything I could possibly think of and find and probably flashed the d1 mini 30+ times… Lmfao

So reflashing the d1 mini it doesn’t overwrite my wifi settings? Well that make sense of why it wasn’t in AP mode broadcasting its own wifi…

Thanks for the help