Community
OpenEnergyMonitor

OpenEnergyMonitor Community

emonTx3 with ESP8266 - No data and cannot connect to Emoncms

I have an emonTx3 with ESP8266 module (I flashed this module myself) and looking at the web interface, there is no data coming in. I also cannot connect it to my locally running emonCMS server.

These issues sound very similar to this. It seems no resolution was found there so I’m not really expecting anyone to be able to resolve this but thought it was worth asking before resorting to other options to get it to work.

I have tried a different ESP8266 module and that worked correctly. I also tried the module with the issue in a different emonTx3 and had the same problem, so it certainly points to something amiss with the module itself. I’ve tried erasing and reuploading the firmware to no avail.

Is the emonTX a recent purchase?
If you have a USB to Serial connector, connect to the EmonTX with a serial monitor and check the output data. Oh you say it works with another module.

@Robert.Wall, do the setting need to be changed on the latest firmware to enable the serial output?

Did you look at this guide Using the emonTx v3 with the ESP8266 Huzzah WIFI module - Guide | OpenEnergyMonitor

Remember, unlike almost every other system, on the emonTX you connect TX-TX & RX-RX (yes we know).

I think you are correct, it must be to do with the configuration of the serial ports on that ESP, especially as a different ESP module works.

Or of course, the hardware has a fault.

Ahhh ok. It’s working now that I’ve sorted the pin connections out, thank you! I was referencing the Github page which I don’t believe mentions this.

I’m curious as to why that stops it connecting to EmonCMS? Not that it matters since that bit works now also.

I think it was connecting, just was not sending any data as it didn’t have any.