emonTX reporting odd values in emonCMS

I have just been through an exercise of flashing my emonPi, emonTX3 and emonTH2(s) to the latest LPL versions of firmware. After some initial pain around re-configuring the config file to see the emonPi, I have now got everything reporting successfully. However the emonTX3 seems to be reporting screwy data in emoncms…and I hope someone can point to any changes I may have missed. All the devices were reporting successfully on the older classic firmware.

A serial monitor on the emonTX3 shows:

However emoncms is reporting:

What have I done wrong?

I’m at the point I may create a new SD card with the latest load to start afresh…but before I do that, I thought I’d ask!

Are you using the built-in UHF radio or a wired/Wi-Fi connection to yor emonPi? A rssi of -93 is cause for concern - that’s hardly a viable signal.

Have you got whitening on in emonhub.conf? If you’re using LPL, it must be off. Otherwise, it should be on.
[ @TrystanLea - A serious omission in the serial printout at startup - there’s no mention of which radio library is being used. :rage: ]

If whitening isn’t the problem, and you are using radio, the Node description in your emonhub.conf doesn’t match the sketch you loaded into the emonTx V3.4
What is the entry in emonhub.conf for Node 15? It should read

  nodename = emonTx3cm15
    names = MSG, Vrms, P1, P2, P3, P4, E1, E2, E3, E4, T1, T2, T3, pulse
    datacodes = L,h,h,h,h,h,l,l,l,l,h,h,h,L
    scales = 1,0.01,1,1,1,1,1,1,1,1,0.01,0.01,0.01,1
    units = n,V,W,W,W,W,Wh,Wh,Wh,Wh,C,C,C,p

The two screenshots are not consistent. Did you have any c.t’s connected when you grabbed the serial monitor printout? It hasn’t detected, hence hasn’t listed, any. Did you have the a.c. adapter connected when you grabbed the emonCMS screenshot?

1 Like

Yes looks like whitening is turned on to me as well. You can either set whitening = 0 or remove the line completely. Hopefully that should solve it.

1 Like

Not directly related to your question, but something you might want to check …

I also updated my emonPi to LPL format. Afterwards I found that the emonPi LCD display was not correct

I would be interested to know if your emonPi LCD display is behaving in the same way as mine!

1 Like


Thank you for the comments. This is using the UHF radio…but I do have a ESP card that could be used to setup Wifi if coverage becomes an issue…but I didn’t seem to be missing data even at that failry weak signal strength. The emonTX is currently on my desk about 22m from the emonPi (which itself is in a cupboard). Eventually it is going into the garage and will be a little closer to the emonPi…so I don’t know what the signal strength might be, but there is a separate WiFi access point in the garage for a worst case scenario. Rather tongue in cheek and ironically…I’ve just had a Low Noise Amplifier with +23dB gain delivered today for some Earth-Moon-Earth receiver projects on 432-435Mhz…maybe that would help that rssi figure improve :rofl:

Back to the issue at hand however, I’ve just checked and whitening does appear to be on. This is the current node description:

    nodename = emontx3cm15
        names = MSG, Vrms, P1, P2, P3, P4, E1, E2, E3, E4, T1, T2, T3, pulse
        datacodes = L,h,h,h,h,h,L,L,L,L,h,h,h,L
        scales = 1,0.01,1,1,1,1,1,1,1,1,0.01,0.01,0.01,1
        units = n,V,W,W,W,W,Wh,Wh,Wh,Wh,C,C,C,p
        whitening = 1

I just changed the whitening setting, and that seems to have fixed the issue! Thank you so much!

I forgot to comment on the last paragraph. There were no CTs connected at this point, and the screenshots were taken at essentially the same time - so any inconsistency is a function of the whitening setting I guess. The ac adapter was connected and the unit was being powered by a separate 5V supply.


I will check to see what is displayed!

The clue was: the whitening value is 0x55 applied to every byte of the message to prevent a long stream of zeros - which otherwise means the receiver can lose sych. Convert those long energy values to hex and you get 0x55555555. (Even if it wasn’t 0 to start with, you’d still get 0x555… or something like.)

Whitening is unnecessary when the message is encrypted, as it is in LPL.

Those thoughts would have been relevant if it wasn’t whitening - which was almost a certainty but nevertheless…

1 Like

@rdavies6 Thanks!

1 Like

It doesn’t appear to have too much information, just a confirmation it is hardwired, and the local subnet address it has been assigned. I tried pressing the button, but nothing seems to change the display. Is there a special incantation I need to use?

Given it sits in a cupboard out of normal sight, I can’t say I have ever used or configured the display…I’m not even sure how you would configure it!

Happy to try making changes if you want to test something.

@rdavies6 Well that’s different!

After the emonPi has been turned on and is running, in my case pressing the button turns the display on and shows the first display. Then pressing the button again cycles through a total of nine displays:

WiFi: YES 86%


Pulse: 300p

Temp 1: 250.37oC
Temp 2: 10.62000

Nov 27 18:42
Uptime 0.72 days

Serial: xxxxxxxx

SSH Enable?
Y press & hold (short press to ignore SSH, second short press to move to next display)

Y press & hold (short press to ignore Shutdown, second short press to move to next display)

and then back to the start

I have updated the emonPi since I put he SD card in. In Admin it says: Emoncms Version low-write 11.4.1.

So I’m not sure why you only see one display. I don’t think the display is configurable.

You’re right, it’s not. The only thing you can do is show the currents whilst calibrating the emonPi.

I didn’t know that one could do that! Thanks for the information.

I can see in the emonPi Docs that there is a section on configuration that lists the commands available, when using the emonPi_CM firmware. These are similar to to the commands used over a terminal/serial/USB link with an emonTx3/4. Presumably with the emonPi front end, the commands would be sent over ttyAMA0.

In my emonPi Admin menu there is a Serial Config entry, although the heading says EmonTx4 Serial Config Tool. Do you just change the serial port in it to ttyAMA0 to talk to the emonPi front end? And how do you get the currents to appear in the LCD display?

Apologies for all the questions if this documented somewhere, or I have misunderstood something!

I don’t know what Trystan has put in the Admin menu. All I know is what I put into the CM sketch for the emonPi (V1) front end, to enable emonCMS to send a command to do it. I don’t know whether you type the commands or they’re on buttons. I struggle with emonCMS because the one-line drop-down boxes only mean something when you know what they mean.

It did seem a good idea at the time to be able to at least see the currents on the emonPi’s display if you were next to it with a hand on the c.t. He might well have taken it out or otherwise disabled it.

Likewise, short press of the reset button used to reset the front end only, without shutting down the Pi.
This was in my original write-up for the front-end sketch:

"If the emonPi does not appear in emonCMS the very first time it is powered up (following setting up the Wi-Fi parameters etc), restart the energy monitoring front end with a short press of the reset button adjacent to the CT1 connector.

"The following setup/configuration commands are available:
c - enable current & power factor values to serial output & LCD display, for calibration. n = 0 for OFF, n = 1 for ON.

It should be in Github somewhere.

@Robert.Wall Thanks for the information. Perhaps I need to do bit of experimentation in the Admin / Serial Config section of the emonPi.

The current emonPi Doc section on configuration says

c n = 0 for OFF, n = 1 for ON, enable current & power factor values to serial output for calibration”

so perhaps the values aren’t available on the LCD at the moment.

Seems I’m not the only one having no functionality on the button… Emoncms stable release v11.4.2 - #16 by lord_valex

yes you’re right

Installed 11.4.2 on emonpi 1 over 11.2.9 ( if I remember correct ) everything working.
Now all seams fine but the push botton on the display is not responding. I can push infinite time but nothing.
SDimage quite old 24/7/2020
Any idea to solve ?

My is on wifi
and also connected to 1 emontx

1 Like

@rdavies6 Thanks for the information - a bit of a surprise - it’s always just worked for me so far! Perhaps I’ll not do any updates until it’s fixed …

Sorry will look into the push button issue, I did test it on the desk here before releasing that update and it all seemed to work fine so not sure what’s gone amiss there…

Hi, any news or ideas ?