EmonTx only displays rssi

I recently set up a new installation with 1 EmonPi and 2 EmonTH. Everything is going great and I managed to create my dashboard with all the feeds I wanted to see (I just followed the guide which is great!).

My problem began when I add an EmonTX (with 4 CT, 1 RJ45 temp sensor and AC/AC adapter). When I log locally, I can see the EmonTx node, but it only displays rssi on the input list.

All the instruments were connected before power up. I tried to reset the EmonTx, I unpowered it and restarted it, but I always get the same lonely input.

Thank you for your help !

Try and run and emonPi update (setup > admin > update emonpi).

Thank you for your help, the problem is solved…
but I have a new one : after adding a 4 temperature sensors on a terminal block breakout and rebooting, I now have the Inputs stuck with the “loading…” message.

I cleared the cache of my browser and I hit the Flush button (setup>admin>server information>Redis) as suggested in this topic [“loading…message”]
but no results.

the “loading…” message appears only for locally loging inputs (I can see feeds and others section) and all datas are ok on emoncms.org

I’m experiencing the same problem:
I have successfully added an emonTH and emonTX (Node 8) to my emonbase and all inputs are shown in the local emoncms server. After adding a second emonTX (Node 7) to the emonbase, the node shows up in the inputs menu, but only rssi shows up when expanding the node.

Strangely enough, if I log in to my online emoncms account, all nodes with all of their inputs are shown in the inputs menu, even though they are still absent in the local emoncms inputs menu.

I have done the following to try to resolve the issue:

  • I ran emonBase update under setup>admin
  • After the update I updated the database as well
  • I then restarted the Raspberry Pi

Unfortunately, none of the above has resolved the issue.

Any advice on what to try next will be greatly appreciated.

Edit: After waiting a little longer, my additional emonTX’s inputs appeared as it should and everything is working correctly now.