emonSD-03May16 Release

The node ID is 10 and appears as emontx1 in emonhub. After much faffing I am just about back.I can give you direct SSH if you want to try things, none of the monitoring is critical per se - except when I am using it to drive the MQTT relay of course :slight_smile:

I will look at this separately but I also had a restore issue and had to manually run the restore. Unrelated.

Also, to note, they are all physically co-located in the under-stairs cupboard - not a distance or RF issue.

Glyn - There was another case where reverting back to v2.5 firmware was needed to restore emonTx traffic after an update to v2.6 on an emonPi.
Re: Loss of feeds to EmonPi from EmonTx after update to 2.6

Plus we are still battling against the same issue on the RFM69Pi stops updating/freezes despite following your lead and recompiling the rfm2pi firmware with the updated JeeLib so it maybe you are just experiencing a “good spell” it certainly isn’t fixing it for all unfortunately.

2 Likes

Peter - at the time you bought your emonTx’s the version was < v2.1 which is where a fix was implemented for a known “bit-slip” issue due to a long run of zero’s when the temperature sensor circuits were not used.

How many temp sensors do you have attached to the emonTx?

1 Like

emonPi firmware has been temporarily rolled back to V2.5. While we investigate what’s going on. If a user now runs an update V2.5 will be flashed.

1 Like

No temp sensors. Hence this sounds like that problem!

No “nodes” module preinstalled in this version?
I’ve installed this release

[email protected]:/boot $ ls emonSD-03May16
emonSD-03May16

As a result “node” menu is not existing.

I installed node module manually using git clone. Nodes appeared in the menu but “control feature” seems to not work.
If I issue a POST /nodes/nodeid /nodes/29/tx/values = 1,2,3,4, i get:
[Wed May 11 19:44:15.735212 2016] [:error] [pid 2344] [client 192.168.1.125:58751] PHP Notice: Undefined variable: mqtt_server in /var/www/emoncms/Modules/nodes/nodes_controller.php on line 144, referer: …
[Wed May 11 19:44:15.735456 2016] [:error] [pid 2344] [client 192.168.1.125:58751] PHP Notice: Undefined variable: mqtt_server in /var/www/emoncms/Modules/nodes/nodes_controller.php on line 144, referer: …
[Wed May 11 19:44:15.735593 2016] [:error] [pid 2344] [client 192.168.1.125:58751] PHP Notice: Undefined variable: mqtt_server in /var/www/emoncms/Modules/nodes/nodes_controller.php on line 145, referer: …
[Wed May 11 19:44:15.736531 2016] [:error] [pid 2344] [client 192.168.1.125:58751] PHP Notice: Undefined variable: mqtt_server in /var/www/emoncms/Modules/nodes/nodes_controller.php on line 145, referer: …
[Wed May 11 19:44:15.737972 2016] [:error] [pid 2344] [client 192.168.1.125:58751] PHP Warning: fsockopen(): unable to connect to :0 (Failed to parse address “”) in /var/www/emoncms/Lib/phpMQTT.php on line 78, referer:

Found emonPi Update error for emoncms (git pull /var/www/emoncms) | Archived Forum but had no luck with any of the mentioned solution.

I use emonbase (raspberry pi running this this release ) equiped with rfm12pi v2 (RFM12Pi V2 - OpenEnergyMonitor Wiki)

Any clue?

Note: after i installed nodes i can see the Inputs and nodes updated. Just I cannot use “control features”

Should I use another image? Do i need to configure something because i don’t use emonpi but emonbase?

Part of configuration:
[interfacers]

This interfacer manages the RFM12Pi/RFM69Pi/emonPi module

[[RFM2Pi]]
Type = EmonHubJeeInterfacer
[[[init_settings]]]
com_port = /dev/ttyAMA0
com_baud = 9600 # 9600 for old RFM12Pi
[[[runtimesettings]]]
pubchannels = ToEmonCMS,
subchannels = ToRFM12,

    group = 210
    frequency = 868
    baseid = 15                              # emonPi / emonBase nodeID
    quiet = true                            # Report incomplete RF packets (no implemented on emonPi)
    calibration = 230V                      # (UK/EU: 230V, US: 110V)
    interval =  60                         # Interval to transmit time to emonGLCD (seconds)

[[MQTT]]

Type = EmonHubMqttInterfacer
[[[init_settings]]]
    mqtt_host = 127.0.0.1
    mqtt_port = 1883
    mqtt_user = emonpi
    mqtt_passwd = emonpimqtt2016

[[[runtimesettings]]]
    pubchannels = ToRFM12,
    subchannels = ToEmonCMS,

    # emonhub/rx/10/values format
    # Use with emoncms Nodes module
    node_format_enable = 1
    node_format_basetopic = emonhub/

    # emon/emontx/power1 format - use with Emoncms MQTT input
    # http://github.com/emoncms/emoncms/blob/master/docs/RaspberryPi/MQTT.md
    nodevar_format_enable = 1
    nodevar_format_basetopic = emon/


[[29]]
nodename = 29aq
[[[rx]]]
names = temperature, filter, lights, co2coil, ph, heater, feeder, hh,mm
datacode = h
scales = 0.01,1,1,1,0.01,1,1,1,1
units = C,p,p,p,pH,p,p,p,p
[[[tx]]]
names = phMin, phMax, tempMin, tempMax
units = pH,pH,C,C
scales = 0.01,0.01,0.01,0.01
datacode = h

In case is important:

[email protected]:/var/www/emoncms $ git branch -a
dev-mosquitto-php
master

  • stable
    symlinked_modules
    remotes/origin/HEAD → origin/master
    remotes/origin/low-write
    remotes/origin/master
    remotes/origin/postgreSQLite
    remotes/origin/stable

[email protected]:/var/www/emoncms/Modules/nodes $ git branch -a

  • 9.0
    remotes/origin/9.0
    remotes/origin/HEAD → origin/9.0
    remotes/origin/auth
    remotes/origin/dev-mosquitto-php
    remotes/origin/master
    remotes/origin/v9.0mod

Nodes module has been replaced by mqtt input

Any data published to /emon base mqtt topic will appear in emoncms inputs

Hi Glyn -

When you say the nodes module has been replaced by mqtt, how difficult will it be for those of us (like me) that have never used mqtt and already have our emonpi setup with all of our nodes and pushing to a remote emoncms (v9.4) server?

Is there some kind of walk-through we can see (examples, etc) before we commit to upgrading?

I am just concerned that I will upgrade, things will break, and I will have to learn (on-the-fly) mqtt to try and get everything back up and running. :slight_smile:

Thanks

Should be explained here, let me know if you have any questions or any part could be better explained.

MQTT - Guide | OpenEnergyMonitor

You shouldn’t need to touch mqtt if you don’t want to. When using the new image, anything emonhub receives will just appear in the inputs section. See the local logging section of the new guide. Using mqtt like this instead of the nodes module makes it much easier to connect other integrations such as nodeRed etc to add functionality, since its possible to subscribe to a particular node / key via mqtt.

Thanks Glyn -

I read through the mqtt, but I guess I am still a bit confused. Is there still an emonhub.conf where we control what makes it into our inputs (formatting, etc)? I do not log anything locally but instead have my own emoncms server, will anything change in the way this data gets to my server with the new version?

Thanks!

I doubt this is confined to this release, however…

I thought I’d have 3 bargraphs for a 3-phase supply, using the phase colours.

Err… Ahem… I think there’s a slight issue of readability!

[Apologies if I’ve got a cynical brain :grinning:]

Maybe it is like that when the reading is so high that you wouldn’t want to see it ;o)

Don’t believe the numbers - I was using my CT test rig. So only about 30 real watts being dissipated. :joy:

I’ve made a fresh install with the emonSD-03May16 image, and ran the update via the admin. All is up and running (thanks for the great work!), except for one oddity: MQTT login fails on port 1883. When I try to reach the MQTT server, Chrome replies “This site can’t be reached”.

  • Nor sure if it is related, in admin the logger (/var/log/emoncms.log) diplays a warning:
    2016-05-18 09:52:39.999|WARN|phpmqtt_input.php|Starting MQTT Input script
    2016-05-18 09:52:41.681|WARN|phpmqtt_input.php|Subscribing to: emon/#
    2016-05-18 09:52:41.689|WARN|phpmqtt_input.php|Not connected, retrying connection
    2016-05-18 09:52:41.690|WARN|phpmqtt_input.php|Connecting to MQTT server: Connection Accepted.: code: 0
    2016-05-18 09:52:41.691|WARN|phpmqtt_input.php|Subscribed to topic: emon/#

  • And Server Information (in admin) states
    MQTT Version n/a
    localhost:1883 (127.0.0.1) - what is that IP address (I connect to emonpi at http://192.168.0.132/)

Any idea what is playing up?

thanks,
Marc

How are you trying to connect? Try mqttlens Chrome extension.

Are you referring to the connection error in the logfile? The connection error was then superceded by a successful connection message, it’s just that MQTT server takes a while to fully boot up at startup. Good to hear image is working for you.

Have been trying to connect through browser screen, same way as NodeREd and OpenHab (assumed it would work similarly) allow. Now mqttlens did the trick. Maybe good to mention this in the changelog with the SD release. Anyway, got connected, thanks!

Have been trying to connect through browser screen, same way as NodeREd and OpenHab (assumed it would work similarly) allow. Now mqttlens did the trick. Maybe good to mention this in the changelog with the SD release. Anyway, got connected, thanks!

Ah yes, this is MQTT not HTTP. This is why your browser would not work