emonSD-03May16 Release

emonSD-03May16- RELEASE: HTTP Download (1.7GB) | UK Mirror 1

Canada Mirror: HTTP Download

This image supports Raspberry Pi 3 and will be shipped with all emonPi’s purchased later this month (May 2016).

See User Guide for user documentation.


MD5 Checksum (zip): d102aff6dafd89d2e4d3209eee964251
MD5 Checksum (.img): 08557bda1c12daa76ab94bef0c04f3fd

New Changes forum discussion

  • Append gpu_mem=16 to /boot/config.txt to give us more RAM at expense of GPU
  • Symlink fstab in emonpi repo to /etc/fstab to allow updating
  • Reduce garbage in /var/log/messages but to Raspbian bug
  • Fix log rotate to includue all log files to ensure /var/log does not fill up
  • RasPi3 SSHD fix
  • Fix language pack support (install gettext & locales), language setting in ‘Account’ now works out the box
  • Fix node-RED flows to survive update cycle
  • Trim SD card (allow 60mB of unallocated partition) to fit on all (or majority) of 4GB SD cards, shop pre-built SD cards included with emonPi / emonBase will be 8GB with ~/data partition expanded accordingly.
  • Generate new SSH keys

See emonPi Wiki for full change log.

Previous (emonSD-29Mar16) image old forum discussion.

1 Like

@glyn.hudson - is the Node-RED port correct?

Been fixed :thumbsup: , thanks. Should be 1880

To Glyn and the OEM Team - thank you for all of your efforts creating the new release! I’ll be updating to the emonSD-03May16 release later today!

I’m unable to complete the download of this file. It bombs out at around 1GB with a “Interrupted (NETWORK_FAILED)” message.
Anyone else getting this? Is there an alternate link I can try?

Cheers.

OK… after many many restarts I finally manged to download the file.
As a test I tried with the 8GB_emonSD-29Apr16.img.zip file and that downloaded fine. Server problems?

Oh dear, sorry to hear. We have not been aware of any server issues. The image is served from the same server as this forum and the main site.

Could you try and download via http as opposed to https and confirm if issues persists?

Tried an http download. The transfer went end-to-end without issue.

That’s interesting, The download link in the post above has always been http. Does it auto resolve to https for you?

I don’t think so. Mousing over it gives me: http://openenergymonitor.org/files/emonSD-03May16.img.zip

This time, I did the transfer at home, so different computer ISP, everything.

The earlier transfers were done from my office. We do share the WiFi “campus-wide” so to speak, but it’s a 50 Mb pipe to the internet backbone, possibly a 100 Mb link, not sure. I know that it runs much faster than the 18 Mb link I have at home.
The one thing in common each time the transfer stopped was the byte count. Both times it was at 1.0 GB when it aborted.

Hmm. Stopping at the same place, on a round number? I smell an artificial limit.

Anyone else noticed this issue with download hanging? Maybe temporary glitch? Again downloading ok for me at home this morning over adsl

Issue still occurring here.

I tried to download again, via the link above and http and both ways interrupted at around 1GB.

Via link:
https://community.openenergymonitor.org/clicks/track?url=http://openenergymonitor.org/files/emonSD-03May16.img.zip&post_id=513&topic_id=145

Redirects to:
https://openenergymonitor.org/files/emonSD-03May16.img.zip

Via http link pasted into browser:
http://openenergymonitor.org/files/emonSD-03May16.img.zip

Also Redirects to:
https://openenergymonitor.org/files/emonSD-03May16.img.zip

Tried this morning and indeed it stops after 1 Gb … isn’t there a cap on download in ftpd ?
No problem to relaunch and continue the download.

Ok, I have just been able to replicate the issue at work. Very strange. I have posted an alternate server mirror download link as an alternative. Is anyone able to host another mirror for us? Ideally in the USA? @Bill.Thomson?

I will have to investigate. I think the issue is could be due to HTTPS and cloudflare.

Have you considered using GitHub’s LFS?

ok, I think issue should be fixed. I created a page rule on Clodflare to disable caching in the /files folder. I have just been able to complete a download at work.

No, but looks interesting. I don’t think it would have helped solve this issue but would be since we could host the large image file on a remote server while tracking changes for the image file in the emonPi repo on github. I will have a go at setting this up.

Nope :confused:, still stops at around 1GB.

Would you mind trying again?

I’ve just white listed cloudflares IP addresses which act as a proxy. I think our web server thought it was under attack do the high volume of traffic funnelled through these IP’s. They should now be white listed so should not be limited any more.

1 Like

Working on it. We changed hosts, and for some reason, I’m not (yet) able to get it working (permissions issue) Will let you know when it’s ready.

Issue resolved. files are available via both HTTP and FTP from the USA mirror. HTTP link and FTP info are at the top of this thread.

1 Like