Emonpi won't boot after full update


Yesterday I ran a full update on my Pi which has been working fine for ages. I then shut it down to change the power supply and now it won’t boot (yes I’ve tried the old supply and two others).

I get Emonpi V2.92, then it finds the AC wave and 2 CT’s, sometimes tells me it can’t find and temp sensors, then briefly goes to ‘booting…’ before rebooting again. During all this, the screen in flickering and sometimes goes dark, sometimes it doesn’t even make it past the AC wave screen.

Any ideas?

Thank you

That’s a message from the “Emon” analogue part, and it sounds as if there’s might be a problem with it starting up, so the watchdog fires and it reboots itself.

Roughly how long is

Does the Pi (as distinct from the front end) boot and generate a web page to log in?

Hi Robert, thanks for the swift reply.

It was up and running for well over 6 months, I forget when I last turned it off. I only did this time because I wanted to swap the power cable (I have tried the original again with the same result, its not the power cable).

I’m afraid there is no webpage, it never gets far enough in the boot. It’s only going for maybe 5 seconds before it restarts.

Your emonPi then is about 6 months old?

The only thing I can suggest is your full update did not complete properly. This is the second similar problem in the same number of days, it’s either a strange coincidence, or I wonder whether there’s a problem with the latest update? I think it’s one for @TrystanLea and/or @glyn.hudson to look into.

Hello @Bigalboyo sorry about this I know it’s a real pain. After running the update, did it appear to have completed correctly? Where you able to navigate around emoncms before you shut the pi down?

If you have a monitor with a HDMI connection you could perhaps try plugging that into the pi to see how far it gets in it’s boot up sequence and if it presents any errors. Let us know if you see anything.

If that’s not possible the quickest way to get back up and running would be to burn the latest emonSD image to a new SD card and import your existing data onto that using the " Import using a USB SD card reader" process given here Import / Backup - Guide | OpenEnergyMonitor.

The similar problem: EmonPi - Local emonCMS not getting data

Thanks @Robert.Wall reading now

FWIF, I’ve just powered up my 433 MHz emonPi and let it self-update, which happened as expected (but it probably had a newer version than either of these two users).

(Of course, the Inputs didn’t update because I’ve set emonHub up to receive emonPiCM, and it replaced that with the stock front end V2.92. Easily reloaded though.)

Hi All,

Thank you all for your input here, I believe I have narrowed it down to a power issue.

When I plugged the monitor in, I took several videos to see where it was failing and it wasn’t always failing at the same point, it just kind of faded out. Then I noticed the little lightning bolt up the top of the screen so I tried another power source, same end result but again, different failure point.

I have an official Pi power source on another project but it has a USB micro, not mini, connection (my Emonpi has a micro, not sure if they still do?). Since it was out of its case, I connected the official power source to the power input on the Pi board rather than the other one and boom, it’s up and running again.

I’ve been using the same power supply (not an official Pi one) on this board for years now with no issue, it’s only after the last update that it started to fail.

I’m going to try to find an official Pi power with a USB mini connector (or a micro / mini converter) to see what happens when I plug it into the normal power input.

Thanks again for your input, I’ll update you with what I find out.


Is the USB cable attached to or separate from the power supply? If it’s separate, it could be the cable has a bit too much resistance (i.e, it was a cheap one).


So apparently I can’t get a USB micro to USB mini converter or a Pi power supply with USB mini on it anymore.
I’ve used the cable I used to use and it is booting up OK but with the under-voltage warning.

So, my options here are to keep it running as it always has been on a non Pi power source using the current cable with an under-voltage warning, or drill a hole in the side of the Emonpi casing to allow me to plug an official Pi power supply into the power input on the Pi.

What would be your advice?

Thanks again

Have you measured the actual voltage on-load?

The official advice is to use the mini-USB connector on the Shield (the “emon” part), but I’m not sure of the reason for that - maybe only because The Shop sells the 5 V d.c USB adapter and the Mini cable, and to be compatible with the emonTx. (And of course, hasn’t the position of the socket on the Pi changed over time?)

My thoughts are headed in the direction of a free USB Micro socket (except I don’t think one is available) and wires to the GPIO connector on the Pi. SMT Micro USB sockets are readily available, but that’s hardly practical.
But I’ve just spotted breakout boards with a micro USB socket - that’s worth consideration.

But there’s one thought bugging me - why has this problem shown up after a software update? I can’t imagine the Pi is working that much harder, but maybe it was on the edge anyway.

I’ve not measured the load, I’m not too sure I know how to do that? Do I just put an ammeter across two of the solder points on the USB mini connection to the shield?

The update side of things is a coincidence. I ran the update for the first time in months then turned it off to move the Emon, in doing so, swapping the cable for a shorter one. I didn’t even consider the cable could be the issue since the update seemed far more plausible.

It seems to be working fine with the power going into the USB micro on the Pi directly. I have no idea if that changes anything about the way it works though. That’s way above my pay grade.

The only Pi power supplies I seem to be able to get where I am (New Zealand) have the cable as part of the transformer, not just a USB to plug a cable into. I’ll have to have a hunt around to see if I can find one.


With a certain degree of difficulty if you can’t break into the circuit. An ammeter is always in series, never ACROSS the supply.


You could PM @Gwil to see who our supplier is. (i.e. no point in shipping one from Aus to the UK and back again to NZ.)

Awesome, thanks for that. I’ve read somewhere it should be a switching supply, not that I know what that is of course.
So far I’ve been using a 5v 2amp one that I got with a Garmin device and I’ve tried one built into a wall socket too.

I meant multimeter for measuring the voltage sorry. I’d put that across two terminals wouldn’t I?


Yes, that’s part is right. But it would only tell you why the voltage was low if you first measured without the Pi, then with it working. But even that might not be very helpful.

It need not be a “switched mode” - to give it the proper name - supply, but it probably will be, most modern power supplies are.

The switched mode power supply works by chopping up the current in order to vary the average that passes through - the shorter the ON time, the lower the output (and vice versa), then filtering that to give a smooth output. (A bit like watering plants - most people tip a lot of water on every few days, but you could pour a thin trickle on continuously.) The problem with a switched-mode power supply is, if there isn’t adequate smoothing, you get the remnants of the switching in the output, they get everywhere and eventually some will get measured and you see a false power reading even when you should have zero.

What power supply have you been using? Power supplies purchased from OpenEnergyMonitor have a 22 AWG min-USB cable and 2A USB adaptor.

See the attached image for the power supply I’ve been using.

Just stumbled across this thread as I was just about to do a full update :grimacing:

When you get your Pi running @Bigalboyo, maybe just check if you are / have been having a problem with your power:

sudo journalctl | grep -i voltage

I bought the OpenEnergyMonitor PSU with my EmonPi (years ago), but I’m seeing errors in the journal:

Under-voltage detected! (0x00050005)

I don’t know whether that error was showing from day 1, but I seem to recall (unverified) that the voltage detection was “improved” at some point in the past - so perhaps updates to the OS are now pushing the PSU to the limit?

Maybe you’ll need a power supply with 2.5A output… or even 3A?

(Just to add… I’m going to look to upgrade my PSU)

In addition to that, the sharp rise/fall time of the chopper generates RFI which can extend into the
HF (and even the VHF) region of the spectrum.