Community
OpenEnergyMonitor

Community

emonGLCD Time stamp wrong

(chris_cronin) #1

Both my local emoncms & emoncms.org graphs show the correct time at the latest daily data plot (@ 17:57) but the emonGLCD shows 16:57. I set the time zone to Europe/London (GMT +1:00) from UTC

0 Likes

(Brian Orpin) #2

The browser based views, use the time zone set for the user.

I’m not sure if the GLCD uses the underlying system/OS time. If you look at the administration page in the Server section, I think the time there is the underlying system/OS time.

Is that correct?

0 Likes

(chris_cronin) #3

I thought the emonGLCD got the time from the internet but I don’t know which time zone it uses.
I’ve tried using UTC & Europe/London +1:00 but the same time appears on the GLCD. All clocks on my charts & PC show the correct time.
I even tried changing the time in ‘My profile’ to Europe/Gibraltar +2:00 with no change to the GLCD time so it appears the the time adjustment option there doesn’t work

0 Likes

(Robert Wall) #4

It does, but indirectly, via the “base”, which in your case is the emonPi. So somewhere in the emonPi, the wrong time is being picked up and sent to the GLCD.

0 Likes

(Brian Orpin) #5

As I said, the charts etc use the timezone set in your user account / browser.

I suspect the GLCD uses the system /OS time which is not set by your profile.

You can copy the server info via the button in the admin page and then paste it here (no further formatting required).

[edit] I recently found that the timezone in my EmonPi was not set correctly.

0 Likes

(chris_cronin) #6

How do I go about changing it in emonpi?

Which OS is this?

0 Likes

(Brian Orpin) #7

Can you do this?

0 Likes

(chris_cronin) #8

I don’t understand this comment!

0 Likes

(Brian Orpin) #9

Under the settings menu, you will see administration
image

Can you please click on this button (on the same page)
image
then paste the clipboard into a reply (no further formatting).

0 Likes

(chris_cronin) #10

I don’t have an ‘adminstration’ option on either my emoncms.org or emoncms.local

local%20setup org%20setup

0 Likes

(Brian Orpin) #11

You wouldn’t I think on the emoncms.org one. On the EmonPi, log out and log back in again. The menu goes when your user session expires.

0 Likes

(chris_cronin) #12

Thanks for that; see attached server info. I can see the time is wrong but how do I correct it?

Server Information
Services
emonhub Active Running
emoncms_mqtt Active Running
feedwriter Active Running - sleep 60s
service-runner Active Running
emonPiLCD Active Exited
redis-server Active Running
mosquitto Active Running
Emoncms Version low-write 9.9.8
Modules Administration : App v1.2.1 : Backup v1.1.6 : EmonHub Config v1.1.0 : Dashboard v1.3.3 : Device v1.2.1 : EventProcesses : Feed : Graph v1.2.3 : Input : Postprocess v1.0.0 : CoreProcess : Schedule : Network Setup v1.0.0 : sync : Time : User : Visualisation : WiFi v1.3.1
Git URL: https://github.com/emoncms/emoncms.git : Branch: * stable : Describe: v9.5.1-1775-gd0db7a57
Server OS Linux 4.14.71-v7+
Host emonpi : emonpi : (192.168.0.52)
Date 2019-04-07 17:05:03 UTC
Uptime 17:05:03 up 11 days, 2:14, 0 users, load average: 0.00, 0.00, 0.02
HTTP Server Apache/2.4.25 (Raspbian) HTTP/1.1 CGI/1.1 80
MySQL Version 5.5.5-10.1.23-MariaDB-9+deb9u1
Host 127.0.0.1 (127.0.0.1)
Date 2019-04-07 17:05:03 (UTC 00:00‌​)
Stats Uptime: 958832 Threads: 2 Questions: 648988 Slow queries: 0 Opens: 37 Flush tables: 1 Open tables: 23 Queries per second avg: 0.676
Redis Version 3.2.6
Host localhost:6379 (127.0.0.1)
Size
Uptime 11 days
MQTT Server Version Mosquitto 1.4.10
Host localhost:1883 (127.0.0.1)
Pi Model Raspberry Pi 3 Model B+ Rev 1.3 - 1 GB (Sony UK)
SoC Broadcom BCM2835
Serial num. 348CE155
Temperature CPU: 61.22°C - GPU: 60.7’C
Release emonSD-30Oct18
Memory RAM Used: 67.50% Total: 976.74 MB Used: 659.25 MB Free: 317.48 MB
Swap Used: 0.00% Total: 100 MB Used: 0 B Free: 100 MB
Disk Mount Stats
/ Used: 39.87% Total: 3.81 GB Used: 1.52 GB Free: 2.11 GB
/boot Used: 51.69% Total: 42.52 MB Used: 21.98 MB Free: 20.54 MB
/home/pi/data Used: 1.13% Total: 10.32 GB Used: 118.84 MB Free: 9.68 GB
PHP Version 7.0.30-0+deb9u1 (Zend Version 3.0.0)
Modules apache2handler : calendar v7.0.30-0+deb9u1 : Core v7.0.30-0+deb9u1 : ctype v7.0.30-0+deb9u1 : curl v7.0.30-0+deb9u1 : date v7.0.30-0+deb9u1 : dom v20031129 : exif v7.0.30-0+deb9u1 : fileinfo v1.0.5 : filter v7.0.30-0+deb9u1 : ftp v7.0.30-0+deb9u1 : gd v7.0.30-0+deb9u1 : gettext v7.0.30-0+deb9u1 : hash v1.0 : iconv v7.0.30-0+deb9u1 : igbinary v2.0.1 : json v1.4.0 : libxml v7.0.30-0+deb9u1 : mbstring v7.0.30-0+deb9u1 : mcrypt v7.0.30-0+deb9u1 : mosquitto v0.4.0 : mysqli v7.0.30-0+deb9u1 : mysqlnd vmysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $ : openssl v7.0.30-0+deb9u1 : pcre v7.0.30-0+deb9u1 : PDO v7.0.30-0+deb9u1 : pdo_mysql v7.0.30-0+deb9u1 : Phar v2.0.2 : posix v7.0.30-0+deb9u1 : readline v7.0.30-0+deb9u1 : redis v4.1.1 : Reflection v7.0.30-0+deb9u1 : session v7.0.30-0+deb9u1 : shmop v7.0.30-0+deb9u1 : SimpleXML v7.0.30-0+deb9u1 : sockets v7.0.30-0+deb9u1 : SPL v7.0.30-0+deb9u1 : standard v7.0.30-0+deb9u1 : sysvmsg v7.0.30-0+deb9u1 : sysvsem v7.0.30-0+deb9u1 : sysvshm v7.0.30-0+deb9u1 : tokenizer v7.0.30-0+deb9u1 : wddx v7.0.30-0+deb9u1 : xml v7.0.30-0+deb9u1 : xmlreader v7.0.30-0+deb9u1 : xmlwriter v7.0.30-0+deb9u1 : xsl v7.0.30-0+deb9u1 : Zend OPcache v7.0.30-0+deb9u1 : zlib v7.0.30-0+deb9u1
Client Information
HTTP Browser Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36
Screen Resolution 1920 x 1080
Window Size 2537 x 1263
0 Likes

(Brian Orpin) #13

You need to SSH into your EmonPi.

First you need to know which timezone you are in - it has to be the exact text https://en.wikipedia.org/wiki/List_of_tz_database_time_zones

This example is for my timezone *Europe/London

In your SSH session:

First, check the string you have is right e.g. (replacing europe/lon with a fragment of your timezone)

timedatectl list-timezones | grep -i europe/lon

to set the correct timezone (replace Europe/London)

sudo timedatectl set-timezone Europe/London

And to check it is now correct

timedatectl status

Hopefully that will solve the problem.

0 Likes

(chris_cronin) #14

I’m no coder so I don’t know how to do this; can you walk me through it?

0 Likes

(Brian Orpin) #15

By the fact you have an emonGLCD, I am suspecting you just have the Raspberry Pi version rather than the EmonPi (the 2 can be seen here to confirm).

Can you confirm what your system is?

I also see you have a 2018 version of the SDCard, did you create this yourself by downloading the image or did you buy a ready made card from the Shop?

0 Likes

(chris_cronin) #16

I have the Raspberry Pi version (emonBase?).
The SD card came with the unit 2 months ago from the shop

0 Likes

(Brian Orpin) #17

Can you attach a keyboard and monitor to the EmonBase?

0 Likes

(chris_cronin) #18

OK, done

0 Likes

(Dave Howorth) #19

FWIW, what you’re seeing is consistent with my shop-bought system from the back end of last year. i.e. the date is UTC.

0 Likes

(Brian Orpin) #20

So you should see what is called the command prompt. something like this.

image

If so type in the following and hit return

timedatectl status

beware, the case is important so TIMEDATE is different to timedate.

You should see something like this (not exactly the same).

      Local time: Sun 2019-04-07 20:58:34 BST
  Universal time: Sun 2019-04-07 19:58:34 UTC
        RTC time: n/a
       Time zone: Europe/London (BST, +0100)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no
0 Likes