Community
OpenEnergyMonitor

OpenEnergyMonitor Community

EmonESP Admin / Password reset?

Tags: #<Tag:0x00007fc9b13d3128>

I’m sure this has been done before, but I can’t seem to find a solution here in the forums. I have a brand new Emontx with the wifi module to use as a standalone power meter recording up to emoncms.org I started setup last evening, connected to my local wifi, added an admin name and pw and saved them to my password manager (it was actually quite simple and straightforward too, just to get up and rolling.) Today however, i am unable to log in! I get to the user/pw popup when going to that IP address but it won’t let me in!
I have tried also connecting via ssh but get a “connection refused” return.

Any help? Is there a hardware reset on the emontx to factory settings where I can start over? I haven’t really gotten very far

Thanks!
Jeff

Hi Jeff, are you referring to EmonESP Wifi adaptor?

There is no default password since authentication should be switched off at standard.

You could try and hold down the BOOT / GPIO0 button for about 10s when powering up the unit. This will force WiFi AP mode which should let you connect directly via WiFi. If this doesn’t work then you will have to manually clear the config. This will require a USB to UART programming cable.

Thank you very much! The reset button trick didn’t seem to work so looks like i’ll need the programming cable. I hate to ship one from overseas, is there anything special about this one or will any 3.3v usb-uart one from say amazon work?

Thanks again,
jeff

Best to use a 5V FTDI / UART cable since the Adafruit Huzzah has a on-board voltage regulator and level shifting on the UART pins. 3.3V may not work but I’ve not tested it. Yes, any FTDI cabe from Amzaon / ebay should work. Just check the pinout matches the one from the shop:

Thanks for your help. I was able to get the cable and get the emontx to receive firmware (wasn’t sure if I had to do that AND/OR the the Huzzah board, so i figured i’d do both) but I can’t seem to get the Huzzah board to take the EmonESP firmware.
I’ve tried several ways and attempts (hold down gpio0 during boot, same then pressing reset etc…)to get it into boot loader mode but each time I get the following error:

Auto-detected: /dev/cu.usbserial-A106TIYK
Uploading .pioenvs/emonesp/firmware.bin
Uploading 385792 bytes from .pioenvs/emonesp/firmware.bin to flash at 0x00000000
warning: espcomm_send_command: didn’t receive command response
warning: espcomm_send_command(FLASH_DOWNLOAD_DATA) failed
warning: espcomm_send_command: wrong direction/command: 0x01 0x03, expected 0x01 0x04
error: espcomm_upload_mem failed
*** [upload] Error 255
========================== [ERROR] Took 5.43 seconds ==========================

================================== [SUMMARY] ==================================
Environment emonesp_fast [SKIP]
Environment emonesp_ota [SKIP]
Environment emonesp_spiffs [SKIP]
Environment emonesp_deploy [SKIP]
Environment emonesp01 [SKIP]
Environment emonesp_staging [SKIP]
Environment emonesp_staging_libs [SKIP]
Environment emonesp [ERROR]
========================== [ERROR] Took 5.43 seconds ==========================

any tips?

Thanks,
Jeff

Nice work getting up and running, it looks like code is compiling ok using Platformio

I don’t recognise that USB programmer. What are you using?

I would recomend you erase the flash before uploading using:

$ esptool.py erase_flash

If you don’t need to change the FW you could download the FW and SPIFFS from the emonesp github releases page then upload both in one go using:

$ esptool.py write_flash 0x000000 firmware.bin 0x300000 spiffs.bin

You will need to install esptool:

Awesome thanks. The programmer is from Adafruit. I can’t get the esptool to work. I’m on a Mac though I have ubuntu running in a vm. I’m just a dumb mechanical engineer so if it doesnt work the first time i’m pretty lost! I did pick up a second Huzzah board too to see if I could get THAT to program but I get the same error, so maybe its the programmer?

Either way i’m going to do the following:

  1. Give this to my intern at work to sort out, he’s pretty smart
  2. Buy a new wifi board from the site and start over that way
  3. Just get the emonpi and use the emontx as just a sensor node…

All of this really makes me appreciate the smarts and knowledge that go into all of this!