Emoncms running on own Server

Following the guides in Openenergy monitor , i ready installed Emoncms in my own Server
But i cant get data from my local emoncms ( emonpi )
and appear some nodes that i never config before with some data on it

the feeds stuck on getting data

Config in Emoncms

did yo use the read api or the write api ? It should be the read one
the other nodes could be just garbage, just delete those. If connection works, the correct node will add itself

im using Read API , but still dont work

This is causing confusion, data doesn’t come from emoncms, it goes to emoncms. even on the emonPi data is directed to a local emoncms and/or a remote emoncms by emonHub.

If I understand correctly, you have a emoncms server set up on AWS, which is not being updated from your local emonpi, is that correct?

If so you must use the readwrite apikey as your local emonHub is writing data to the remote emoncms, that is not possible with the readonly apikey.

What response is emonHub getting when posting to emonCMS, can you check emonhub.log on the local emonPi?

Are you able to restart your remote emoncms instance?
Not only is the feeds page not populating or the inputs updating but there is also a “wait…” message in the processlist area of Node 19 which is odd if you never created these inputs as where would a processlist have come from and why isn’t it populating?
Do you have access to the mySQL tables and myphpadmin installed?

Hi Paul
i just follow the instructions here

Yes i install a emoncms on AWS

yes i m using Read Write Api from my emoncms server

Emonhublog (emonpi)

But i had this in remote emoncms log ( server)

Yes i restarted my emoncms remote instance, nothing change
Yes i have acces to mysql and myphpadmin

That last log from “remote emoncms log ( server)” is not emoncms it is emonhub! It’s called emonhub.log and it even has “Emonhub Pre-release Development version (rc1.2)” in the log to identify itself.

I See no reason for you to be running emonhub on the remote instance, but that doesn’t mean you can’t, there may even be a specific reason for doing that but it will not get access to a serial port on an AWS server, of that we can be pretty sure. That’s why it is reporting it cannot find the serial port.

If you want to keep emonhub on the remote for another reason, that’s fine but you should disable the [[RFM2Pi]] interfacer.

The 2nd log, from the local emonPi it short and a screendump, can you log in to the Pi directly or via ssh and search for any sign of “emoncmsorg” interfacer activity, that centre column in that pic that just shows “RFM2Pi” on every line denotes the interfacer the log entry belongs to, your “snippet” of emonhub.conf from a few posts back looks like you have named the interfacer “emoncmsorg”.

Perhaps you could restart emonhub on the local emonPi using sudo service emonhub restart and post the log that is produced? that will show if the “emoncmsorg” interfacer is being created or not.

Please also confirm you only have one [[emoncmsorg]] in your local emonhub.conf.

i m confused
i install this : GitHub - emoncms/emoncms: Web-app for processing, logging and visualising energy, temperature and other environmental data on my remote server AWS

nothing change i think


anyway i think my emonpi dont work ok
if we check the data in emonhublog [local] appear

very out of date

after upgrade emonpi
i get this imputs in emoncms remote ( AWS server) , the process to add feeds its the same,like emoncms.org ?

Good news!

Yes it is pretty much, but there are also more types of processor and a wider range of feed types possible.

its very strange why sometimes the option Administrator appear in setup menu other times no
from there update the emonpi

how can

there is a guide with all this new processes what that means ?


Have you setup more than one user? It sounds like sometimes you are logged in as user1 with admin rights and sometimes as another user without admin rights.

i only have one user

what do you think about the config in emoncms server ?

Sorry, I’m not sure what you are asking here.

The admin menu is only there if the user is an “admin” which is defined by a single field in the user table, i’m unsure how that can change. You could try clearing your cache ???

thanks the admin issue was solved

im asking about what would be the issue about this images
in my server emoncms is not taking data from emonpi
i ready made the configs
exist a guide for this new process available to add in feeds ?
the process to add feeds is not working
this is my emoncms server runing in aws that i mentioned before

Can you show us your feeds page?
Do those actually feeds exist?
What type feeds are they?

Have you got the correct ownership and permissions for the php feed datadir’s? location is set in settings.php.

That is by design. The administration menu option should only be available during the current login session, otherwise it’s hidden.
Introduced in emoncms v9.
(I would have expected the api keys to be included within ‘administration’ instead of ‘My Account’…)


hi paul ,
that images are from my emoncms remote ( AWS ) server
do you need from local emonpi too ?
that are the feeds , appear to config in emoncms remote , in the guide of open energy monitor appear as main feeds to config ,
Log to Feed - Power 1
Power to kwh - Power 1
Log to Feed - VRMS ACAC 9v
i asume its the same config feeds for emoncms remote ( emoncms.org ) than my emoncms server ( AWS ) if the emoncms its the same installed , i just follow the guide

Have you got the correct ownership and permissions for the php feed datadir’s? location is set in settings.php. ( about this what kind of permission-ownership i should add ? )


hi paul

what you mean with this
(I would have expected the api keys to be included within ‘administration’ instead of ‘My Account’…)
i try booth keys but dont working when i trying config feeds

Following the topic

i would like to solve the issue about getting feeds config on my emoncms remote server

Following the instructions i ready set up a emoncms server
inputs are getting data , but when i try to set up feeds for inputs , its stuck on wait message
if this could be a protocol or receiving data issue , the inputs are not receiving any data too , but its getting values from my emonpi

Starting a new thread with the same issue will not get it resolved any sooner.

You haven’t answered these questions yet. Show us the Feeds page so we can see these feeds exist and what type they are.

Where are your datadir’s ?
In settings.php, what is the address for those datadir’s?
can you show us the output from ls -la /path/to/my/datadirs/php*

I am referring to the remote install and only the remote install at this time, that is the only part of interest if the inputs on the inputs page (of the remote install) are updating.